Squeaking noise when I get out of the car - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-06-2009, 11:46 AM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1992 190E 2.3L
Location: Palo Alto, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to rsteckly
(Thread Starter)
Squeaking noise when I get out of the car

Hi,

So I've been posting a lot lately (sorry). I've gone through a first round of repairs and am trying to get the car to a good, stable point to regroup.

Its not a major problem but its kind of embarrassing.

I notice that when I get out of the car, there is this squeak coming from the rear. Its almost as if there are springs in the car that are worn or need some kind of service. Has anyone else had this problem? I'm not sure what they do, but could it be the coil springs need to be replaced?

Thanks,

Ron
rsteckly is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-06-2009, 01:55 PM
BenzWorld Elite
 
shingleback's Avatar
 
Date registered: Apr 2006
Vehicle: '98 E300, '03 3.2TL-S 'A-Spec', '92 S500 (sold), '87 190D 2.5 Turbo (RIP)
Location: Vancouver, Canada
Posts: 1,236
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had some strange squeaks from mine, and it turned out to be one of the rear shocks.
shingleback is offline  
#3 (permalink) Old 02-06-2009, 02:06 PM
BenzWorld Veteran
 
importfan21's Avatar
 
Date registered: Apr 2008
Vehicle: 1998 C43 AMG
Location: Washington DC & Delaware
Posts: 692
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yeah, I've had squeaks come from the suspension when I get in/out sometimes or I push down on it repeatedly. Just normal I guess. Now if you hear a groan....that's trouble.

1998 C43 AMG, 187k miles (DD)|1992 190E 2.3, 162k miles (SOLD)|1984 190E 2.3 (SOLD)
importfan21 is offline  
#4 (permalink) Old 02-07-2009, 05:39 PM
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 518
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Maybe get a can of Silicone spray and spray some of the bushings until you hit the magic one. ....I heard the same squeak getting out of my car today!
Ignatz is offline  
#5 (permalink) Old 02-08-2009, 06:26 AM
BenzWorld Elite
 
Turnpike's Avatar
 
Date registered: Mar 2008
Vehicle: '87--190E 2.3-16v, '92--300TE 4-Matic
Location: Lower Slower Delaware
Posts: 3,422
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
considering that most of the cars we all have are close to being 20 years old, a squeak here and there is to be expected
Turnpike is offline  
#6 (permalink) Old 02-08-2009, 09:26 AM
BenzWorld Member
 
tnez190e's Avatar
 
Date registered: Dec 2008
Vehicle: 1988 190e 2.3 8v 5spd- manual
Location: Bronx, NY
Posts: 230
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to tnez190e
I get that noise sometimes too, but with a nice car wash it fixes the noise, the times I've heard it was during the snow times...

Don't know if this would work... But hope it helps, good luck.
tnez190e is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Squeaking Noise benzW140 W140 S-Class 2 05-26-2007 05:22 AM
Squeaking Noise!! benzW140 General Mercedes-Benz 1 05-25-2007 01:59 PM
Squeaking Noise?? bcaese W163 M-Class 7 03-12-2007 08:33 PM
Squeaking noise BBALLER14 W220 S-Class 3 06-09-2006 03:36 PM
squeaking noise? acbenz W208 CLK Class 2 11-30-2005 03:05 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome