ABS light stays on - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-12-2009, 11:03 PM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1992 190E 2.3L
Location: Palo Alto, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to rsteckly
(Thread Starter)
ABS light stays on

My abs light is on all the time. Do you guys know what that means and what to check for it? I replaced my brakes but didn't change any sensors or anything...

Ron
rsteckly is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-12-2009, 11:21 PM
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 62,237
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 165 Post(s)
Lifetime Premium Member
Most likely your OVP relay (Over Voltage Protection Relay)
DP is offline  
#3 (permalink) Old 01-12-2009, 11:32 PM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1992 190E 2.3L
Location: Palo Alto, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to rsteckly
(Thread Starter)
What is the OVP?

When I changed the brakes, I didn't change the sensors...could that be it?

Where is the OVP--how can I fix it?

Ron
rsteckly is offline  
#4 (permalink) Old 01-12-2009, 11:47 PM
DP
Moderator
 
DP's Avatar
 
Date registered: Aug 2002
Vehicle: 190E, 400E, SLK350
Location: Chesapeak Bay
Posts: 62,237
Mentioned: 0 Post(s)
Tagged: 2 Thread(s)
Quoted: 165 Post(s)
Lifetime Premium Member
ABS light on has nothing to do with the sensor pads but it could with the ABS sensors.
As to the OVP you are better off replacing it rather than fixing it. On mine, a 2.3L, the OVP is behind the battery hidden by a plastic cover.

This is what an OVP looks like


Location
DP is offline  
#5 (permalink) Old 01-13-2009, 10:42 AM
BenzWorld Extremist
 
355190E26's Avatar
 
Date registered: Oct 2007
Vehicle: 1989 190E 2.6 (diamond blue metallic), 1989 190E 2.6 (blue green)
Location: Bay Area, CA
Posts: 1,086
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
If you've recently tried to jump start your car you could have fried the OVP. Several friends of mine who own Benzes have had to replace theirs after jumping their car.

#1. 1989 190E 2.6 fun car 355 Diamond Blue Metallic, euro spec goodies, Borbet wheels, Koni shocks, Brabus W124 springs, Stromung exhaust and much more

#2. 1989 190E 2.6 Daily Driver 877 Blue Green metallic, Euro headlights w/ HID projector, 15" AMG monoblock wheels, tinted windows.
355190E26 is offline  
#6 (permalink) Old 01-13-2009, 11:28 AM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1992 190E 2.3L
Location: Palo Alto, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to rsteckly
(Thread Starter)
I did jump start it, but its been on since I bought it...

Hi,

Well, I've owned this car for a month and since I've owned it the ABS light has been on...I have had to jump it twice since I've owned it because the battery died...but again, it was on since I've owned it.

I'll replace the OVP...although I had trouble finding it on autopartswarehouse.com...a google turned up a universal one that I'm not sure will work.

Ron
rsteckly is offline  
#7 (permalink) Old 01-13-2009, 11:37 AM
BenzWorld Elite
 
slk230red's Avatar
 
Date registered: Mar 2004
Vehicle: '01 SLK230,'93 190E 2.3, 1971 LS5 Corvette Convertible
Location: Tampa, FL
Posts: 1,890
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by rsteckly View Post
Hi,

Well, I've owned this car for a month and since I've owned it the ABS light has been on...I have had to jump it twice since I've owned it because the battery died...but again, it was on since I've owned it.

I'll replace the OVP...although I had trouble finding it on autopartswarehouse.com...a google turned up a universal one that I'm not sure will work.

Ron

Why not check the fuse on top first?

slk230red is offline  
#8 (permalink) Old 01-13-2009, 11:43 AM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1992 190E 2.3L
Location: Palo Alto, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to rsteckly
(Thread Starter)
Don't know how to tell if a fuse is gone or not

I would but I'm not sure how to tell...I showed the fuses to a mechanic who said they were fine...how can you tell if a fuse is gone (you are talking about the fuse box, right?)

Ron
rsteckly is offline  
#9 (permalink) Old 01-13-2009, 11:47 AM
BenzWorld Elite
 
slk230red's Avatar
 
Date registered: Mar 2004
Vehicle: '01 SLK230,'93 190E 2.3, 1971 LS5 Corvette Convertible
Location: Tampa, FL
Posts: 1,890
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by rsteckly View Post
I would but I'm not sure how to tell...I showed the fuses to a mechanic who said they were fine...how can you tell if a fuse is gone (you are talking about the fuse box, right?)

Ron
Hi Ron,

No, on top of the OVP Relay you either have 1 or 2 fuses...look at the photo in post #4. The best way to check the fuses it to do a continuity check with a VOM. Usually you can tell by looking at the fuse to see if the link is broken.
Have you located your OVP Relay behind the battery? You can open the lid and pull the fuse out without removing the relay.
Another tip, if you pull the OVP Relay out of the socket, it probably won't go back in fully seated unless you somehow hold the bottom of the socket while pushing in the relay.

Dave


Last edited by slk230red; 01-13-2009 at 11:52 AM.
slk230red is offline  
#10 (permalink) Old 01-16-2009, 04:35 PM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1992 190E 2.3L
Location: Palo Alto, CA
Posts: 101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to rsteckly
(Thread Starter)
Its off for now...but I'm not sure I replaced the right thing

Hi,

So I went to Kragen to try and find the right fuses...had to buy several emergency fuse kits for $3.99 each because they only came with one blue fuse each...but I have plenty of spares now!

In any case, I took a photo of what I think was the OVP relay. Its the thing in the little black plastic case right below the fuse box (I think). Both of those black boxes below the fuse box have two blue fuses each. I replaced the fuses in both.
Attached Thumbnails
Click image for larger version

Name:	012.jpg
Views:	808
Size:	83.3 KB
ID:	215866  
rsteckly is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ABS light stays on c220guy W202 C-Class 14 03-23-2009 10:16 AM
ASR and ABS indicator light stays on, on my 93 SL500 Strick9 General Mercedes-Benz 0 10-17-2008 04:06 PM
ABS light stays on ... need help desperately Roughneck G-Class 5 05-22-2006 07:34 AM
ABS LIGHT STAYS ON, 1988 300TE gdeniro W124 E,CE,D,TD Class 6 09-02-2005 09:49 AM
abs light stays on tigger W220 S-Class 2 07-17-2004 10:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome