rough idle, low power, injectors? - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-22-2008, 09:06 AM   #1 (permalink)
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: 1985 500SEL euro (SOLD), 1984 190d, 1996 S600
Posts: 51
Send a message via AIM to benzrider85
rough idle, low power, injectors?

My '84' 190D 2.2 has a pretty bad shake in idle, and I know this car is slow, but I think I'm missing some power as well. When I put the A/C on, the idle gets worse and the car barely has enough power to drive. I have replaced the fuel filters, and the fuel tank screen has been cleaned. I have what I believe to be most of the service records for the vehicle and I can't find any with fuel injector service. After 247,000 miles, would be a good idea to try replacing these next? Thanks for the advice!
benzrider85 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-22-2008, 10:20 AM   #2 (permalink)
BenzWorld Member
 
Saltyal's Avatar
 
Date registered: Jan 2008
Vehicle: 1984 190D: 2.2 5-speed, well over 500,000 kilometres
Location: Salt Spring Island
Posts: 83
did you check the air cleaner too?... more than a few folks have suffered the embarassment of having their mechanic "tune up" the engine by changing the element ....... If those injectors are the originals you'd probably see some improvement with new ones in power, smoke etc; I changed mine a couple months ago & glad I did...
BTW, its also worth checking your engine mounts & shocks (including the one on the belt tightener) as they help reduce the shake a lot...
__________________
this message uses 100% recycled electrons
Saltyal is offline   Reply With Quote
Old 04-22-2008, 10:29 AM   #3 (permalink)
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: 1985 500SEL euro (SOLD), 1984 190d, 1996 S600
Posts: 51
Send a message via AIM to benzrider85
thanks for the info, air filter is new as well. I know the mounts were changed about 100k ago, they may need replacement again. Is there a write up on changing the injectors somewhere online?
benzrider85 is offline   Reply With Quote
Old 04-22-2008, 10:50 AM   #4 (permalink)
BenzWorld Member
 
Saltyal's Avatar
 
Date registered: Jan 2008
Vehicle: 1984 190D: 2.2 5-speed, well over 500,000 kilometres
Location: Salt Spring Island
Posts: 83
I'm sure if you did a search you'll find a write-up, but its not a complicated job.... clean up around the injectors & lines real good, remove rubber return lines,(maybe a good time to replace these too) release the clips holding the steel lines together, undo the nuts holding the lines @ the injectors, you'll be able to SLIGHTLY bend the lines aside, then simply unscrew the injectors out of the head....
Clean up the injector seat real good with rags, wire brush & vacuum cleaner.... I re-used the crush washers without problem (down in the seat) but you should probably replace them if you can... Torque the new injectors in & hook up all the lines again & Bob's yer uncle.... mine took a few extra seconds of cranking to purge the air & start the first time after that, but no big deal.... she's sweet now!
Saltyal is offline   Reply With Quote
Old 04-22-2008, 10:53 AM   #5 (permalink)
IR MODERATOR
 
Jippi's Avatar
 
Date registered: Aug 2002
Vehicle: 1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Location: somewhere in NJ or PA
Posts: 9,194
Lifetime Premium Member
Send a message via AIM to Jippi Send a message via MSN to Jippi
seafoam the car and call it a day....
__________________

1993 MB 190E 2.3 105k- its alive.. 1996 Volvo 855 GLT-R 350k still rolling
1998 Subaru Outback SUS 210k- Daily Driver 2011 Toyota Camry XLE 36k
1991 BMW 525I stock as stock gets 98k (Wrecked) 1998 MB C230 209k possessed by the devil
Benzworld.org---Tri-State Crew
Jippi is offline   Reply With Quote
Old 04-22-2008, 11:16 AM   #6 (permalink)
BenzWorld Member
 
Saltyal's Avatar
 
Date registered: Jan 2008
Vehicle: 1984 190D: 2.2 5-speed, well over 500,000 kilometres
Location: Salt Spring Island
Posts: 83
Yeah, a clean ride is a good ride.......
Saltyal is offline   Reply With Quote
Old 04-22-2008, 02:54 PM   #7 (permalink)
BenzWorld Elite
 
AMGViper's Avatar
 
Date registered: Sep 2006
Vehicle: SLR
Location: Work
Posts: 1,348
Send a message via AIM to AMGViper
It could be numerous things. I killed mine after replacing

-engine mounts
-tranny mounts
-engine shock
-bent tensioner
-acc. belt damper
-acc. belt

The engine shock really helped as the old damper was able to move freely up and down
AMGViper is offline   Reply With Quote
Old 04-22-2008, 03:43 PM   #8 (permalink)
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Before replacing parts, have the motor checked out, particularly the valves and cylinder compression. It would be nice to know if the car is running on all those diesel cylinders.
MTI is offline   Reply With Quote
Old 04-23-2008, 07:49 AM   #9 (permalink)
BenzWorld Elite
 
shingleback's Avatar
 
Date registered: Apr 2006
Vehicle: '98 E300, '03 3.2TL-S 'A-Spec', '92 S500 (sold), '87 190D 2.5 Turbo (RIP)
Location: Vancouver, Canada
Posts: 1,234
While the car is idling, crack the fuel line nut at each injector (or at the inj pump), one at a time, to see if it makes a difference in the way it idles. This is the equivalent of unplugging a spark plug wire at a time in a gasser. This will help you determine if one of the cylinders is not igniting due to a problem with the injector or pump.
shingleback is offline   Reply With Quote
Old 04-23-2008, 08:01 AM   #10 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2008
Vehicle: 1985 190E 2.0lt
Location: Melbourne, Australia
Posts: 40
crap idle

don't know much about the 190D but can tell you about the 190E, Had the same problem, check all hoses to inlet manifold, ignition coil, dist box, leads and spark plugs. Had what sounds like a very similar problem with my 190E, did all this myself for minimal cost and is now all good.
Don't know if that helps with 190D soon find out??
Cheers Paul
rgbenz is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Low idle, rough idle, stalling, hot and cold start solved: E320/300 rvenerac W124 E,CE,D,TD Class 10 03-22-2010 11:28 PM
runability and rough idle, low oil pressure...video Digital K W126 S,SE,SEC,SEL,SD,SDL Class 21 11-25-2007 11:42 PM
95 S 320 Rough Idle and low power Pedsdmd W140 S-Class 11 09-10-2007 09:22 PM
low fuel(quater of a Tank) = rough idle and stalls S3201994 W140 S-Class 6 02-05-2007 05:11 PM
ROUGH IDLE AND LOW RPM STUMBLING DDEWSBURY W126 S,SE,SEC,SEL,SD,SDL Class 5 02-06-2004 01:58 PM


All times are GMT -7. The time now is 09:49 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.