climate controls - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-24-2008, 11:49 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
climate controls

I have a 1986 190E and the climate controls stopped working. The fan switch also is not working. When you start the car the climate control buttons will light up. However when you turn on the headlights the lights on the climate control panel will go off. At the present time heat is coming out of the defroster however you cannot control the heat level since the temp dial will not adjust the heat level. I did a search on this but didn't find anything relating to the lights.
zeke33 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-24-2008, 12:52 PM
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like multiple problems.

You should probably check the heater valve, on the engine side of the firewall and the auxillary coolant pump near the coolant expansion tank and wiper fluid reservoir.

To check the fan speed switch and HVAC controller, you'll need to remove them from the center console. The HVAC controller has a separate fuse mounted in the rear corner that may be at issue.


Last edited by MTI; 03-24-2008 at 12:55 PM.
MTI is offline  
post #3 of 4 (permalink) Old 03-25-2008, 10:02 AM
BenzWorld Elite
 
shingleback's Avatar
 
Date registered: Apr 2006
Vehicle: '98 E300, '03 3.2TL-S 'A-Spec', '92 S500 (sold), '87 190D 2.5 Turbo (RIP)
Location: Vancouver, Canada
Posts: 1,240
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by zeke33 View Post
I have a 1986 190E and the climate controls stopped working. The fan switch also is not working. When you start the car the climate control buttons will light up. However when you turn on the headlights the lights on the climate control panel will go off. At the present time heat is coming out of the defroster however you cannot control the heat level since the temp dial will not adjust the heat level. I did a search on this but didn't find anything relating to the lights.
When my car did this I found a disconnected vacuum line under the hood, on the left wheel well.
shingleback is offline  
post #4 of 4 (permalink) Old 03-27-2008, 10:02 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
When I did a search some models had a 30 amp fuse in the engine comparment. Does the model have this fuse and if so where is it located?
zeke33 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Climate controls B200T W245 B-Class 5 11-15-2007 12:43 PM
    Remove Climate Controls fun 380 R/C107 SL/SLC Class 6 07-23-2007 12:53 PM
    Climate controls for a 280CE Bev W123 E,CE,D,CD,TD,TE Class 0 11-22-2006 06:13 AM
    hot climate controls yellobenz W123 E,CE,D,CD,TD,TE Class 3 04-22-2005 09:45 PM
    Light behind Climate controls is out Marc W163 M-Class 3 07-17-2002 02:04 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome