Location of Fuel Filter on 190E 2.3 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-20-2006, 06:04 PM
BenzWorld Newbie
 
Date registered: May 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Location of Fuel Filter on 190E 2.3



My Benz Runs at high RPM's only. Caughs, spits and pops and will not idle. Before it began doing this it ran rough for two weeks, lacked power at initial acceleration and then ran clean at highway speeds. I get the feeling it is the fuel filter???? Can anyone give me some insight into this problem and I'd like to know the location of the fuel filter itself....yep....I'm a nooob!!!

thanks,

Rick
RicoDirenzo is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-20-2006, 06:33 PM
BenzWorld Elite
 
jdc1244's Avatar
 
Date registered: Jun 2003
Vehicle: 1991 300 SE
Location: Lakeland, Florida
Posts: 18,534
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's under the car, passenger side forward of the rear axle in a container with the fuel pump.

But it sounds like you've got more issues than just a dirty filter.
jdc1244 is offline  
#3 (permalink) Old 05-20-2006, 06:40 PM
BenzWorld Newbie
 
Date registered: May 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Any Suggestions....Sounds like I need to spend some shop money>?
RicoDirenzo is offline  
#4 (permalink) Old 05-20-2006, 06:49 PM
BenzWorld Elite
 
jdc1244's Avatar
 
Date registered: Jun 2003
Vehicle: 1991 300 SE
Location: Lakeland, Florida
Posts: 18,534
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
No, sounds like you need to check the cap/rotor/plugs and wires.
jdc1244 is offline  
#5 (permalink) Old 05-20-2006, 11:28 PM
Moderator
 
Date registered: Mar 2004
Vehicle: Amethyst 2001 C320
Location: Austin, TX
Posts: 1,697
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lifetime Premium Member
By the way, welcome to the forums!
n0alpha is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome