BAS ESP A160 - HELP!!!!! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-27-2010, 03:44 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2010
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy BAS ESP A160 - HELP!!!!!

Hi all new to this site I bought my A Class a few weeks ago with 50K on the clock. My first Mercedes. Been experiencing problems with my A160 - BAS ESP light flickers on/off and the car completely loses all power, no response from gearbox, press down on accelerator, no response. Car doesn’t even idle no revs just completely shuts down. It comes magically back to life when I restart the car. Happened in traffic on the motorway - shifted from 5th to 3rd to 1st, car powered down and I broke slightly to a stop. Lifted up on the accelerator and the BAS light came on, could hear the car struggling and the car shut down.
I really enjoy driving my A-class but after reading the vast array of problems that this could be I’m at a complete loss to where I start in trying to rectify this - should I take it to MB to solve, or can anyone help me diagnose a solution to this recurring problem that’s driving me crazy. HELP!!!!!
Bhav101 is offline  
Sponsored Links

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W168 A-Class

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    A160 BAS-ESP Ahronos W168 A-Class 28 05-03-2011 12:01 PM
    A160 BAS / ESP Cable Short itsStorm General Mercedes-Benz 1 10-16-2010 04:41 PM
    BAS / ESP Andrzejek W202 C-Class 4 07-24-2009 04:32 PM
    BAS Esp & ESP Lights Up... amflip W163 M-Class 6 09-23-2007 07:32 PM
    esp/bas gary1378 W163 M-Class 2 06-04-2004 06:23 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome