2010 ML350 - AC fans run after car is shut off - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-12-2011, 07:02 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: May 2011
Posts: 2
2010 ML350 - AC fans run after car is shut off

Hello. Brand new to the forum, and I posting this one for my mother. She's struggling with this. She bought the 2010 ml350 brand new a couple months ago and had this issue the whole time.

Problem - She has had the car jumped a total of 12 times because the car battery is always dying on her. At first she thought the battery was bad, then the alternator and on and on trying to rule out issues.

Recently, she came out to her car and heard the AC fans running (keys not in the ignition and car shut off)... She never noticed before because the second the door opens, the fans turn off. It is almost like the car thinks someone is still in there and keeping them cool. Problem is the car isn't smart enough to turn itself off when the fans run it dead.

She has taken it to the dealer twice... they charged her 200 dollars twice ... and didn't fix the issue twice. Worst off is we can't make the issue happen cause we wanted to show the dealer. It just randomly happens so they don't see the problem.

Anyone have any idea what could be causing this?

Last edited by duggerdean; 05-12-2011 at 07:09 PM.
duggerdean is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-12-2011, 07:49 PM   #2 (permalink)
BenzWorld Senior Member
 
Date registered: Dec 2007
Location: Alberta Canada
Posts: 452
It has to be some sort of electrical/software gremlin....is your mileage so high already you have no warranty?
Intermitent things like that need to be left there at a dealer for a few days. Suggest they give you a loaner and let them keep it for a week
__________________
1980 450sl traded in
1983 380sec sold
1989 300se traded in
2002 ML320 Gave to Family member
2008 ML320CDI /Full load (inc air susp) minus rear entertainment/ Pewter Silver Black leather

Last edited by Vernl; 05-12-2011 at 07:52 PM.
Vernl is offline   Reply With Quote
Old 05-12-2011, 08:01 PM   #3 (permalink)
BenzWorld Newbie
 
Date registered: May 2011
Posts: 2
It is under warranty still. I am not sure what she got charged for both times. I will ask her tomorrow on that.

I personally also feel that it is an electrical issue but we have had it in twice. If we tell the dealer it is still happening, I am not sure if they will try to fix it at this point.

We are also considering taking it to another dealer also.
duggerdean is offline   Reply With Quote
Old 05-12-2011, 10:17 PM   #4 (permalink)
BenzWorld Senior Member
 
Date registered: Dec 2007
Location: Alberta Canada
Posts: 452
Quote:
Originally Posted by duggerdean View Post
It is under warranty still. I am not sure what she got charged for both times. I will ask her tomorrow on that.

I personally also feel that it is an electrical issue but we have had it in twice. If we tell the dealer it is still happening, I am not sure if they will try to fix it at this point.

We are also considering taking it to another dealer also.
I am puzzled about the billing issue.
But at this point you have it documented in the system , If you dont have any luck with your current dealer you have a few options. You can get a regional service rep involved and that can move things along, or you can go to another dealer. I personally have a great dealer and have dealt there for 25 yrs but if they changed the way they handled service issues i would be across town to the next dealer in a minute.
Its hard to say , not knowing your dealer and its service dept, but something doesnt seem right, whether the problem hasnt been explained to them properly or they are just letting it slide. The billing issue make me suspect the latter.
It seems there is no happy medium when it comes to dealerships. They either treat you like royalty..as mine does...or they assume once they have your money, that you have no options.Let me say that the regional and head office of MB are very strict on customer service and frown on dealers not following up on complaints. Perhaps a call to the regional rep might be whats needed to get them back on track.
Vernl is offline   Reply With Quote
Old 05-15-2011, 10:09 PM   #5 (permalink)
BenzWorld Member
 
Date registered: May 2010
Vehicle: '11 ML350
Location: Colorado, Arizona
Posts: 131
I have the same issue with an '11 ML350. Haven't taken to the dealer yet, but will talk to them later in the year when I have the 1st required service done.
FredGarvin is offline   Reply With Quote
Old 06-03-2011, 02:33 PM   #6 (permalink)
BenzWorld Member
 
ChedengML350's Avatar
 
Date registered: Jul 2007
Vehicle: ML350 2006
Location: USA-SW
Posts: 165
Next time it happens, video record it and show it to the dealer.

Does anyone know if there is a TSB for this issue? Thanks.
__________________
2006 ML350, Pewter, Black Leather Seats, Navigation, Sunroof, Trim Package, Entertainment Package (Harman Kardon Surround w/ 5 Disc Changer, Auxillary Jack), Brown Birds Eye Maple Wood, Rear Side Airbags, Trailer Hitch, Heated Front Seats, Power Liftgate, 20% OE rear colored glass.
Mod: Front Grill Chrome Kit, Suntek HP 35 (35% tinted front windows).
Mileage: 108K+ miles
ChedengML350 is offline   Reply With Quote
Old 06-07-2011, 06:56 PM   #7 (permalink)
BenzWorld Member
 
icerabbit's Avatar
 
Date registered: Jun 2009
Vehicle: '08 ML350 4Matic US
Location: New England
Posts: 173
In our family we've had this issue maybe 15-20 years ago where my parents new luxury car (not MB) would not start either. Could be anything from parking it a few hours to a few days. Drive to a restaurant. Can't leave after dinner. Get up in the morning, can't go to work. After long runarounds, non-effective service visits, ... corporate was contacted with threat of legal action & negative publicity. They took the car in at the biggest regional dealer for a week and as far as we know rewired it. Problem solved. Never another issue.

Good point on using a video camera device (photo camera in video mode, iphone, ...) . It might be possible to make a better recording with the window rolled down partially or more, for clearer video & audio.

Can't believe they charged for both visits, unless it is one of those things where the technician can't find anything wrong and they bill you for all the diagnostic work? I certainly would bring this to MBUSA's attention and ask for a refund. The car is under warranty ... and if the dealer again can't fix it, you're getting into melon law territory.

Crossing fingers this will get resolved soon.
I know I'd be pulling my hear out if my ML did this, where you never know if she'll start or not.

Last edited by icerabbit; 06-07-2011 at 06:59 PM.
icerabbit is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
2010 ML350 BTEC Residual / Radiator Fans Running after engine off bdbe320 W164 M-Class 3 12-14-2010 03:23 AM
What are the Differences between 2007 ML350 and 2010 ML350? begone W164 M-Class 9 05-27-2010 04:46 AM
99 AC Compressor won't engage and fans won't run Toomchisnvrenuf R129 SL Class 33 09-17-2008 09:48 PM
Fans run continuously mslchief W140 S-Class 4 03-31-2007 03:45 PM
engine run on after shut off 300se 1990 bendaddyo W126 S,SE,SEC,SEL,SD,SDL Class 1 06-18-2005 08:55 AM


All times are GMT -7. The time now is 03:42 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.