2006 ML350 NEED ASSISTANCE, ENGINE CODES P0016 AND P0017 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-28-2010, 02:44 PM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question 2006 ML350 NEED ASSISTANCE, ENGINE CODES P0016 AND P0017

Hi,
I have a 2006 ML350, 72,000km. Vehicle is in great condition, but the engine light came on and off intermittently over the last month. Had the error codes checked. P0016 and P0017 right bank, intake and exhaust. Is this a big fix? I've seen some threads on cam sensors to magnets, to timing chains worn out. Any insight that anyone can provide would be greatly appreciated. Trying to get this repaired without it costing me a fortune. Drives great, no issues in performance. Where to start? Thx in advance for your help.
Fab1060
Fab1060 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-28-2010, 05:53 PM
BenzWorld Veteran
 
Date registered: Mar 2007
Vehicle: 2001 ml320 and 2006 ml350 (sold)
Location: minnesota
Posts: 711
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I am confused on those 2 codes...they refer by some websites to crankshaft (not camshaft) position...it is the 4 camshaft position sensor that you can see at top front of motor with 2 on each side...one for intake and one for exhaust on each side of v6.

another web site says they map to 1200 and 1208 which are the balance shaft sprocket failure...ML350 3.5L Balance Shaft Failure - Page 3 - PeachParts Mercedes ShopForum

but for your sake i hope i am wrong...

ScottB
scottbordo@hotmail.com is offline  
post #3 of 3 (permalink) Old 11-30-2010, 07:15 AM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: City on the TN River
Posts: 10,615
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 179 Post(s)
Lifetime Premium Member
Get the codes read by an mb dealer. But scott, I'm afraid, is right. It sounds like you have the dreaded balance shaft failure.
cmitch is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    P0016 and P0017 CEL 2006 C230 Crank/Cam alignment Achped W203 C-Class 1 12-03-2012 10:03 AM
    DTCs P0016 & P0017 CEP007 General Mercedes-Benz 8 03-25-2011 10:44 PM
    2006 ML350 NEED ASSISTANCE, ENGINE CODES P0016 AND P0017 Fab1060 General Mercedes-Benz 4 12-16-2010 10:54 AM
    Please help 2006 ml350 engine noise snowbirdMN W164 M-Class 4 04-14-2009 07:08 PM
    2006 ML350 engine noise snowbirdMN W164 M-Class 3 11-21-2005 05:36 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome