2006 ML-350 check engine light on! - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-16-2009, 10:28 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Dec 2009
Vehicle: Mercedes Benz 2006 ML-350
Location: Live in San Francisco
Posts: 2
Thumbs down 2006 ML-350 check engine light on!

Hello All, I have a used 2006 ML-350 that I bought with 48K miles under warrenty. the first week the fuel sensor went out and i ran out of fuel with the gas guage indicating 1/2 full. The dealer fixed it. Now with only 55K miles the check engine light has come on & off continuoiusly(?). I took it to one dealer & they said that the crank shaft balance weel needed to be replaced - took it to another dealer & they said the fuel injection system needed to be repaired. now with 56K miles the check engine light is on all the time. I took it to a local MB repair shop & they are saying that the sensors on the camshaft might be bad or the sensor on the crankshaft is bad. they switched the 4 front camshaft sensors around & turned off the check engine light off. I drove the car around for a day & the CE light came back on. now the repair shop wants to run diagnostics again to see if the same codes come up = I'm real upset.
here's the funny thing - I have driven the car from San Francisco to Los Angeles & back 3 times - 400 miles one way - no problems!!!
No one can give me a straight answer - is it the sensors or a real problem
Can anyone relate to this situation or provide some good advice...
zzsprm0 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-17-2009, 07:24 AM   #2 (permalink)
BenzWorld Veteran
 
roadrutz's Avatar
 
Date registered: Sep 2008
Vehicle: '09 ML550, honking great motorhome, M3, PT Cruiser
Location: Calgary
Posts: 736
If the vehicle is still under warranty, why are you stressing over this? Let the dealer figure out what is wrong and fix it.
roadrutz is offline   Reply With Quote
Old 12-17-2009, 02:14 PM   #3 (permalink)
BenzWorld Newbie
 
Date registered: Dec 2009
Vehicle: Mercedes Benz 2006 ML-350
Location: Live in San Francisco
Posts: 2
Angry Roadrutz

The ML-350 now has almost 60K miles on it and the dealer says that the Warrenty has expired. The MB auto repair guys say that they will have to talk with mercedes to see if they will cover the camshaft/crankshaft replacement if that is the problem because it is a knowned defect on these models/engines. My wife took the car and drove it down to Los Angeles again - another 400 miles on I-5 - & had no problesm - runs like a top she says & got down there on 3/4 of a tank of gas. I think it is the sensors!!!
zzsprm0 is offline   Reply With Quote
Old 12-22-2009, 12:16 PM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 6
I have the same problem, told me its the balance shaft and costs $4000 to fix. They told me Mercedes will kick in $2000 costing me $2000. I will soon be in the process of fighting Mercedes on this one since I now cannot get an inspection sticker in Massachusetts and the car is unsaleable with the check engine light on.
pauldunton is offline   Reply With Quote
Old 01-02-2010, 07:52 PM   #5 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2010
Vehicle: '86 420SEL; '02 SLK 32 AMG; '06 ML 350
Location: Springfield, VA
Posts: 2
CEL Codes 0016 & 0017

This thread is disturbing. My wife's '06 ML 350 just went off warranty and has started throwing CEL codes 0016 & 0017. We just had the two cam adjusters replaced in the right bank in the hope this would solve the problem. No such luck - 24 hours later, and the CEL light is back on.

Any advice? What happens if we ignore? We've driven about 600 miles with codes without any noticable consequences. Will this eventually happen to the left side too?
Hillenbrand is offline   Reply With Quote
Old 01-03-2010, 04:11 PM   #6 (permalink)
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 6
Problem to me

Quote:
Originally Posted by Hillenbrand View Post
This thread is disturbing. My wife's '06 ML 350 just went off warranty and has started throwing CEL codes 0016 & 0017. We just had the two cam adjusters replaced in the right bank in the hope this would solve the problem. No such luck - 24 hours later, and the CEL light is back on.

Any advice? What happens if we ignore? We've driven about 600 miles with codes without any noticable consequences. Will this eventually happen to the left side too?
According to Mercedes its not a problem, but according to the State of Massachusetts its a problem, I cannot get an inspection sticker because of it. Mercedes agreed to pay half leaving me with around $2K to fix, which I think is ridiculous because its obviously a common problem.
pauldunton is offline   Reply With Quote
Old 01-03-2010, 06:51 PM   #7 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2010
Vehicle: '86 420SEL; '02 SLK 32 AMG; '06 ML 350
Location: Springfield, VA
Posts: 2
Anybody in particular to quote at Mercedes as a reference? I suspect I'l lbe calling this week.
Hillenbrand is offline   Reply With Quote
Old 01-04-2010, 05:32 AM   #8 (permalink)
BenzWorld Junior Member
 
Date registered: Dec 2009
Posts: 6
Quote:
Originally Posted by Hillenbrand View Post
Anybody in particular to quote at Mercedes as a reference? I suspect I'l lbe calling this week.
Unfortunately I do not have the name of the guy from Mercedes Benz USA, I spoke with, but he told me that it was up to service manager where I bought my car. The number I called was 1-800-367-6372 and a guy named Ralph from Mercedes Benz USA emailed me, but that is not who I spoke with on the phone. Let me know if you have any luck with them.
pauldunton is offline   Reply With Quote
Old 05-21-2010, 01:26 PM   #9 (permalink)
BenzWorld Newbie
 
Date registered: Jul 2009
Vehicle: 2006 ML350
Location: New Jersey
Posts: 4
I have the same problem for a few months now. It's the camshaft, air pump, etc, same as allt he other members. The cost quoted was $1,200, the air pump itself $800. The guy at Mercedes told me that I could drive it like that but won't get as good mileage as before. I do plan to get it fixed because it won't pass inspection at the DMV. It's a known defect on the ML350's.

p.S. I have driven it for the past 3,000 miles like that.
mosinoi is offline   Reply With Quote
Old 05-21-2010, 02:37 PM   #10 (permalink)
BenzWorld Veteran
 
Date registered: Mar 2007
Vehicle: 2001 ml320 and 2006 ml350 (sold)
Location: minnesota
Posts: 711
attached is bulletin on balance shaft. i bought my 2006 ml350 with 83k miles. right after i got it i had one camshaft sensor go out, and a week later another. i luckily do not have the balance shaft problem. my point is this: not every problem indicates the balance shaft problem. the cam sensors,of which there are 4, do go out. no big deal. and my other point is that not everyone that is in vin range to possibly have the balance shaft problem has the problem. when i spoke to mbusa they indicated that if i did have the problem down the road the likely would work something out with me thru the dealer. i believe her as indicated by this thread with someone saying mb will pay half. i say take them up on that offer and pay the $2k. then other then minor electronics your basic engine will be solid and good for ten if not 100 of thousands of miles. cel light can be scary but can be any number of things. i had intermittant misfires turning on the light. i disconnected and reconnected coils and light has not gone on for weeks.

taking car back and forth to dealer, and check engine lights coming on can be both very concerning and a pain in the butt. but that is sometimes how it is with these cars. reading the codes to diagnosis, making tweaks, replacing parts and re-reading codes can be part of process.

you have to decide what is right for you depending on aptitude, time, and money. i paid $80 to mbusa and bought shop manual. i also paid like $120 and bought my own code reader. i also signed up for epc on line so i can figure out what part# i need and then shop myself from many online oem mbdealers.

http://epc.startekinfo.com/epc/login.jsp
http://www.trademotion.com/partlocat...?siteid=214089

0016 and 0017, i think are crankshaft position sensors. i had to replace this item on wifes ml320 2001. it was 30 minute job and like 80 bucks. i don't think this has anything to do with balance shaft issue. eventually the wifes car would not restart when hot. so i would get it fixed.

the other advice i have is negotiate. when i needed to have something repaired at dealer and labor was small but part was expensive. they matched part price from online mb oem dealer. for example, i don't know exactly what air pump you needed but the link i gave you has $750 retail air pump for $585.
Attached Files
File Type: pdf S-B-03.30-08i_Damaged_balance_shaft_sprocket[1].pdf (342.7 KB, 726 views)
__________________
ScottB

Last edited by scottbordo@hotmail.com; 05-21-2010 at 02:58 PM.
scottbordo@hotmail.com is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
350 engine to replace 280 in 280slk 171 2006 ibizafun R171 SLK Class 3 04-13-2008 01:34 PM
2006 C280 4matic Check engine light merce-deez W203 C-Class 4 03-21-2008 11:11 AM
1997 S420 Fuel gage light flasehs setting Check Engine light aljabari W140 S-Class 7 09-03-2007 09:19 PM
How to check code for check engine light 94 E320 W124 Synd W124 E,CE,D,TD Class 1 05-24-2007 02:37 PM
check engine light & flashing fuel guage light pd99sl500 R129 SL Class 7 02-27-2005 04:31 PM


All times are GMT -7. The time now is 08:45 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.