Removing the Audio 20 for Ipod Instal. - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-21-2006, 11:40 PM
BenzWorld Member
 
Steve (Austria)'s Avatar
 
Date registered: Aug 2002
Vehicle: 2006 ML 320 CDI
Location: Vienna, Austria
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile Removing the Audio 20 for Ipod Instal.

Hi Everyone!

Does anyone have experience removing the Audio 20 ? I want to try installing the MB Ipod Interface Kit myself this weekend. According to many, the most difficult and time consuming part is the removal of the Audio 20, in which you need to remove most of the middle console first.

I would greatly appreciate any assistance.

Steve
Steve (Austria) is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-22-2006, 10:53 PM
BenzWorld Member
 
Steve (Austria)'s Avatar
 
Date registered: Aug 2002
Vehicle: 2006 ML 320 CDI
Location: Vienna, Austria
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So I have now removed the right lower panel, the glove compartment, the ashtray and climate controls, but I cant get the damn radio out! Does anyone know if you need special radio removal tools for the w164 ?? Is there a trick or something, because my radio won't budge!!
Steve (Austria) is offline  
#3 (permalink) Old 04-23-2006, 09:51 AM
BenzWorld Member
 
Steve (Austria)'s Avatar
 
Date registered: Aug 2002
Vehicle: 2006 ML 320 CDI
Location: Vienna, Austria
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I have successfully installed the ipod integration kit "without removing the radio!" It just was not possible for me to get the Audio 20 out, so I unplugged and plugged the ipod kit from the side and front. More or less blind! In total I spent something like 5-6 hours on this job, but it is now perfect. The ipod fired straight up and the sound is very good. I did not notice any decrease in volume. (5th generation 30 gig.)

With many scrapes and scratches from the sharp plastic pieces, I do not recommend this installation technique to everyone. But I did save myself about EURO 300 by doing it myself. Also, my dealer has never done an ML, so why should he do it right ??

Steve
Steve (Austria) is offline  
#4 (permalink) Old 04-23-2006, 02:51 PM
BenzWorld Senior Member
 
mikenj6's Avatar
 
Date registered: Aug 2005
Vehicle: 06 ML350
Location: Bordentown, NJ
Posts: 492
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Steve,

Do you have all of the integration functionality? If so very good job.

Mike

Packages: Appearance (Pewter/Charcoal), Lighting, Entertainment, Comfort and Sunroof:
Options: Hitch, Heated Seats, Rear Airbags, Parktronic, Power Liftgate, Frt & Rr Stainless Steel Skid Plates, DVD Nav Sys, IPod Kit and Craddled Phone Kit

Mods: Hoen Titanium H-7 High Beams, All Weather H-11 Fogs, 5000k W5W Standing Lamps, Chrome Door Lock Pins & Hood Fins, Brabus Monoblock IV 20" Wheels with Hankook Ventus ST RH06 275/45 Tires, Brabus Custom Suspension 164-016-00 and SS Side Bars
mikenj6 is offline  
#5 (permalink) Old 04-23-2006, 03:21 PM
BenzWorld Member
 
Steve (Austria)'s Avatar
 
Date registered: Aug 2002
Vehicle: 2006 ML 320 CDI
Location: Vienna, Austria
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile

Quote:
Originally Posted by mikenj6
Steve,

Do you have all of the integration functionality? If so very good job.

Mike
Mike,

Yes the iPod has all of the functionality through the steering wheel controls. Although I did not test it very long today, everything seems to be working fine.

Steve
Steve (Austria) is offline  
#6 (permalink) Old 04-26-2006, 08:03 PM
BenzWorld Elite
 
Date registered: Nov 2004
Vehicle: My Benz: 04 S430
Location: A,Tx
Posts: 1,219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Steve (Austria)
I have successfully installed the ipod integration kit "without removing the radio!" It just was not possible for me to get the Audio 20 out, so I unplugged and plugged the ipod kit from the side and front. More or less blind! In total I spent something like 5-6 hours on this job, but it is now perfect. The ipod fired straight up and the sound is very good. I did not notice any decrease in volume. (5th generation 30 gig.)

With many scrapes and scratches from the sharp plastic pieces, I do not recommend this installation technique to everyone. But I did save myself about EURO 300 by doing it myself. Also, my dealer has never done an ML, so why should he do it right ??

Steve
Congrats on your IpOD install.. Your decrease in volume is the Kit itself not the IPOD. I know I'm a little late, but if you had left the Aux connection on your command, you could have connected your iPOd dorectly to it, and just hooked up the rest of the wires for integration and saved a few hours of dealing with your command, plus retain your sound quality.
The connection on the command is just for Audio and is redundant. so it's not really needed for integration at all. But, I'm glad to see another happy DIY'er out there who'd not afrqaid to take his car apart to figure out how do do something and save mega$$$..

Congrats
My04230k is offline  
#7 (permalink) Old 05-03-2006, 03:40 PM
BenzWorld Newbie
 
Date registered: May 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Start by removing the leather around the gear lever and then remove the plastic which simply unclips. then remove the cig lighter area, remove the air con controls. Then the hard bit between the air vents are two screws, remove these and the plastic above the stereo will unclip from the bottom. You'll then be able to see the four screws to remove the stereo.

I did this today, took me 2hrs, however I cant figure out the sterin controls, and ideas anyone. and how can i get the song title on the main screen?
Using an Audio 20 not command
shawda is offline  
#8 (permalink) Old 05-03-2006, 04:34 PM
BenzWorld Member
 
Steve (Austria)'s Avatar
 
Date registered: Aug 2002
Vehicle: 2006 ML 320 CDI
Location: Vienna, Austria
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
First question, are you talking about a new w164 ML or an older model ? Secondly, I am quite sure you cannot get an iPod to display in the center display, only in the driver display.
Steve (Austria) is offline  
#9 (permalink) Old 05-04-2006, 11:04 AM
BenzWorld Newbie
 
Date registered: May 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'm talking about a 2006 C Class, does anyone know how the steering controls should work?
shawda is offline  
#10 (permalink) Old 05-04-2006, 02:21 PM
BenzWorld Senior Member
 
ABenzGuy's Avatar
 
Date registered: Jan 2006
Vehicle: '06 ML350; '11 C300
Location: Chesapeake, VA USA
Posts: 418
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Smile

Quote:
Originally Posted by shawda
I'm talking about a 2006 C Class, does anyone know how the steering controls should work?
shawda. Just cruising around in the different sections of the Forum and saw your post: 1) Try posting your question in the W203 C Class section and you might get an answer. You are in the W164 M Class Section of the Forum and you own a C Class Benz; 2) Welcome to BenzWorld and hope this helps.

ED - '06 ML350 w/AMG Sport Package & '11 C300 Luxury (Wife's car)

Last edited by ABenzGuy; 05-04-2006 at 02:23 PM.
ABenzGuy is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W164 M-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome