Intermittent BAS/ESP light and code 1025-003 … - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 66 (permalink) Old 03-10-2017, 08:06 AM Thread Starter
BenzWorld Member
 
Date registered: Jun 2016
Vehicle: ML 55 2000
Location: Spring TX
Posts: 122
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
(Thread Starter)
Intermittent BAS/ESP light and code 1025-003 …

I have been having this issue for the past couple of weeks. Brake light switch has been replaced recently and codes read by STAR. Code 1025-003 was found and as per MB instructions was removed. Light stayed off for couple of days and has returned though intermittently.
Today while driving and light braking it seemed the ABS engaged (not 100% sure) but something did act on the brakes for the vehicle to almost stop even though the situation did not warrant the ABS or whatever to kick in.I was on a straight road and trying to slow down for an impending turn.

I have read thru the forum as much as I could with ECU, Sensors etc.. Like to know the best possible next step?
sstomcat1 is offline  
Sponsored Links
Advertisement
 
post #2 of 66 (permalink) Old 03-10-2017, 12:47 PM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML430 , 2008 C200k Elegance 2006 C180k sports(sold)
Location: Melbourne Australia
Posts: 2,944
Mentioned: 3 Post(s)
Quoted: 450 Post(s)
Lifetime Premium Member
Intermittent BAS/ESP light and code 1025-003 …

Pull the connector off the ABS pump and check it for any corrosion. Give it a good clean with electrical contact cleaner. Make sure your washer bottle is not leaking onto the connector.


Sent from my iPhone using Tapatalk

Last edited by mattml430; 03-10-2017 at 12:49 PM.
mattml430 is online now  
post #3 of 66 (permalink) Old 03-10-2017, 01:05 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2016
Vehicle: ML 55 2000
Location: Spring TX
Posts: 122
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
(Thread Starter)
Quote:
Originally Posted by mattml430 View Post
Pull the connector off the ABS pump and check it for any corrosion. Give it a good clean with electrical contact cleaner. Make sure your washer bottle is not leaking onto the connector.


Sent from my iPhone using Tapatalk
Great will do this weekend and revert. Thanks!
sstomcat1 is offline  
 
post #4 of 66 (permalink) Old 03-10-2017, 02:46 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2016
Vehicle: ML 55 2000
Location: Spring TX
Posts: 122
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
(Thread Starter)
Happened again while driving back from work, this time the traction control kicked in (the triangle was flashing) and ESP/BAS light came on.
sstomcat1 is offline  
post #5 of 66 (permalink) Old 03-10-2017, 04:58 PM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML430 , 2008 C200k Elegance 2006 C180k sports(sold)
Location: Melbourne Australia
Posts: 2,944
Mentioned: 3 Post(s)
Quoted: 450 Post(s)
Lifetime Premium Member
While your in there pull the inner guard and check to make sure no wires have chaffed through on the loom to the pump. I had that happen to a friends ml.


Sent from my iPhone using Tapatalk
mattml430 is online now  
post #6 of 66 (permalink) Old 03-11-2017, 11:03 AM Thread Starter
BenzWorld Member
 
Date registered: Jun 2016
Vehicle: ML 55 2000
Location: Spring TX
Posts: 122
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
(Thread Starter)
Quote:
Originally Posted by mattml430 View Post
While your in there pull the inner guard and check to make sure no wires have chaffed through on the loom to the pump. I had that happen to a friends ml.


Sent from my iPhone using Tapatalk
Cleaned and checked put back on, light is still on..
sstomcat1 is offline  
post #7 of 66 (permalink) Old 03-11-2017, 11:38 AM
BenzWorld Elite
 
art_arev's Avatar
 
Date registered: May 2013
Vehicle: ML 500 2002 RHD, ML55 AMG 2003 RHD
Location: Harare, Zimbabwe
Posts: 3,316
Mentioned: 3 Post(s)
Quoted: 552 Post(s)
Send a message via Skype™ to art_arev
You might have to replace your ESP module. C1025 is a CAN fault within the ESP module.

Art
art_arev is online now  
post #8 of 66 (permalink) Old 03-11-2017, 01:02 PM
Lifetime Premium Member
 
mattml430's Avatar
 
Date registered: Sep 2008
Vehicle: 2000 ML430 , 2008 C200k Elegance 2006 C180k sports(sold)
Location: Melbourne Australia
Posts: 2,944
Mentioned: 3 Post(s)
Quoted: 450 Post(s)
Lifetime Premium Member
Searching about this code and it can also point to brake light switch or wheel speed sensors. Did it start recently after you replaced the B/L switch?
Was it adjusted properly after installation.
Hope this is not to blurry. Art or Jim might repost it as I can't copy and paste these original documents.



Sent from my iPhone using Tapatalk
mattml430 is online now  
post #9 of 66 (permalink) Old 03-11-2017, 04:10 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2016
Vehicle: ML 55 2000
Location: Spring TX
Posts: 122
Mentioned: 0 Post(s)
Quoted: 40 Post(s)
(Thread Starter)
Quote:
Originally Posted by art_arev View Post
You might have to replace your ESP module. C1025 is a CAN fault within the ESP module.
Is this plug and play ? or there needs to be some coding involved?

Quote:
Originally Posted by mattml430 View Post
Searching about this code and it can also point to brake light switch or wheel speed sensors. Did it start recently after you replaced the B/L switch?
It started before I replaced the brake switch as a potential solution.
sstomcat1 is offline  
post #10 of 66 (permalink) Old 03-11-2017, 04:17 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 19,680
Mentioned: 22 Post(s)
Quoted: 1045 Post(s)
Lifetime Premium Member
If you replace the ESP module with a used one you will most likely have to clear the fault codes after it is back together.
Noodles is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
    DigitalDavid
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome