ML320 SRS light on - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-11-2011, 08:12 PM
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2000 ML320
Location: Questa, NM
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
ML320 SRS light on

Cold today-2000 ML320 w/ 110k miles stalled in garage. Restarted and SRS light stayed on. Code reader says no codes but I cleared anyway and still have the light. The sticker on the door pillar says the air bags are good 'till 10/14 so that shouldn't be the problem. Fuse?
pkunk1 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-12-2011, 01:18 AM
BenzWorld Elite
 
Date registered: Aug 2006
Vehicle: 02 ML320
Location: Bronx, New York
Posts: 10,836
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 76 Post(s)
plunk, there can be any number of reasons why the SRS light has stayed on. Look at the list of the possibilities.

Your code reader does not have the capabilities to read those codes, nor does it have the capability to clear them. The code/s can only be read and cleared by a professional grade scanner, similar to the one pictured below.
Attached Images
 
Attached Files
File Type: pdf Air Bag Trouble Codes.pdf (39.9 KB, 550 views)
43sqd is offline  
#3 (permalink) Old 11-12-2011, 04:38 PM
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2000 ML320
Location: Questa, NM
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
So, you're saying there is nothing I can do myself? I'm 170 mi from a dealership and that would require 2 days in a motel.
pkunk1 is offline  
#4 (permalink) Old 11-12-2011, 04:49 PM
BenzWorld Elite
 
Date registered: Aug 2006
Vehicle: 02 ML320
Location: Bronx, New York
Posts: 10,836
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 76 Post(s)
Quote:
Originally Posted by pkunk1 View Post
So, you're saying there is nothing I can do myself? I'm 170 mi from a dealership and that would require 2 days in a motel.
Most any independent mechanic should have a professional grade scanner.
43sqd is offline  
#5 (permalink) Old 11-12-2011, 05:16 PM
BenzWorld Elite
 
Date registered: Feb 2006
Vehicle: 1999 ML320
Location: Ratville
Posts: 22,752
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 45 Post(s)
Quote:
Originally Posted by pkunk1 View Post
Cold today-2000 ML320 w/ 110k miles stalled in garage. Restarted and SRS light stayed on. Code reader says no codes but I cleared anyway and still have the light. The sticker on the door pillar says the air bags are good 'till 10/14 so that shouldn't be the problem. Fuse?
FTF check the battery. They don't work well in the cold.

... and this important discussion continues.


Dooloogssst!
mlfun is offline  
#6 (permalink) Old 11-12-2011, 07:13 PM
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2000 ML320
Location: Questa, NM
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by mlfun View Post
FTF check the battery. They don't work well in the cold.
It's plenty strong to start the car, but we did have the seat heaters on. I'll do a drawdown on the battery tomorrow. It is about 4-5 years old.
I thought my code reader was a good one as several years ago it cost about $100. I also have a Scangauge but would need to unhook the cord from the other vehicle or order another cord.
pkunk1 is offline  
#7 (permalink) Old 11-13-2011, 02:10 PM
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2000 ML320
Location: Questa, NM
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I checked the battery this AM - load tested OK, but when I reconnected the ground wire, the BAS/ESP light is now on in addition to the SRS. I put a charger on the batt thinking I drug it down with the load tester but no change.
pkunk1 is offline  
#8 (permalink) Old 11-13-2011, 03:15 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Location: Dallas, Texas
Posts: 3,499
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BAS/ESP warning is on because you have disconnected battery. Steering angle sensor lost its center position. Start vehicle turn steering wheel lock to lock few times it will disappear.

SRS fault has to be read using dedicated MB scanner. No OBDII scanner will help you with that.

1972 280SEL 4.5
1999 ML320
2000 E320
Witek_M is offline  
#9 (permalink) Old 11-13-2011, 06:17 PM
BenzWorld Junior Member
 
Date registered: Nov 2011
Vehicle: 2000 ML320
Location: Questa, NM
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Witek_M View Post
BAS/ESP warning is on because you have disconnected battery. Steering angle sensor lost its center position. Start vehicle turn steering wheel lock to lock few times it will disappear.

SRS fault has to be read using dedicated MB scanner. No OBDII scanner will help you with that.
Thanks! Is there any harm in driving it with the SRS light lit until I can find a MB scanner locally?
pkunk1 is offline  
#10 (permalink) Old 11-14-2011, 02:07 AM
BenzWorld Elite
 
Date registered: Aug 2006
Vehicle: 02 ML320
Location: Bronx, New York
Posts: 10,836
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 76 Post(s)
Quote:
Originally Posted by pkunk1 View Post
Thanks! Is there any harm in driving it with the SRS light lit until I can find a MB scanner locally?
No there isn't.
43sqd is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
98 ML320 w/ ETS light on MugenRD1 W163 M-Class 7 10-02-2010 06:08 AM
ML320 ETS light on kbhowmed W163 M-Class 6 06-11-2009 11:28 PM
98 ML320 ETS light on Da80 W163 M-Class 6 02-09-2009 06:53 AM
2002 ML320 Fog light Architect25 W163 M-Class 10 01-09-2007 08:55 PM
ABS & ETS Light On on ML320 carreagt1990 W163 M-Class 1 03-14-2005 02:33 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome