radio code after oil,brake and battery change - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-09-2011, 10:58 PM
BenzWorld Newbie
 
Date registered: Oct 2011
Vehicle: 2005 Mercedes Benz Ml350 SE
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
radio code after oil,brake and battery change

today i changed the oil the rear brakes and the battery and my radio code came on, the thing is i got my radio code in my booklet think my question is what would of caused the message to come on could it be cause i changed the battery or did i touch something that i shouldn't have while changing the oil brake or battery? the car is at 62000 km's and its been 6 years and i just changed the battery for the first time in this car.
///mbenz is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-09-2011, 11:17 PM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: 1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Location: NW Arkansas, La Jolla CA, Hong Kong
Posts: 6,203
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Yes, the battery change

Yes due to the battery change.

Also go to the owners manual to reset steering angle sensor, sunroof, windoes, seats, etc.
fabbrisd1 is offline  
#3 (permalink) Old 10-09-2011, 11:26 PM
BenzWorld Newbie
 
Date registered: Oct 2011
Vehicle: 2005 Mercedes Benz Ml350 SE
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
will it show in the owners manual what else i have to reset and how to cause no other warning came on
///mbenz is offline  
#4 (permalink) Old 10-10-2011, 11:02 AM
BenzWorld Elite
 
Merzatt's Avatar
 
Date registered: Nov 2007
Vehicle: '02 ML320
Location: Indianapolis
Posts: 1,257
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Copied this info from the sticky.

After disconnecting/reconnecting the battery ground cable

1) Enter the security code for the radio.
- Enter the number on the radio card and hit "OK"

If the code is entered incorrectly, word "CODE" appears on the display. After entering the wrong code for 3 times, "WAIT" appears on the display and the radio is disabled for 10 mins. After entering the wrong code for 3 more times, radio is disabled for 60 mins.

2) Re-activate steering angle sensor
- Start the engine
- Turn the steering wheel from lock to lock.
- Malfunction lamp should turn off.

3) Synchronize sunroof
- Open sunroof and hold down the switch. Sunroof moves to the end position, pulls back 1/4 turn and stops.

4) Synchronize power windows (as of VIN A289565)
- Press the switch for the power windows to the 1st actuation point, and then hold down for another 5 seconds after the windows has reached its top end position.

Note: When removing and installing battery, always remove the key from ignition to avoid fault codes. Remove the ground cable first and connect it last. Insulate both cable terminals to prevent unintentional contacts.
Merzatt is offline  
#5 (permalink) Old 10-10-2011, 11:08 AM
BenzWorld Newbie
 
Date registered: Oct 2011
Vehicle: 2005 Mercedes Benz Ml350 SE
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
thank you very much i will get those done as soon as i have a chance
///mbenz is offline  
#6 (permalink) Old 10-10-2011, 11:59 AM
BenzWorld Newbie
 
Date registered: Oct 2011
Vehicle: 2005 Mercedes Benz Ml350 SE
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
thank you very much guys i realized it was only radio and sunroof and my rip computer date time compass.my power windows and steering malfunction lamp didn't come on so all i did was reSynchronize my sunroof set the time and unlocked my radio as the rest was working again thank you very much
///mbenz is offline  
#7 (permalink) Old 10-11-2011, 06:42 PM
BenzWorld Elite
 
Darkmann's Avatar
 
Date registered: Aug 2002
Vehicle: 05 500
Posts: 5,873
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Merzatt View Post
Copied this info from the sticky.

After disconnecting/reconnecting the battery ground cable

1) Enter the security code for the radio.
- Enter the number on the radio card and hit "OK"

If the code is entered incorrectly, word "CODE" appears on the display. After entering the wrong code for 3 times, "WAIT" appears on the display and the radio is disabled for 10 mins. After entering the wrong code for 3 more times, radio is disabled for 60 mins.

2) Re-activate steering angle sensor
- Start the engine
- Turn the steering wheel from lock to lock.
- Malfunction lamp should turn off.

3) Synchronize sunroof
- Open sunroof and hold down the switch. Sunroof moves to the end position, pulls back 1/4 turn and stops.

4) Synchronize power windows (as of VIN A289565)
- Press the switch for the power windows to the 1st actuation point, and then hold down for another 5 seconds after the windows has reached its top end position.

Note: When removing and installing battery, always remove the key from ignition to avoid fault codes. Remove the ground cable first and connect it last. Insulate both cable terminals to prevent unintentional contacts.
Really interesting. Over the weekend I managed to disconnect the negative terminal only. Radio code came on and I did the reset. I don't have any errors showing up. Do I have to re-synch everything?

1996 Z32 TT
A 18Hp lawn mower
370Z - I want one!
Darkmann is offline  
#8 (permalink) Old 10-11-2011, 07:24 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Location: Dallas, Texas
Posts: 3,499
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Darkmann View Post
Really interesting. Over the weekend I managed to disconnect the negative terminal only. Radio code came on and I did the reset. I don't have any errors showing up. Do I have to re-synch everything?
Yes!

1972 280SEL 4.5
1999 ML320
2000 E320
Witek_M is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Battery died - need radio code??? mhotchkiss4 W163 M-Class 2 10-31-2007 07:56 AM
Battery, and Radio Code swiftwind W163 M-Class 4 05-02-2007 09:44 PM
Radio code after battery replacement Phonepro W210 E-Class 13 01-10-2007 12:42 PM
No radio code after a dead battery motoadve W163 M-Class 2 07-06-2004 04:47 PM
No radio code after a dead battery motoadve W163 M-Class 4 07-05-2004 09:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome