ML320 transmission problem. - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-07-2011, 09:16 AM
BenzWorld Newbie
 
Date registered: Apr 2011
Vehicle: 2001 Chevy Tahoe
Location: St.Paul,MN
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question ML320 transmission problem.

I am new to the forum.Great information.I am a transmission rebuilder in St.Paul,MN.I have a 2001 ML320 that goes to limp mode right away.It has some codes yhat keep comming back.P2066,P2066,147,051,014,P0730,P0715. I do not think there is any mechanical problem with trans,I just went through the unit.T/C,O/H kit,Filter.New speed sensors w/plate.Any ideas?Thank You.
mannerl is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-07-2011, 09:50 AM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: 1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Location: NW Arkansas, La Jolla CA, Hong Kong
Posts: 6,215
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
If there are "hard" tranny codes they have to be reset by the dealer or indie SDS system.

Did you check and replace the Connector/adapter plug ? Did you check the harness for "weeping" leakage that will travel up the harness ?

Keep the faith !
fabbrisd1 is offline  
#3 (permalink) Old 04-07-2011, 11:27 AM
BenzWorld Elite
 
Date registered: Aug 2006
Vehicle: 02 ML320
Location: Bronx, New York
Posts: 11,007
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)
Quote:
Originally Posted by mannerl View Post
I am new to the forum.Great information.I am a transmission rebuilder in St.Paul,MN.I have a 2001 ML320 that goes to limp mode right away.It has some codes yhat keep comming back.P2066,P2066,147,051,014,P0730,P0715. I do not think there is any mechanical problem with trans,I just went through the unit.T/C,O/H kit,Filter.New speed sensors w/plate.Any ideas?Thank You.
The P2066 etc. codes are those that are reported by the ETC Module to the Eng. Control Module. But codes 014 etc. are authentic transmission codes and are therefore locked into the Electronic Transmission Control Module.

You must clear the Pxxx codes from the Eng. Control Module as usual and then access the ETC Module and clear the 014 etc. codes. You will need a professional grade scanner e.g. Snap-On, or similar to perform this.
Attached Files
File Type: pdf Trans. Codes, Tests & Pin-Out.pdf (70.8 KB, 336 views)
43sqd is offline  
#4 (permalink) Old 04-07-2011, 12:37 PM
BenzWorld Junior Member
 
Date registered: Jul 2009
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It might be worth checking the battery out. You often find a faulty battery will put the transmission into limp mode and throw up a series of error codes (not sure about these specific codes). If this is the case you need to change the battery and reset the fault codes
tony jr is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Transmission problem ML320 1998 lb_35 W163 M-Class 4 12-26-2010 05:15 PM
Transmission problem ml320 2000 Brandily W163 M-Class 8 09-25-2009 08:57 AM
ML320 transmission problem P2203 Patamdar W163 M-Class 3 08-23-2009 12:35 PM
Transmission for ML320 bealestreetbenz W163 M-Class 8 03-09-2009 02:28 PM
Questions on 1998-99 ML320 transmission problem autobahnNY W163 M-Class 5 07-06-2004 04:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome