Door Lock Issue? 2006 ML350 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-26-2011, 08:31 PM
BenzWorld Newbie
 
Date registered: Mar 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Door Lock Issue? 2006 ML350

I own a 2006 ML350. I recently noticed that the driver side door lock has something wrong with it. When the car is running and I am inside, the lock works fine. However, after I park and get out and try to lock it, all the doors lock except the driver side. When i use my hand and try to push the lock down, it wont go. It feels like its being forced up into the unlocked position. I would normally go to a mercedes dealership to get it fixed, however, the closest one to where I am now is around 45 minutes away and its Saturday. Is there a quick way I can fix this myself? Thanks in advance

Dale

Last edited by kingdaleo; 03-26-2011 at 08:34 PM.
kingdaleo is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-26-2011, 09:47 PM
BenzWorld Elite
 
bocabenz's Avatar
 
Date registered: Jul 2006
Vehicle: 2000 ML430, 2006 BMW 325i, 2007 BMW 328i Coupe
Location: South Florida
Posts: 2,982
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not really. The actuator has likely begun to bind and its easier to replace once than continuously repair it. Do a search for "machine gun lock" for more info.


bocabenz is offline  
#3 (permalink) Old 03-27-2011, 05:20 AM
BenzWorld Newbie
 
Date registered: Aug 2009
Vehicle: 2001 ML55 AMG
Location: Tucson, AZ
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Gernan Car Door Locks...

As far as I know, all German cars are built that way, you can't lock the driver's door using the push-button in the door, the key is used once driver's door is closed (or by using the remote). Keeps one from locking the keys in the vehicle. Hope this helps... --Jim
jascot1 is offline  
#4 (permalink) Old 03-31-2011, 09:12 PM
BenzWorld Newbie
 
Date registered: Mar 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
ok cool thanks for the help guys!
kingdaleo is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
88 300E Door Lock Issue blackphenomenon W124 E,CE,D,TD Class 1 06-15-2009 08:05 PM
Weird Door Lock Issue Darkmann W163 M-Class 3 06-13-2007 04:17 AM
89 560SEL Door Lock Issue? 500MPL W126 S,SE,SEC,SEL,SD,SDL Class 7 12-29-2006 12:01 PM
300SD door lock issue (can't lock with key, but can unlock) Mugsy90/10 W126 S,SE,SEC,SEL,SD,SDL Class 5 11-12-2006 07:12 PM
Door Lock Issue Boerne ML320 W163 M-Class 2 06-09-2006 11:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome