ML350 Unusual Electrical Problems, HELP! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 02-15-2011, 08:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 2005 ML350 SE; 2005 Dodge Viper; 2003 Porsche 996 Cab.; 1966 Pontiac GTO
Location: California
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML350 Unusual Electrical Problems, HELP!

I would like to solicit the help from the many experts out there.

I have a 2005 ML350SE. My problem began recently after the vehicle has sat for about 3 months. The problem began with windshield wiper creeping up about 1/4" increments, it will do a full sweep when it reaches the 1/3 mark. The wiper switch is at OFF position.

Next, the horn will toot ever so slightly randomly. The sound is not at full level, but rather sound like a light tap. It will honk several times each time when it honks. I checked the contact, spring, wiring, everything is normal.

Finally, my door lock will make a ticking noise, but at a faster pace than a clock's tick. It seem that the lock is trying to acuate, but failing.

All these problems seem like it's casued by micro electrial pulses. I have checked the fuse box and rotated the relays to troubleshoot and eleminate the possibilty of a bad relay.

My next step will be taking it to the stealer to have them check it out. I just wanted to know if anyone out there has experienced anything like this. Any help will be greatly appreciated.
jjyu68 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-16-2011, 02:18 AM
BenzWorld Junior Member
 
Date registered: Feb 2008
Vehicle: Sprinter 312 4x4, 316 4x4, 316 4x2, 316 4x4, ML270
Location: Officer Vic
Posts: 27
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
This reminds me of a similar problem which turned out to be damage to a loom done by a mouse biulding a nest in the large grommet in the fire wall. Eric.
Eric Dodge is offline  
post #3 of 10 (permalink) Old 02-16-2011, 08:37 AM
BenzWorld Elite
 
Date registered: Jul 2006
Vehicle: 1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Location: NW Arkansas, La Jolla CA, Hong Kong
Posts: 6,817
Mentioned: 4 Post(s)
Quoted: 102 Post(s)
Personally, I would check the condition of the battery... pending/borderline low voltage in the ML can bring up some very wierd electrical gremlins..I haven't seen the wiper one...but the "bliping horn".. I have seen...

Good luck - keep the faith !
fabbrisd1 is offline  
post #4 of 10 (permalink) Old 02-23-2011, 09:32 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 2005 ML350 SE; 2005 Dodge Viper; 2003 Porsche 996 Cab.; 1966 Pontiac GTO
Location: California
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by fabbrisd1 View Post
Personally, I would check the condition of the battery... pending/borderline low voltage in the ML can bring up some very wierd electrical gremlins..I haven't seen the wiper one...but the "bliping horn".. I have seen...

Good luck - keep the faith !
Thanks for the suggestion.

My battery is only a few months old, so that eliminated the poor battery condition theory. I think the problem might stem from the battery change. Maybe damaged circuits from improper procedures?

Now I am hearing ticking sounds from behind the dash board, similar to that of the door lock. It seems that the relay ticking noises is spreading to other electrical components.
jjyu68 is offline  
post #5 of 10 (permalink) Old 03-07-2011, 11:05 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2008
Vehicle: 2005 ML350 SE; 2005 Dodge Viper; 2003 Porsche 996 Cab.; 1966 Pontiac GTO
Location: California
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Update.

Brought the car back from the stealer. I was charged $165 for an hour of diagnostics. Conclusion: they don't know what's going on. They ask me to take the car straight there next time when the car is acting up so they can read the codes. What a waste of my time and money.
jjyu68 is offline  
post #6 of 10 (permalink) Old 03-08-2011, 04:05 AM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 13,754
Mentioned: 11 Post(s)
Quoted: 739 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by jjyu68 View Post
Update.

Brought the car back from the stealer. I was charged $165 for an hour of diagnostics. Conclusion: they don't know what's going on. They ask me to take the car straight there next time when the car is acting up so they can read the codes. What a waste of my time and money.
Remove both cover the the fuse/relay box and look for rodent damage.
Attached Files
File Type: pdf R&I Fuse & Relay Box.pdf (53.2 KB, 353 views)
43sqd is offline  
post #7 of 10 (permalink) Old 03-19-2012, 01:56 PM
BenzWorld Newbie
 
Date registered: Feb 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Updates?

Any updates or more insight into the issue? My '99 ML320 is doing the exact same thing.
BIG_B1977 is offline  
post #8 of 10 (permalink) Old 03-19-2012, 03:08 PM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 13,754
Mentioned: 11 Post(s)
Quoted: 739 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by BIG_B1977 View Post
Any updates or more insight into the issue? My '99 ML320 is doing the exact same thing.
Open the thread and then click and his name and send an email to him.
43sqd is offline  
post #9 of 10 (permalink) Old 08-13-2013, 11:09 AM
BenzWorld Newbie
 
Date registered: Aug 2013
Vehicle: ml350
Location: new jersey
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
help

I started having the same issue on my 05 ml350 I would like to know if you found any solution and what is the problem
nunez162002 is offline  
post #10 of 10 (permalink) Old 08-13-2013, 07:27 PM
BenzWorld Elite
 
Mars478's Avatar
 
Date registered: Nov 2011
Vehicle: Black 1999 ML320
Location: NYC
Posts: 1,203
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
You are most likely going to receive a reply as the one directly above yours (#8).

I would start a new thread describing your issues in detail. You are more likely to get help that way

ML320: 1999, black, in dash iPad Mini, LED tails, Facelift headlights with Hella E55's, 6k bulbs, RallyCrossed, and 250k and counting.

And a few other, less reliable cars...
Mars478 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Unusual Maintenance Costs for 2009-2010 ML350 MCF W164 M-Class 43 02-15-2012 09:30 PM
    Electrical Problems! yoffer W210 E-Class 14 10-01-2010 07:47 PM
    electrical problems? LesPaul2510 C208/A208 CLK-Class 4 09-07-2008 06:44 PM
    Electrical Problems jsupstarz R170 SLK-Class 0 05-22-2007 09:46 AM
    electrical problems... djplasticfork W163 M-Class 1 05-06-2003 08:24 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome