02 ML320 BAS/ESP/ETS/ABS Lights - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 02-18-2011, 03:10 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Alright too the car to a local independent and had the codes read Here's what the mechanic wrote c1200, c1010,c1314, c1022, c1141, c1140-008, c1100-016 (Dont know what the dashed suffixs are) I noticed that there are codes for steering angle sensor initialization, stop light switch, under voltage, some of this I have already done (new battery, brake light switch, and steering sensor initialization ) could some of some of these be old stored codes from some of the stuff already done ? Anyway the mechanic told me that I probably need a new ESP control module. Does this sound right. Anybody know how much the module is ? Does it have to be programmed or is it something I can change if bad?
np90fxrp is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 02-18-2011, 03:29 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 17,828
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 687 Post(s)
Lifetime Premium Member
If you know he was using an MB scanner/ computer or a pro grade one like the Solus
then the readings are probably valid. As you say you have addressed some of them.

Have the tech clear all of them as they are hard codes and won't go away by themselves.
Codes can breed codes. So drive it for a week or a couple of hundred miles after the codes
have been cleared and have it scanned again. Then you will know what codes are real
and what codes are ghost codes. Do not by any means just toss in an ESP module.
Some do need replacing, but your issue may just be a bad sensor.
Noodles is offline  
post #13 of 13 (permalink) Old 04-26-2011, 09:40 PM
tma
BenzWorld Junior Member
 
Date registered: Apr 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I live in a cold country and drive in icy roads. The 3 lights came on after the first few times using the brakes. The lights will off after I restart the engine and come back again after the more braking. I looked up the posts and replaced the battery and checked my brake switch, but the problem stays. I found a ABS relay in the fuse box (by the RHS of the engine). I swapped with the one next to it , I think it was the blower one. It fixed the problem. Now, some time I have to wait for a few seconds before my blower comes on.
tma is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    ML320 - My ABS, BAS, ESP, ETS lights are on and the Tranny wont shift out of 1st gear Wephunk1 W163 M-Class 92 04-20-2012 07:41 PM
    BAS ETS ESP ABS Lights...Help? vancevirgil W163 M-Class 20 09-04-2011 12:42 PM
    BAS/ESP,ETS,ABS lights all on zmanzbo W163 M-Class 38 12-01-2009 09:09 PM
    4 Lights up BAS.ESP.ETS.ABS mplays W163 M-Class 10 05-22-2009 12:17 AM
    01 ML320 ABS/ETS/BAS-ESP Lights On hlai W163 M-Class 6 06-21-2006 05:45 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome