Catalyst monitor never gets ready on OBDII after Oxygen sensor change - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-10-2011, 03:33 PM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Catalyst monitor never gets ready on OBDII after Oxygen sensor change

Had a code for Driver side O2 sensor. Never changed them since they new (13 years). So I changed the both front 2 with Bosch 17382. Reset the code. However, every OBDII monitor is ready except the Catalyst monitor after one month 2000 miles drive. No code except the not ready "c" icon on my OBDII. Anything wrong here? Am I missing some steps? Thanks!
idahombz is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-10-2011, 04:38 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Location: Dallas, Texas
Posts: 3,499
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It takes ~10 minutes at 50 mph on level road with minimal load changes. Do one run, turn key off for >10 seconds and repeat.

1972 280SEL 4.5
1999 ML320
2000 E320
Witek_M is offline  
#3 (permalink) Old 01-10-2011, 05:09 PM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
repeat once?
idahombz is offline  
#4 (permalink) Old 01-10-2011, 07:41 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Location: Dallas, Texas
Posts: 3,499
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Repeat once. Turn key off for >10 seconds, back on then read results.

In most states car passes emissions check with one monitor not ready.

1972 280SEL 4.5
1999 ML320
2000 E320
Witek_M is offline  
#5 (permalink) Old 01-11-2011, 05:13 AM
BenzWorld Senior Member
 
mbenz80's Avatar
 
Date registered: Dec 2009
Vehicle: 1999 ML320
Location: Chicago suburb
Posts: 423
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Was the cat. monitor ready before the O2s replacement?
I've always thought that the monitoring is done by the rear sensors.
I just changed (couple months back) both of my original front sensors, never even check with OBDII since I can step on it as hard as I want without CEL activation.

1999 ML320 223K miles
2003 Lexus GX470 280K miles
1980 280SE W126 EURO 142mph top speed (sold)
mbenz80 is offline  
#6 (permalink) Old 01-11-2011, 08:42 AM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
To Witek:

Did 52 MPH cruise 11 min then stop key off. Going back another 13min at 51MPH cruise. No change on the obdii, ie the catalyst is still not ready.

To mbenz80:

Was ready before. No CEL , just an O2 sensor code before I change the 2 front ones.


I tried another OBDII still got the same information. Is it possible I should go to indy to get SDS machine to reset it?
idahombz is offline  
#7 (permalink) Old 01-14-2011, 11:28 AM
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Update:

Catalyst monitor ready now!

I did lots 10 min+ 50MPH+ driving these days. Thanks Witek!
idahombz is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Oxygen Sensor / Lambda Sensor Voltage Testing cbc atl W124 E,CE,D,TD Class 8 01-04-2011 06:47 PM
How difficult is it to change Oxygen sensor 2 in bank 1? AMGSingh W208 CLK Class 5 11-21-2009 08:58 PM
how do you change an oxygen sensor row503 W208 CLK Class 1 02-28-2008 05:30 PM
help on change oxygen sensor echaocn AMG W210 E50 , AMG E55 1 10-04-2007 10:49 PM
OBDII Catalyst I/M Monitor "Not Ready" elk127 W163 M-Class 0 08-11-2005 07:36 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome