Multiple Misfire Cause? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-13-2010, 07:38 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2008
Vehicle: 2001 ML 320
Location: NY
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Multiple Misfire Cause?

I turned on my car a few days ago, there was a hard start. The car would increase rpm then drop and eventually shut off.

I used the obdII and picked up codes for Misfire in different cylinders and multiple misfire.

Initially, since the weather here in NY has been freezing, I thought maybe water in fuel so I added Water Removal.

That did not work, and changed the spark plugs. I still get the same codes. Any ideas or solutions?

Thanks
brklynrep88 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-13-2010, 08:44 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2008
Vehicle: 2001 ML 320
Location: NY
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
can a poor or malfunctioning fuel pressure regulator cause multiple misfire?? thanks
brklynrep88 is offline  
post #3 of 7 (permalink) Old 01-13-2010, 08:48 PM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Location: Dallas, Texas
Posts: 3,713
Mentioned: 0 Post(s)
Quoted: 64 Post(s)
Quote:
Originally Posted by brklynrep88 View Post
can a poor or malfunctioning fuel pressure regulator cause multiple misfire?? thanks
Yes it can. But so are hundred other things. What specific codes are you getting?

http://www.benzworld.org/forums/w163...ml#post3329300

1972 280SEL 4.5
1999 ML320
2000 E320
Witek_M is offline  
post #4 of 7 (permalink) Old 01-13-2010, 09:49 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2008
Vehicle: 2001 ML 320
Location: NY
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Misfire for each of the Cylinder 1/2/3/4/6 and multiple.random misfire
Each time I read the codes three cylinders would come up in the codes, I took it the reading a few times
brklynrep88 is offline  
post #5 of 7 (permalink) Old 01-14-2010, 06:02 AM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,281
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
Have you done the fuel filter update yet? Also noticed you did not mention changing the wires. What is your mileage?

Mike
Michael Pillay is offline  
post #6 of 7 (permalink) Old 01-14-2010, 11:17 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2008
Vehicle: 2001 ML 320
Location: NY
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
current mileage is 70,000.
fuel filter has been updated, and was changed within the last 6 months
fuel pump also has been changed with last year
brklynrep88 is offline  
post #7 of 7 (permalink) Old 01-14-2010, 11:58 AM
BenzWorld Elite
 
Witek_M's Avatar
 
Date registered: Sep 2008
Location: Dallas, Texas
Posts: 3,713
Mentioned: 0 Post(s)
Quoted: 64 Post(s)
Concentrate on things that affect all cylinders. It is unlikely that all coils/wires went bad overnight.

Fuel pressure? Delivery volume.
Fuel contamination. Diesel in tank.
Large vacuum leak.
Bad MAF.
Stuck open EGR valve.
Plugged up converters.

Do you have means of looking at live data stream?

1972 280SEL 4.5
1999 ML320
2000 E320
Witek_M is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Need your help - misfire - CEL comes on, now off, and no misfire Magnified W220 S-Class 1 06-16-2010 12:26 PM
    Multiple issues dsw7283 W124 E,CE,D,TD Class 3 07-06-2009 03:25 PM
    2005 c240 misfire on multiple cylinders jasonrcooke W203 C-Class 7 12-02-2008 02:42 PM
    multiple problems 2003 s600 W220 S-Class 9 04-29-2008 02:19 PM
    Multiple photos ghitos73 Test 0 04-30-2006 06:34 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome