ML-320 HORN PROBLEM - PLEASE HELP - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-28-2009, 11:40 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML-320 HORN PROBLEM - PLEASE HELP

I was hoping that someone could help with my problem. I have a 2000 model ML-320 and the horn stopped working. I checked the fuse under the hood (#37) and it is good. The horn relay for my vehicle is also appears to be in the under hood fusebox right in front of the horn fuse. I also looked in the passenger side footwell to confirm that there is nothing there related to the horn.

I see two horns under the front bumper (one on each side) and a thrid horn (I believe this is only for the panic alarm) located under the hood on the firewall behind the fuse box. This third horn does work when I activate the panic button on my remote.

Here are my questions:

1. Are the two horns independent of each other of if one goes bad do they both stop working?

2. Can I test the horn relay and if so how?

3. Can I test the horns and if so how?

Any other helpful hints you can provide would be greatly appreciated.

Thanks in advance for any help you can provide.
Likewho is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-28-2009, 12:28 PM
BenzWorld Elite
 
Date registered: Apr 2006
Vehicle: CL55
Posts: 1,523
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Search. Answered zillion times.
Alex L is offline  
post #3 of 6 (permalink) Old 04-28-2009, 01:23 PM
Lifetime Premium Member
 
Date registered: Aug 2006
Vehicle: 02 ML320 06 ML500
Location: Bronx, New York
Posts: 13,754
Mentioned: 11 Post(s)
Quoted: 739 Post(s)
Lifetime Premium Member
Remove the cover to the fuse/relay box. Turn the key to the on position. Have someone press the horn pad while you feel/listen to the horn relay. If it clicks then you are good up to the relay. Then with a test light, perform the same procedure and test the two contacts on the top of fuse #37. If the test light illuminates for both contacts, then your problem is with dirty contacts at the horn or the horns themselves are bad.

The alarm horn is not in any way connected to the regular horns. Roll down the driver's window and then lock the truk with your remote. Allow time for the alarm to set, then open the door from the inside. If the alarm sounds, then the alarm system is working properly and there is something wrong with the panic part of the remote key.
43sqd is offline  
post #4 of 6 (permalink) Old 04-28-2009, 06:08 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Gee your welcome too!
Likewho is offline  
post #5 of 6 (permalink) Old 04-28-2009, 06:10 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi 43sqd
Thanks for taking the time to help me. I really do appreciate your advise and I'll give it a go tomorrow. Thanks again
Likewho is offline  
post #6 of 6 (permalink) Old 04-28-2009, 06:19 PM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: City on the TN River
Posts: 10,650
Mentioned: 3 Post(s)
Quoted: 188 Post(s)
Lifetime Premium Member
I wouldn't fix it. I'd just put one of these stickers on the bumper, instead.
Attached Thumbnails
Click image for larger version

Name:	HornBroke.jpg
Views:	358
Size:	23.8 KB
ID:	235339  

2005 S430 4Matic 'Morton' W220.183 • 722.671 Rest in Peace

Bells and whistles are thorns and thistles.
cmitch is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    '83 240D Horn problem jamison9271 W123 E,CE,D,CD,TD,TE Class 1 04-18-2009 10:20 PM
    Horn Problem (A Little different) Benzlova W163 M-Class 6 11-14-2008 04:51 AM
    problem with my horn. ZEEK C208/A208 CLK-Class 0 06-20-2008 10:41 PM
    HORN FOR CLK 320 CAB 1999 bxclip C208/A208 CLK-Class 0 05-24-2008 11:09 AM
    My 320 ML horn failed this morning HELP ! uoowhoo W163 M-Class 4 11-20-2005 08:39 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome