ML320 won't stay running - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-14-2008, 06:18 AM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Apr 2008
Vehicle: 1998 ML320
Posts: 1
ML320 won't stay running

I have a 98 ML320 - it will crank and run for 2 seconds and then die. When it dies, I can hear what sounds like a backfire (but from the engine bay) - like a pop noise. I cannot get it to run any longer than that even if I step on the gas. The tachometer moves upto around 1200 rpm - so I guess that means my cps sensor is good.

For the key issue - I used the 5 second test (turn key to on position for 5 seconds and then turn key) to eliminate any key issues - the key works (my other 2 keys will not pass this test). Plus I can see the red led light come on. The remote does not work - maybe bad batteries. Would that make a difference, for example - if I had locked with the remote, remote batteries die, and I unlock with key? Would it cause the das system to not start? Should I put in new batteries and try it like that? Putting that aside, could there still be a problem with the aam?

I left the pressure gauge on the fuel line. It fell from 52 psi to 43 in the first 1/2 hour. Down to 36 psi in the next 1/2 hour. Then down to 30 psi in the next hour. 12 hours later it was down to 12 psi. Do I have a fuel pump or fuel regulator (fuel filter) problem?

I pulled 2 codes - p0110 and p0204. Cleared them, and they have not come back.

Is it still worth trying out to replace the cps or camshaft sensor? What does the backfire noise mean?
jessiesm1 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
'76 450 sl won't stay running squirrel_master Vintage Mercedes-Benz 4 09-16-2012 06:44 PM
'98 ML320 won't stay running dusk01 W163 M-Class 6 11-02-2007 03:30 PM
HELP ml wont stay running... canadaml General Mercedes-Benz 3 05-21-2007 05:13 PM
89 190e that wont stay running!! mercedesgirl W201 190 Class 2 09-26-2006 05:55 PM
car will not stay running MB250 Vintage Mercedes-Benz 32 04-15-2006 02:25 PM


All times are GMT -7. The time now is 05:10 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.