Resetting Service Indicator ML350 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-05-2008, 08:00 AM
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Resetting Service Indicator ML350

Hello Folks,

I recently changed the oil on my 2003 ML350 (didn't take it to the MB dealear) because it was due for the B-service (double wrench) and I am wondering if I could get any help/ advice on how to clear the service indicator.

I tried to follow the instructions in the owner's manual but was NOT successful after numerous attempts.

Any thoughts?

Thanks.......
alonzofynn is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-05-2008, 11:37 AM
BenzWorld Member
 
Date registered: Aug 2002
Vehicle: ML320
Location: Colorado
Posts: 303
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If you follow the instructions in the owner's manual exactly, you should be able to clear the service indicator, eventually.

That said, I think some ML on-board computers might be a little "touchy" that you might have to reset it serveral times before it would clear - case in point, my wife's uncle and I both have the same model year ML, however, I could clear my SI the first try but on his, I'd have to reset it at least 4~5 times before it would finally take, go figure.

Maybe his (and your's) have a "flakey" computer.
joeml is offline  
#3 (permalink) Old 02-20-2011, 02:27 PM
BenzWorld Newbie
 
Date registered: Feb 2011
Vehicle: 2007 Mercedes ML 350
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by alonzofynn View Post
Hello Folks,

I recently changed the oil on my 2003 ML350 (didn't take it to the MB dealear) because it was due for the B-service (double wrench) and I am wondering if I could get any help/ advice on how to clear the service indicator.

I tried to follow the instructions in the owner's manual but was NOT successful after numerous attempts.

Any thoughts?

Thanks.......
Hello,

I found it very hard to find the instuctions to reset my service indicator. They are several conflicting instructions and none of them worked on my ML 350 2007. I finally found this:
make sure car doors are closed,
Place Key in Position 1
Cycle cluster screen to the Odometer
Push R button 3 times

use arrows to get to the service items menu. Service 1, 2 3 (or ABC)
you can scroll through from there. I was dissapointed that so many forum members said it was in the service manual that came with the car. FSS reset information was NOT in my service manual . My manual said it could be done, but did not give instructions on how to do it. It said to refer to the SERVICE INSTRUCTION MANUAL.
Which does not come with your car.

Thank you BRIAN_74 I found these instuctions that you posted. You are a life saver
relaxnow is offline  
#4 (permalink) Old 02-21-2011, 05:20 AM
BenzWorld Elite
 
Date registered: Aug 2006
Vehicle: 02 ML320
Location: Bronx, New York
Posts: 11,007
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 115 Post(s)
Quote:
Originally Posted by relaxnow View Post
Hello,

I found it very hard to find the instuctions to reset my service indicator. They are several conflicting instructions and none of them worked on my ML 350 2007. I finally found this:
make sure car doors are closed,
Place Key in Position 1
Cycle cluster screen to the Odometer
Push R button 3 times

use arrows to get to the service items menu. Service 1, 2 3 (or ABC)
you can scroll through from there. I was dissapointed that so many forum members said it was in the service manual that came with the car. FSS reset information was NOT in my service manual . My manual said it could be done, but did not give instructions on how to do it. It said to refer to the SERVICE INSTRUCTION MANUAL.
Which does not come with your car.

Thank you BRIAN_74 I found these instuctions that you posted. You are a life saver
You are on the wrong forum.

W164 M-Class - Benzworld.org - Mercedes-Benz Discussion Forum
43sqd is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Resetting the Service A Indicator? Diggers W169 A-Class 18 04-02-2011 01:11 AM
Help Resetting Service Indicator 08cls550guy W211 E-Class 7 04-13-2008 06:17 PM
Resetting service indicator on Viano/New style Vito alanuk400 V-Class 4 11-01-2007 03:11 AM
Resetting Service Indicator slanford77 W211 E-Class 2 04-12-2007 07:10 PM
Resetting the maintenance indicator on the dash.... underdog R170 SLK Class 1 03-28-2004 04:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome