ML 430 Tune up instructions - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-07-2007, 07:39 AM
BenzWorld Newbie
 
Date registered: Jul 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
ML 430 Tune up instructions

I'm wondering if I can do a DIY tune up of my 2001 ML 430. Has anyone done this? Does anyone have step by step instructions?

Thanks!

-J
jrome74 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-07-2007, 11:27 AM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Location: Swartz Creek, MI
Posts: 4,695
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
DIY for spark plug change is on the w163 forum. Just do a search. Besides that what else do you want to do? There are also instructions to change front and rear diff fluid and transfer case fluid. I believe those are to be changes every 50,000 miles.

Mike
Michael Pillay is offline  
#3 (permalink) Old 07-07-2007, 11:59 PM
BenzWorld Extremist
 
busoptr's Avatar
 
Date registered: Oct 2006
Vehicle: 2000 ml430, 99 infiniti i30 limited edition
Location: california
Posts: 980
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by jrome74
I'm wondering if I can do a DIY tune up of my 2001 ML 430. Has anyone done this? Does anyone have step by step instructions?

Thanks!

-J

The ML has electronic ignition system so a tune up is basically changing spark plugs and spark plug cables, air filter change and if there are bad ignition coils you should replace it too. There is no need for distributor or rotor or timing gun. Yes it is a DIY, just do a search.
busoptr is offline  
#4 (permalink) Old 07-08-2007, 04:45 AM
BenzWorld Member
 
Date registered: Dec 2003
Vehicle: '99 ML430, 06 SRX AWD
Location: King of Prussia, Pa.
Posts: 328
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Is there a mileage life for the wires ?

ie. O2 sensors recommend replacement @ 100K
gw17625410 is offline  
#5 (permalink) Old 07-08-2007, 05:02 AM
BenzWorld Elite
 
Bogie's Avatar
 
Date registered: Aug 2006
Vehicle: 2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Location: Boston, MA
Posts: 2,126
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My wires went bad at 60k. I changed my plugs at 75k. They were still good, but nearly soldered in place.
Bogie is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome