Cel - P0456 - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-06-2007, 10:02 AM
BenzWorld Elite
 
MJ50's Avatar
 
Date registered: Nov 2003
Vehicle: W204 & W211
Location: S. Pasadena, CA
Posts: 2,419
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Question Cel - P0456

I got CEL a few days ago.
Bought OBDII scanner and got following message

P0456 - EVAP Evaporation Control System Leak Very Small

I have service due in 3k miles.
Is this something I can wait that long or should I take it to dealer asap to get it fixed? The car runs same as before btw.


2012 C250 AeroWerkz full wrap, 70 Ceramic Tint
2004 E55 MBenzNL (057,219,390,428,500,527,615,682,816,881,882,884, CLS63 IC, AMG Airbag, iPod, Euro Door Pins/Convex Mirrors/Trunklid), SL65 rims, RENNtech pulley
1985 190E 2.3-16 Ground Control
2004 ML350 MBenzNL
2003 C240 MBenzNL (PTS, IMS, euro COMAND, folding/convex mirrors, euro bi-xenons, SAM, MHI, euro trunklid, euro mat, steering wheel, etc...)
MJ50 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-06-2007, 06:33 PM
BenzWorld Elite
 
Date registered: Aug 2002
Vehicle: Black 2005 ML 500
Location: Galveston, TX
Posts: 1,662
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cel - P0456

Are you sure your gas cap is closed all the way in..? The cel light will turn on if the gas cap seal has a leak or if it is not closed all the way..

AC

2005 ML 500
Black, 18" AMG Wheels, 285/60R18 Yokohama Geolander HTS + Bi-Xenons(+ Drew's e-code mod, though the reflectors rusted off and do not give out much light anymore), Yakima roof bars, Akebono pads all around. Former vehicle 2001 ML 320 with 108K miles, when traded, and a large repair/defect history. After all these years of owning my current 2005 ML 500, it is a major unreliable vehicle with a very large/expensive repair/defect history and has been like this since brand new.
AC_ML is offline  
#3 (permalink) Old 01-06-2007, 09:47 PM
BenzWorld Elite
 
MJ50's Avatar
 
Date registered: Nov 2003
Vehicle: W204 & W211
Location: S. Pasadena, CA
Posts: 2,419
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
yeah, i put gas today and double checked the gas cap...
it's sealed until u clear click... (unless cap itself has some leak???)


2012 C250 AeroWerkz full wrap, 70 Ceramic Tint
2004 E55 MBenzNL (057,219,390,428,500,527,615,682,816,881,882,884, CLS63 IC, AMG Airbag, iPod, Euro Door Pins/Convex Mirrors/Trunklid), SL65 rims, RENNtech pulley
1985 190E 2.3-16 Ground Control
2004 ML350 MBenzNL
2003 C240 MBenzNL (PTS, IMS, euro COMAND, folding/convex mirrors, euro bi-xenons, SAM, MHI, euro trunklid, euro mat, steering wheel, etc...)
MJ50 is offline  
#4 (permalink) Old 01-07-2007, 08:13 AM
BenzWorld Elite
 
Date registered: Aug 2002
Vehicle: Black 2005 ML 500
Location: Galveston, TX
Posts: 1,662
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cel - P0456

Did you reset the CEL light, with your OBDII, to see if it will come up again..? On other vehicles, too, any disconnected/broken vaccum hoses will cause similar problems.. You may want to check your engine area hoses/connections just in case..

Or since you have only 3000 miles for service, they can hook it to the computer for a more detailed diagnostic. Unluckily our simpler OBDII's features (I have an ACTRON CP9145 scanner) are still not complete enough in many diagnostic/trouble shooting areas.

AC

2005 ML 500
Black, 18" AMG Wheels, 285/60R18 Yokohama Geolander HTS + Bi-Xenons(+ Drew's e-code mod, though the reflectors rusted off and do not give out much light anymore), Yakima roof bars, Akebono pads all around. Former vehicle 2001 ML 320 with 108K miles, when traded, and a large repair/defect history. After all these years of owning my current 2005 ML 500, it is a major unreliable vehicle with a very large/expensive repair/defect history and has been like this since brand new.
AC_ML is offline  
#5 (permalink) Old 01-07-2007, 08:17 AM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: Down by the river smoking a cigar
Posts: 9,993
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Lifetime Premium Member
Remove your engine cover and look at the left side for an aluminum tube that comes from the back of the engine and ends with a plastic cap towards the front. Make sure the plastic cap hasn't come loose. If this cap is loose, it will throw this code (happened to me a month ago).

2005 S430 4Matic 'Morton' W220.183 • 722.671 Transmission

Bells and whistles are thorns and thistles.
cmitch is offline  
#6 (permalink) Old 01-07-2007, 11:58 PM
BenzWorld Elite
 
MJ50's Avatar
 
Date registered: Nov 2003
Vehicle: W204 & W211
Location: S. Pasadena, CA
Posts: 2,419
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
ok, i'll take a look.


2012 C250 AeroWerkz full wrap, 70 Ceramic Tint
2004 E55 MBenzNL (057,219,390,428,500,527,615,682,816,881,882,884, CLS63 IC, AMG Airbag, iPod, Euro Door Pins/Convex Mirrors/Trunklid), SL65 rims, RENNtech pulley
1985 190E 2.3-16 Ground Control
2004 ML350 MBenzNL
2003 C240 MBenzNL (PTS, IMS, euro COMAND, folding/convex mirrors, euro bi-xenons, SAM, MHI, euro trunklid, euro mat, steering wheel, etc...)
MJ50 is offline  
#7 (permalink) Old 01-08-2007, 01:52 AM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
usually the common causes are the purge valve or the canister. I have seen a few leaky fuel tanks cause the issue. I just recently put a purge valve in a ML500 for the same code. Wee different code but same thing.
Streetglower is offline  
#8 (permalink) Old 01-14-2007, 10:11 AM
BenzWorld Elite
 
MJ50's Avatar
 
Date registered: Nov 2003
Vehicle: W204 & W211
Location: S. Pasadena, CA
Posts: 2,419
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
i removed the scanner and CEL is turned off for the last several days.... hope it will stay that way...


2012 C250 AeroWerkz full wrap, 70 Ceramic Tint
2004 E55 MBenzNL (057,219,390,428,500,527,615,682,816,881,882,884, CLS63 IC, AMG Airbag, iPod, Euro Door Pins/Convex Mirrors/Trunklid), SL65 rims, RENNtech pulley
1985 190E 2.3-16 Ground Control
2004 ML350 MBenzNL
2003 C240 MBenzNL (PTS, IMS, euro COMAND, folding/convex mirrors, euro bi-xenons, SAM, MHI, euro trunklid, euro mat, steering wheel, etc...)
MJ50 is offline  
#9 (permalink) Old 01-14-2007, 11:02 AM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
with evap leak codes, whether a big or small leak, it wont come right back. those kinds of codes take several drive cycles before it will return. it may return in a week, maybe 6 months depending on if you met the drive cylce.
Streetglower is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Cel penbed51 R170 SLK Class 9 12-27-2006 03:25 PM
Has your CEL just...... gsj224 W163 M-Class 1 05-17-2006 07:57 AM
CEL YOGGI W202 C-Class 9 04-03-2006 04:25 AM
Why I like my CEL Check Codes General Mercedes-Benz 5 03-06-2006 08:59 AM
Ok, my CEL came on ... JimB W163 M-Class 4 11-17-2005 07:29 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome