Hesitation above 3k RPM when accelerating - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-10-2006, 05:28 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Mar 2006
Posts: 1
Hesitation above 3k RPM when accelerating

I own a 2000 ML320 and today there was a need to floor the gas pedal to overtake 2 cars in front of me. As I floored the gas pedal at about 60 MPH, i noticed hesitation above 3k RPM. It felt as if the gas was cutting out and as a result the car started to jerk. It does not happen when I am cruising, only when i accelerate above 3k RPM. Does anyone have any ideas? Thanks in advance.

charles
polousa2000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2007, 01:35 AM   #2 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2007
Posts: 27
Did you find out the cause of this? I have a similar problem.

princeginge@yahoo.co.uk
AdamNEUK is offline   Reply With Quote
Old 02-21-2007, 01:40 AM   #3 (permalink)
Lifetime Premium Member
 
lorryfan's Avatar
 
Date registered: Jun 2006
Vehicle: 02 ML320; 08 E350 4MATIC - P1 & SPORT PKG
Location: San Diego
Posts: 320
Lifetime Premium Member
I get that too sometimes, but I thought that was the V6 kicking in when all of a sudden you make a switch from 40mph or less to 60mph in a split second.
lorryfan is offline   Reply With Quote
Old 02-21-2007, 09:25 AM   #4 (permalink)
BenzWorld Elite
 
Date registered: Aug 2002
Vehicle: Black 2005 ML 500
Location: Galveston, TX
Posts: 1,662
Hesitation above 3k RPM when accelerating

I had something similar when one of my coils went bad. At low rpms, it will work fine, but when I accelerated to higuer rpms, the whole engine will begin to miss and hesitate..

Use an OBDII to check which cylinders are missing, and you can change the coils to see if the cylinder number/side changes.. Make sure first that all your plugs/boots and connections are tight. If you have change spark plugs lately and did not push your boots all the way in, you may have similar simptoms.

Careful with the crooked dealers. Normally, they will string you with a list of other repairs/parts.. Normally, just one device breaks at a time.. If they come to you and want to change MAF, O2, Coils, etc.. go to another dealer because they are stringing you and can do it in different ways..


AC
__________________
2005 ML 500
Black, 18" AMG Wheels, 285/60R18 Yokohama Geolander HTS + Bi-Xenons(+ Drew's e-code mod, though the reflectors rusted off and do not give out much light anymore), Yakima roof bars, Akebono pads all around. Former vehicle 2001 ML 320 with 108K miles, when traded, and a large repair/defect history. After all these years of owning my current 2005 ML 500, it is a major unreliable vehicle with a very large/expensive repair/defect history and has been like this since brand new.
AC_ML is offline   Reply With Quote
Old 02-22-2007, 04:44 AM   #5 (permalink)
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Location: Swartz Creek, MI
Posts: 4,655
Is the check engine light on? On my slk, it missed between 2000 and 3000 rpms. Turned out the MAF needed cleaning. If it is the MAF, you will get codes P0170 and p0173. Codes P0300, P030x are misfires. x=1-6
__________________
Mike

Last edited by Michael Pillay; 02-23-2007 at 04:32 AM.
Michael Pillay is offline   Reply With Quote
Old 02-22-2007, 09:59 AM   #6 (permalink)
BenzWorld Elite
 
Date registered: Apr 2006
Posts: 1,495
Quote:
Originally Posted by polousa2000
I own a 2000 ML320 and today there was a need to floor the gas pedal to overtake 2 cars in front of me. As I floored the gas pedal at about 60 MPH, i noticed hesitation above 3k RPM. It felt as if the gas was cutting out and as a result the car started to jerk. It does not happen when I am cruising, only when i accelerate above 3k RPM. Does anyone have any ideas? Thanks in advance.

charles
Search on "MAFS" or Mass Airflow sensor...
DaveN007 is offline   Reply With Quote
Old 02-22-2007, 09:49 PM   #7 (permalink)
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: ML320 CDI 2006 SAAB 9-3 Convertible 2004
Location: Melbourne, Australia
Posts: 68
I had this with my 2000 ML320 and was diagnosed as MAF going bad. Replaced and is driving like a sports car (OK, it revs cleanly right up to red line). But as was advised, get the codes checked first.
ml_saab is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W163 M-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:01 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.