93 300sd stereo problems - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-01-2012, 09:01 AM   #1 (permalink)
BenzWorld Member
 
Date registered: Oct 2011
Vehicle: 1985 500SEC, 1993 300SD
Location: Windermere, Florida
Posts: 69
93 300sd stereo problems

Hey guys back again with some stereo problems. I have a Becker stereo with the iPod hookup from the manufacturer and im getting some back cracking on the right side speakers. I was told that the amps in these cars had a problem and sometimes went and was looking to see if it's true or not. Also front to back fader seems to work but when I go to the front speakers all I get is the center one behind the mirror but when in middle seem to hear front door speakers but also no sound from four deck speakers. Baffled .please help. Thanks
leo500sec is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-02-2012, 10:47 PM   #2 (permalink)
BenzWorld Extremist
 
glenlloyd's Avatar
 
Date registered: Apr 2005
Vehicle: 92 W140 300SD 97 VW Jetta TDI 89 VW Fox diesel
Location: Iowa
Posts: 990
prolly the amp, it's the weakest part of the system.
__________________
92 W140 300SD "Bender"
97 VW Jetta TDI
89 VW Fox diesel
94 Chevy K1500 6.5TD
82 Suzuki GS1100E
glenlloyd is offline   Reply With Quote
Old 02-12-2012, 10:36 AM   #3 (permalink)
BenzWorld Member
 
Date registered: Oct 2011
Vehicle: 1985 500SEC, 1993 300SD
Location: Windermere, Florida
Posts: 69
thanks Glen,
Now for the million dollar question, I see that some amps say from 92-99 and others say 92-93 any input the plug looks a little different.
Leo
leo500sec is offline   Reply With Quote
Old 02-12-2012, 12:30 PM   #4 (permalink)
BenzWorld Extremist
 
aboynton's Avatar
 
Date registered: Jun 2005
Vehicle: 93 500SEL DOA - PARTING OUT, 08 CLK350 Cab -DOA, '05 CLK500 Cab (hers), '10 Razor Elec Scooter (his)
Location: Northern California's Great Central Valley - Meth Capital of USA
Posts: 1,061
For $500 you can send your amp off to Radioman in San Diego for repair if you want to retain the originality of the audio system.

You also can swap the amp out, but I believe the tuner is in there as well, so you'd also have to swap out the head unit.

The FM tuner is shot in my 1993 and I am probably going to chuck the whole lot in the bin and upgrade to a full-featured and better sounding modern setup and less than $500 will get me there.
aboynton is offline   Reply With Quote
Old 02-12-2012, 12:55 PM   #5 (permalink)
Lifetime Premium Member
 
Merc-S600's Avatar
 
Date registered: Aug 2007
Vehicle: Merc 93 W140 S600 / Merc-05-413CDI-Sprinter Turbo / 07-A170-Classic / Holden Rodeo RA 3.5L V6 <
Location: Sydney / Australia
Posts: 4,614
Lifetime Premium Member
Knock your self out with tonnes of info regarding the problem you have in the link below (pictures,links adresse's etc ), your AMP is 7 channel so to fix that at the radioman you be wasting a good 300 bucks to much of the 500,way to expensive ,Leo will look after you like he has with many of us .
The AMP is not interchangable between models 91-93 to 94-98/9 as the plugs change and the AMP itself ,you also have a Tuner in there like "Aboynton" mentions above ,it is always good to send them together to be fixed or check't up,a mini service sort off for the tuner.
Crackiling indicates AMP capacitors leaking .

http://www.benzworld.org/forums/w140...pter-w140.html

1st Picture (dusty amp) is your AMP in your car (91&93 ) / 2nd Picture is the later model 94 & up .
Attached Images
   
__________________
>>>>>>>>>>>>>>>>
Driving a W140 & everything else feels like is standing still . - Merc S-600 = Chris


Like to see more of my S600 ----- ALL AUSTRALIAN W140 OWNERS ,CLICK ME:

Last edited by Merc-S600; 02-12-2012 at 01:09 PM.
Merc-S600 is offline   Reply With Quote
Old 02-15-2012, 09:27 AM   #6 (permalink)
BenzWorld Extremist
 
glenlloyd's Avatar
 
Date registered: Apr 2005
Vehicle: 92 W140 300SD 97 VW Jetta TDI 89 VW Fox diesel
Location: Iowa
Posts: 990
Quote:
Originally Posted by leo500sec View Post
thanks Glen,
Now for the million dollar question, I see that some amps say from 92-99 and others say 92-93 any input the plug looks a little different.
Leo
They used that system for two years then went to a different setup. There are some reputable shops that will repair your amp for somewhere between $200-$300 which would be worth it. The problem is with the capacitors inside the amp, they all need to be replaced. It's time consuming work.

I'd repair the existing system but that's just my preference.
glenlloyd is offline   Reply With Quote
Old 03-04-2012, 04:01 PM   #7 (permalink)
BenzWorld Member
 
Date registered: Oct 2011
Vehicle: 1985 500SEC, 1993 300SD
Location: Windermere, Florida
Posts: 69
Thank you all, now I have to find a reputable repair shop, and seeing that I want to keep the car original.
leo500sec is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
1982 Mercedes 300SD Euro Look, Chrome Wheels, New Stereo, New suspension, Bio Diesel smokingtires For Sale/Wanted/Trade/Giveaway 2 12-10-2010 11:17 AM
1980 300sd stereo upgrade need help tallerthanu420 Audio & Telematics Forum 0 08-08-2008 05:57 AM
Stereo for 300SD studlygerman For Sale/Wanted/Trade/Giveaway 1 08-17-2006 03:21 PM
new stereo wiring power antena on 85 300sd cornpone General Mercedes-Benz 1 04-09-2006 04:29 PM
w126 300sd alarm and stereo cornpone General Mercedes-Benz 1 04-01-2006 09:49 AM


All times are GMT -7. The time now is 07:21 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.