Radio wiring diagram needed...W140..1992 500 SEL - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-14-2010, 10:41 PM
Lifetime Premium Member
 
Benica's Avatar
 
Date registered: Sep 2010
Vehicle: 2002 Black SL500, 2000 Azure blue SL500, '68 VW Fiberglass Dune Buggy, '05 Black CL55 AMG Coupe.
Location: Around the world...TDY between Omaha and Honolulu.
Posts: 343
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Lifetime Premium Member
(Thread Starter)
Radio wiring diagram needed...W140..1992 500 SEL

Any one have one? Any links?
I need to know what wire goes where for the dash radio...back of the radio has 5 spots for connectors....what goes where?
The wiring harness was cut at al the connectors and the aftermarket harness spliced in...same with the tuner in the trunk...
I am installing the original MB radio....but the the wiring harness (dash) has a number of color coded wires....what color(s) are connected to the speakers, etc?
The trunk tuner..same thing...
I should never have taken out the original radio....anyway.....
Thanks all!
Benica is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-15-2010, 04:06 AM
~BANNED~
 
Date registered: Aug 2008
Vehicle: 93 300se,92 300se,93 600 sel,92 500 sel,79 500slc,02 1.8t bug,01 a8,01 s80 t6,96 bmw 740il,86 rx7
Location: MN
Posts: 822
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to phamilton01
Ill send it to you via email....
phamilton01 is offline  
#3 (permalink) Old 09-15-2010, 12:50 PM
Lifetime Premium Member
 
Benica's Avatar
 
Date registered: Sep 2010
Vehicle: 2002 Black SL500, 2000 Azure blue SL500, '68 VW Fiberglass Dune Buggy, '05 Black CL55 AMG Coupe.
Location: Around the world...TDY between Omaha and Honolulu.
Posts: 343
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Lifetime Premium Member
(Thread Starter)
Quote:
Originally Posted by phamilton01 View Post
Ill send it to you via email....
Thanks phamilton01~
Received it and waiting on the harness...then the fun begins!
Benica is offline  
#4 (permalink) Old 09-16-2010, 04:09 PM
Lifetime Premium Member
 
Merc-S600's Avatar
 
Date registered: Aug 2007
Vehicle: Merc 93 W140 S600 / Merc-05-413CDI-Sprinter Turbo / 07-A170-Classic / Holden Rodeo RA 3.5L V6 <
Location: Sydney / Australia
Posts: 5,411
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Lifetime Premium Member
Hi Benica
How come you are Reinstalling the Original Radio ?
There are lot's of Aftermarket Radio's ( Kenwood / Alpine / Pioneer etc just to name a few ) wich blow the Original Sound out of the Way with the right Setup if it is done Properly .
Maybe you have been disgusted by the Radios Sound with a bad Setup instalation .The Way i have mine in ,i would never go back , only upgrade to a better Brand .
Dont know if you have seen this but just check it out ,maybe there is some easy fix for you within all of those Post's ,after all your Car is the same like mine /1993.
Ciao

http://www.benzworld.org/forums/w140...pter-w140.html

>>>>>>>>>>>>>>>>
Driving a W140 & everything else feels like is standing still . - Merc S-600 = Chris


Like to see more of my S600 ----- ALL AUSTRALIAN W140 OWNERS ,CLICK ME:
Merc-S600 is offline  
#5 (permalink) Old 09-16-2010, 10:05 PM
BenzWorld Member
 
VictorS500's Avatar
 
Date registered: Jun 2006
Vehicle: 91 500SL, 93 600SL, 95 S600 coupe, 97 S320, 99 ML430, 2000 S430
Location: Brooklyn, NY
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had Alpine CD/MP3 player in dash with stock Bose amp in my 92 S500. It blows stock radio away. MUCH nicer sound with Alpine. I would never go to stock cassette player if I were you.


Sold:
88 420 SEL, 90 300E, 92 500SEL, 2x 94 S420s, 96 E320, 97 E320, 97 C280
VictorS500 is offline  
#6 (permalink) Old 09-16-2010, 10:28 PM
Lifetime Premium Member
 
Benica's Avatar
 
Date registered: Sep 2010
Vehicle: 2002 Black SL500, 2000 Azure blue SL500, '68 VW Fiberglass Dune Buggy, '05 Black CL55 AMG Coupe.
Location: Around the world...TDY between Omaha and Honolulu.
Posts: 343
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Lifetime Premium Member
(Thread Starter)
Quote:
Originally Posted by merc s500 View Post
Hi Benica
How come you are Reinstalling the Original Radio ?
There are lot's of Aftermarket Radio's ( Kenwood / Alpine / Pioneer etc just to name a few ) wich blow the Original Sound out of the Way with the right Setup if it is done Properly .
Maybe you have been disgusted by the Radios Sound with a bad Setup instalation .The Way i have mine in ,i would never go back , only upgrade to a better Brand .
Dont know if you have seen this but just check it out ,maybe there is some easy fix for you within all of those Post's ,after all your Car is the same like mine /1993.
Ciao

http://www.benzworld.org/forums/w140...pter-w140.html
I know that some of the aftermarket radios are great! I have one. It's just a personal choice...had the car since it was NEW...18 years...and I want to keep it stock.....I don't need a killer sound system....the original is loud enough for me.
I just wish the 1432 could be fitted with a USB connector.
Benica is offline  
#7 (permalink) Old 09-19-2010, 04:21 AM
BenzWorld Member
 
Date registered: Oct 2007
Vehicle: 1988 W126 560SE
Location: SERBIA , BELGRADE
Posts: 85
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I also need radio wiring diagram for w140 s320 year92 ,
thank you in advance , Shomikus
shomikus is offline  
#8 (permalink) Old 09-19-2010, 10:52 AM
BenzWorld Elite
 
shingleback's Avatar
 
Date registered: Apr 2006
Vehicle: '98 E300, '03 3.2TL-S 'A-Spec', '92 S500 (sold), '87 190D 2.5 Turbo (RIP)
Location: Vancouver, Canada
Posts: 1,236
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Benica View Post
I just wish the 1432 could be fitted with a USB connector.
It can, you just have to send it to Becker; see here

exchange_vs_epair
shingleback is offline  
#9 (permalink) Old 11-07-2010, 08:08 AM
BenzWorld Newbie
 
Date registered: Nov 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Could someone please help?

I have a 92 500SEL and am trying to wire in an aftermarket radio to the amp. I figured most of it out with the meter and other threads. Anyone have a wiring diagram for it, (w140) it is not the same as the 300SE.

I ran speaker wires, a power lead, antenna extension, and an amp trigger wire from the head unit to the trunk. Went in two channels to the amp, connected the trigger, power lead and grounded from the ground wire on the power led plug into the trunk.

I get a buzzing sound, and the amp only kicks on sometimes, and even then only the front door speakers work.

Any advice would be awesome, as would a real wiring diagram for it.

Thanks folks.
Cville is offline  
#10 (permalink) Old 11-02-2011, 11:22 AM
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: 1999 E320
Location: Canada
Posts: 103
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have a 1995 s-350td and wanted to know how to wire up the aftermarket cd player/radio. I took out the old head unit and just wanted to know how to wire the new one, or would it just be easier to pay future shop $70 to do it? Thanks
s-350d is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Wiring diagra w140 500 SEL ikarin W140 S-Class 5 01-06-2010 02:39 AM
1982 500 SEL W126 WIRING DIAGRAM ? zedmolly W126 S,SE,SEC,SEL,SD,SDL Class 3 11-25-2009 06:56 PM
wiring diagram for radio on 1992 2.3 4 cylinder snakehips916 W201 190 Class 3 09-19-2008 04:49 PM
1989 420 SEL Radio Wiring Diagram/Schematics? chaoticjen Audio & Telematics Forum 0 04-08-2007 09:25 AM
Wiring Diagram (or at least a radio wiring diagram) for ML320 yawstring W163 M-Class 3 07-02-2003 05:12 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome