Windshield Washer System - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-06-2010, 10:48 PM
iss
BenzWorld Extremist
 
iss's Avatar
 
Date registered: Aug 2009
Vehicle: 1998 Mercedes-Benz S500
Location: Kent,WA
Posts: 877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Windshield Washer System

Hi to ALL!!! I been having problems with my windshield washer system (From the time I bought a car (7-9 months ago)) - not spraying and even no sound from the pump. SO TODAY i check all connectors and water tubs and they all OK! I almost pulled out the washer fluid reservoir to see my pump and so by chance I saw the collapse of the insulating tube in which I found broken wires. Connect them together and-the miracle it work!!! pictures will say more......
Attached Thumbnails
Click image for larger version

Name:	DSC04945.JPG
Views:	163
Size:	92.3 KB
ID:	300800   Click image for larger version

Name:	DSC04947.JPG
Views:	78
Size:	46.8 KB
ID:	300801   Click image for larger version

Name:	DSC04948.JPG
Views:	78
Size:	62.4 KB
ID:	300802   Click image for larger version

Name:	DSC04950.JPG
Views:	88
Size:	68.6 KB
ID:	300803   Click image for larger version

Name:	DSC04952.JPG
Views:	101
Size:	194.2 KB
ID:	300804  


Oh MAN!!! Every second i am older and older!
iss is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-06-2010, 10:49 PM
iss
BenzWorld Extremist
 
iss's Avatar
 
Date registered: Aug 2009
Vehicle: 1998 Mercedes-Benz S500
Location: Kent,WA
Posts: 877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Windshield Washer System
Attached Thumbnails
Click image for larger version

Name:	DSC04953.JPG
Views:	191
Size:	68.1 KB
ID:	300805   Click image for larger version

Name:	DSC04955.JPG
Views:	127
Size:	77.8 KB
ID:	300806  

Oh MAN!!! Every second i am older and older!
iss is offline  
#3 (permalink) Old 04-07-2010, 02:33 AM
BenzWorld Extremist
 
bobs's Avatar
 
Date registered: Dec 2007
Vehicle: '97 S320 (LWB), '01 E320
Location: Richmond, VA, USA
Posts: 1,141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Interesting... What you repaired there was just the connector to washer fluid level sensor. The washer pumps (one for the windshield and one for the headlights) are located on the bottom, outboard side of the reservoir. You have to pull the belly pan off to get at them.

They must share a common ground wire

"It's not about how fast you can go, but how well you can go fast."

'97 S320 (LWB), Ruby Red Metallic/Tan, 75k miles
'01 E320, Black/Charcoal, 105k miles

Gone but not forgotten. . .
'97 S420V, Smoke Silver Metallic/Tan, (RIP 22 Oct 2012, 178627 miles) He gave his life to save mine.
bobs is offline  
#4 (permalink) Old 04-07-2010, 10:17 AM
iss
BenzWorld Extremist
 
iss's Avatar
 
Date registered: Aug 2009
Vehicle: 1998 Mercedes-Benz S500
Location: Kent,WA
Posts: 877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
no i did not touch the level senser wire,there was another one see my marks,there was a 3 wire cable.
Attached Images
   

Oh MAN!!! Every second i am older and older!
iss is offline  
#5 (permalink) Old 04-07-2010, 04:19 PM
BenzWorld Member
 
Date registered: Dec 2006
Vehicle: 1999 S500 GRAND EDITION (32,800 Miles)
Location: Seattle, WA
Posts: 269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Very interesting

Thank you for the write up and pics. I had no idea that that system was buried so deep in the car.

Telechronos

1999 S500 Grand Edition
1984 380 SL
1955 MG TF1500
1969 Factory Stick, Factory Tri-Power Pontiac Grand Prix SJ
telechronos is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
problem with braking light and windshield washer system WANTAMB W123 E,CE,D,CD,TD,TE Class 3 02-12-2010 10:50 AM
Help with Spray Nozzle in Windshield Washer System 1999 SLK 230 dbottoms R170 SLK Class 4 01-11-2010 03:00 PM
windshield washer Dukegrad R170 SLK Class 4 03-22-2009 12:18 PM
windshield washer kdude87 W210 E-Class 4 01-20-2008 11:43 PM
Windshield Washer alfredgee W123 E,CE,D,CD,TD,TE Class 3 02-18-2005 05:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome