slow speed on blower (96 S500) - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-08-2010, 04:58 AM
BenzWorld Junior Member
 
Date registered: Jul 2007
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
slow speed on blower (96 S500)

hi all, recently the blower started acting up and would not come on then would go off. figured it was the regulator (had similar problem on a friends e-class). i got a regulator of e-bay (fraction of dealers price) and fitted it. blower now works without cutting out but i have no slow setting. With the display set on the first bar the blower runs as if it was on four bars. three bars is now the same as the old one on full speed. is this a faulty (cheap) regulator or is there some way of syncronising the speeds on the display to that of the regulator. any help appriciated.


Brian.....
mooneys500 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-08-2010, 05:33 AM
BenzWorld Member
 
klwinkel's Avatar
 
Date registered: Sep 2009
Vehicle: W140 1997 S500
Location: Europe - Netherlands
Posts: 193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
seems like a faulty regulator, or you did not connect it as it should (but I thing there is no way to do it wrong.)

contact the ebay seller..... he is probably willing to send you another one, they don't like the negative feedback.
klwinkel is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
99 E320 ac working yet blower weak/slow??? DominicArnold W210 E-Class 2 07-26-2008 09:36 AM
Slow Speed Viberations tbarlas W124 E,CE,D,TD Class 10 08-15-2007 11:00 PM
Slow A/C blower motor? sdiianni W124 E,CE,D,TD Class 2 01-13-2007 05:58 PM
Heater/AC blower seems slow...sounds bad Benz4Dirt&Sky W163 M-Class 4 11-29-2004 10:21 AM
slow speed shifting.... 4x4Runner09 R170 SLK Class 0 12-05-2003 10:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome