S320 running rough after timing cover reseal - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-16-2009, 06:22 PM   #1 (permalink)
BenzWorld Member
 
Date registered: May 2008
Vehicle: 1994 Mercedes-Benz S320 SWB
Location: Modesto
Posts: 93
Send a message via AIM to adam94
S320 running rough after timing cover reseal

I replace my timing cover seal the other day along with the belt tensioner, Everything went back together good but once I started the car the idle was very unstable... like a slight miss

In park the rpms are at 700 to 750
When I put the car in gear it gets really bad and the rpms go from 500 to 750

-----------------------------

I checked if the spark plug wires were plugged in all the way and they were fine and in the correct order.

All sensors are plugged in and were functional before the repair.

I checked for vacuum leaks with carburator cleaner and I could not find anything

The wiring harness looks to be in alright condition.



What could it be?
adam94 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-16-2009, 09:06 PM   #2 (permalink)
BenzWorld Member
 
BENZBOSS's Avatar
 
Date registered: May 2006
Vehicle: 1999 S500 1999 S420 1994 S320 1994 E320
Location: San Diego CA
Posts: 268
Vacuum leak,check around ETA.Disconect the battery for 1 minute.
__________________
http://mercedes-bulgaria.com/
BENZBOSS is offline   Reply With Quote
Old 06-17-2009, 03:14 PM   #3 (permalink)
BenzWorld Member
 
Date registered: May 2008
Vehicle: 1994 Mercedes-Benz S320 SWB
Location: Modesto
Posts: 93
Send a message via AIM to adam94
what is the ETA?
adam94 is offline   Reply With Quote
Old 06-17-2009, 04:33 PM   #4 (permalink)
BenzWorld Member
 
stox's Avatar
 
Date registered: Dec 2004
Vehicle: 1996 C36, 1995 S500 Coupe, 1985 190E 2.3
Location: Westmont, Illinois
Posts: 301
Send a message via Yahoo to stox
ETA=Electronic Throttle Actuator. What used to be called a throttle body until it became servo controlled.
stox is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
M104 Timing Cover Reseal !!!HELP!!! adam94 W140 S-Class 3 06-14-2009 04:28 PM
104 engine timing chain cover reseal procedure cpiad W210 E-Class 26 05-27-2009 04:31 AM
1994 E320 reseal top cam/timing cover hantour W124 E,CE,D,TD Class 7 02-06-2009 02:41 PM
timing chain allignment on a 1994 s320 er7383noc General Mercedes-Benz 0 12-22-2008 08:23 PM
96 S320 ROUGH idle & running anhtuanle W140 S-Class 22 05-14-2008 10:55 AM


All times are GMT -7. The time now is 12:16 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.