dreaded wiring harness? 94 s350 diesel - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-20-2009, 08:45 PM
BenzWorld Newbie
 
Date registered: Mar 2009
Vehicle: 1994 S350D
Location: hot humid houston texas
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
dreaded wiring harness? 94 s350 diesel

I bought an excellent condition S350 with 109,050 miles that now is beginning to have mutiple warning light indicators (e.g. ABS, SRS, battery indiators) come on. It is starting to run sluggish as well along with the AC not blowing cold, along with a sluggish power steering. Jointly, the cruise or rear window defogger is not working though the later two issues was purchased this way. I am reading alot about the wiring harness defects but don't know exactly where they are located. Does anyone have a photo showing these - preferably an actual photo or photo drawing (not eletrical drawing)? There is one large cable that has a part number ending in 2005 which I think is an engine harness. It starts near the air intake and loops back to the fire wall and down to the injector area. The insulators look good on it so it must of been replaced. If anyone has any guidance please share as I prefer to do this myself versus wrestle with a dealership or MB. I can't even find aftermarket harnesses. I prefer to not go through MB if they will deteriorate again.

thanks in advance

Robert
rhoadrw is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-28-2009, 10:06 AM
BenzWorld Member
 
muleears's Avatar
 
Date registered: May 2006
Vehicle: '02 S430, '02 Golf GL, '10 Accent GLS
Location: Hampton Roads, VA
Posts: 159
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would like the answer to this also as I am looking at a S350D (yes, I know, rod bender). I thought the decaying harness was straightened out by '94?

Cal
02 S430 181K miles
10 Hyundai Accent (wife's grocery getter)
02 Golf GL Son's college car
Hampton Roads, VA, USA
muleears is offline  
#3 (permalink) Old 03-28-2009, 04:25 PM
Premium Member
 
bayhas's Avatar
 
Date registered: Oct 2005
Vehicle: SL55, SL500, 300SE, ML430, Saturn SCX 1.9L DOHC.
Location: Lincoln / Boston - MA
Posts: 8,821
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Premium Member
Garage
Send a message via MSN to bayhas Send a message via Yahoo to bayhas
no, not until late 95 early 96 when they changed the insulation used...

however, 1992-1995 harnesses you buy from the delaer or made after 97 as a replacement part are already using better plastic insulation.

Garage:

Mercedes-Benz, W140 S Class S320 (AKA 300SE)

Mercedes-Benz, R230 SL Class SL55 (///AMG)

Mercedes-Benz, R129 SL Class SL500 (AKA 500SL)

Mercedes-Benz, W163 ML Class ML430 (Designo Edition)

Triumph Daytona 955i - SSSA

Former Mercs:
W140 S Class 500SEL(sold) - W140 S Class S320(sold) - W140 S Class S500(sold) - W140 S Class 500SEL(sold) - W201 190E 2.3(sold)
bayhas is offline  
#4 (permalink) Old 03-28-2009, 04:36 PM
Premium Member
 
bayhas's Avatar
 
Date registered: Oct 2005
Vehicle: SL55, SL500, 300SE, ML430, Saturn SCX 1.9L DOHC.
Location: Lincoln / Boston - MA
Posts: 8,821
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Premium Member
Garage
Send a message via MSN to bayhas Send a message via Yahoo to bayhas
Quote:
Originally Posted by rhoadrw View Post
I bought an excellent condition S350 with 109,050 miles that now is beginning to have mutiple warning light indicators (e.g. ABS, SRS, battery indiators) come on. It is starting to run sluggish as well along with the AC not blowing cold, along with a sluggish power steering. Jointly, the cruise or rear window defogger is not working though the later two issues was purchased this way. I am reading alot about the wiring harness defects but don't know exactly where they are located. Does anyone have a photo showing these - preferably an actual photo or photo drawing (not eletrical drawing)? There is one large cable that has a part number ending in 2005 which I think is an engine harness. It starts near the air intake and loops back to the fire wall and down to the injector area. The insulators look good on it so it must of been replaced. If anyone has any guidance please share as I prefer to do this myself versus wrestle with a dealership or MB. I can't even find aftermarket harnesses. I prefer to not go through MB if they will deteriorate again.

thanks in advance

Robert
All of these problems and you are considering the car to be in excellent contdition?

Anyway, the harness, as the name suggests, is a wiring harness that connects the main components of the upper end of the engine.

Best way to track it, look at the injectors, and check the condition of wires hooked up to them. thats the harness.

From the symptoms you are describing, check your battery and charging system

Garage:

Mercedes-Benz, W140 S Class S320 (AKA 300SE)

Mercedes-Benz, R230 SL Class SL55 (///AMG)

Mercedes-Benz, R129 SL Class SL500 (AKA 500SL)

Mercedes-Benz, W163 ML Class ML430 (Designo Edition)

Triumph Daytona 955i - SSSA

Former Mercs:
W140 S Class 500SEL(sold) - W140 S Class S320(sold) - W140 S Class S500(sold) - W140 S Class 500SEL(sold) - W201 190E 2.3(sold)

Last edited by bayhas; 03-28-2009 at 04:44 PM.
bayhas is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
The dreaded wiring harness! dealmaker883 W124 E,CE,D,TD Class 9 07-25-2008 01:59 PM
1992 S350 Diesel 108Benz W140 S-Class 2 02-01-2008 02:18 PM
Should I expect to have the dreaded wiring harness problem? echandler W140 S-Class 8 01-21-2008 08:36 PM
1993 600SEL body harness vs. wiring harness Sojourner43 W140 S-Class 6 09-17-2007 11:34 PM
1994 s350 diesel harleyman07105 W140 S-Class 0 07-13-2005 09:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome