do you have a coupe w/ seat belt extenders? Click here ... - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-27-2008, 08:21 PM
BenzWorld Veteran
 
Date registered: Dec 2003
Vehicle: 1996 S500 coupe
Location: Canada
Posts: 707
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
do you have a coupe w/ seat belt extenders? Click here ...

hey guys

I know there are 2 plastic gears that go mushy and SBE stops working on the coupe, and I think that's what has happened on my car .. I can hear the assembly making noises everytime i buckle and unbuckle the seat belt but the arm doesnt move

according to this site:

K6JRF Auto Page

the gears can be purchased in aluminum, but the new price is $72 ea (there's 4 of them for both sides)

is there any other gears that can be retrofitted in there? I dont wanna spend $300 on just some gears

also.. how do you remove the rear panel to access the SBE?

am I the only one whose SBE doesnt function or are there others coupe out there w/ the same issue?

1996 S500 coupe, black on black, 18" AMGs
snik is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-27-2008, 08:51 PM
BenzWorld Junior Member
 
Date registered: May 2007
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the same problem. I have just pulled out the fuse concerned in the trunk to kill the noise and use my own hand to pull the safety belt forward. By by doing so, you will disable at the same time the function of the front seats for easy access to the back seats.
jimmytsoi is offline  
#3 (permalink) Old 01-28-2008, 07:01 AM
BenzWorld Veteran
 
Date registered: Dec 2003
Vehicle: 1996 S500 coupe
Location: Canada
Posts: 707
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Quote:
Originally Posted by jimmytsoi View Post
By by doing so, you will disable at the same time the function of the front seats for easy access to the back seats.
can you please explain what this function is? I am not familiar with it

1996 S500 coupe, black on black, 18" AMGs
snik is offline  
#4 (permalink) Old 01-28-2008, 07:20 PM
BenzWorld Junior Member
 
Date registered: May 2007
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
When you push the back of either front seat forward, the whole seat will automatically move forward to let back-seat passengers enter. If you pull out the fuse of the safety belt extender, the back of either front seat can no longer be moved forward and you have to use the front seat controls at the door to move the front seats forward to let back-seat passengers in.
jimmytsoi is offline  
#5 (permalink) Old 01-28-2008, 07:44 PM
BenzWorld Veteran
 
Date registered: Dec 2003
Vehicle: 1996 S500 coupe
Location: Canada
Posts: 707
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Quote:
Originally Posted by jimmytsoi View Post
When you push the back of either front seat forward, the whole seat will automatically move forward to let back-seat passengers enter. If you pull out the fuse of the safety belt extender, the back of either front seat can no longer be moved forward and you have to use the front seat controls at the door to move the front seats forward to let back-seat passengers in.

ahh got it, thx

1996 S500 coupe, black on black, 18" AMGs
snik is offline  
#6 (permalink) Old 01-30-2008, 02:38 AM
BenzWorld Elite
 
Merc600sec's Avatar
 
Date registered: Mar 2004
Vehicle: SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Location: Leicestershire UK
Posts: 2,232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Merc600sec Send a message via Yahoo to Merc600sec
I will try to find the gears.. on my eng dist net.. what are the specs..dia pitch teeth etc..

Torque isn't cheap
Merc600sec is offline  
#7 (permalink) Old 07-01-2009, 07:18 AM
BenzWorld Junior Member
 
razerman's Avatar
 
Date registered: Jun 2007
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi.
My seat belt extenders have stopped working too. The gears are fine but there is a funny noise from a module attached below. Any idea where i can get one of these or what it would cost. The part number is 140 820 25 26.
Thanks
Razerman
razerman is offline  
#8 (permalink) Old 07-15-2009, 06:32 PM
BenzWorld Junior Member
 
razerman's Avatar
 
Date registered: Jun 2007
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I bought a replacement module on ebay for $140. Replaced it but it didn't fix the problem. If anyone needs this part, I have one for sale
Any ideas where to go next ot fix this? Both seat belt extenders have quit at the same time. Can't believe that it would the seat belt extender motors.
razerman is offline  
#9 (permalink) Old 07-19-2009, 09:58 AM
BenzWorld Junior Member
 
razerman's Avatar
 
Date registered: Jun 2007
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
There are two fuses for the seat belt extenders. One in the fuse panel under the hood and one in the trunk (RHS). The one under the hood was fine. THe one in the trunk had burnt. Replaced it but it would burn out as there was some sort of issue with the seat belt extender trying to reset itself to full retracted position. Had to replace the fuse about 4 times to allow it to reset itself and now it works fine.
razerman is offline  
#10 (permalink) Old 07-20-2009, 04:13 AM
BenzWorld Elite
 
Merc600sec's Avatar
 
Date registered: Mar 2004
Vehicle: SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Location: Leicestershire UK
Posts: 2,232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Merc600sec Send a message via Yahoo to Merc600sec
I took mine out to play with it when it stayed out for no reason, It was easy to see the switch and gear position somehow it had overeached on forward.. i just held the switch down and it retracted.. not had problem since.. worst part was getting the side panel off with the arm extended..I would recomend removal and a play about .. dont forget the control box is in the boot right hand side..

Torque isn't cheap
Merc600sec is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Electric seat belt not working on 94 Coupe fifalex W124 E,CE,D,TD Class 20 10-19-2010 11:08 AM
Seat Belt Extenders and other gremlins GR8CAR W140 S-Class 12 07-19-2009 09:59 AM
SEC seat belt extenders mikey747 W126 S,SE,SEC,SEL,SD,SDL Class 3 10-14-2007 04:06 PM
Coupe seat belt presenters gptce W124 E,CE,D,TD Class 1 12-02-2004 06:46 AM
1995 E320 Coupe Seat Belt Feeder Cover pfadvisor W124 E,CE,D,TD Class 4 02-15-2003 02:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome