PSE pump short? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-29-2007, 02:42 PM
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: 1997 E420
Location: Glendale, CA
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
PSE pump short?

Hi all, I have a question bout the PSE pump

Well it started with the car not turning on, a guy checked it out and told me when the light on the rear view mirror is red, your car isn't gonna turn on, and i remember how you had to unlock it to work (woops)....well after getting that sorted out, more problems came.

Lights in the car wouldn't turning on, you would open the door and no light, the light in the back wouldn't turn on from the switch, but the front would manually, not by the door opening. The seat could not be adjusted, and the side view mirrors cant either, nothing happens when u press the buttons

The trunk latch wouldn't come out, even though the trunk was open, and the trunk then wouldn't close but he managed to close it later, also locks wouldn't work.

So its the PSE pump from what i understand, but hes saying it somehow caused a short and made all the other stuff also not work. lol sory for the long story, but why would the pump cause those things to not work? Are side view mirrors, lights and seat adjustment all connected somehow?
AA99 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-01-2007, 02:15 AM
BenzWorld Member
 
AlexanderZwo's Avatar
 
Date registered: May 2007
Vehicle: Mercedes 300 SE (W140)
Location: West-Germany, near Cologne
Posts: 356
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If I understand you well the only thing having to do with the PSE is the trunk latch. So why are you suspicious about the PSE? Malfunction of the trunk latch can have mechanic reason and could be managed via the upper hole on this frequently shown pic :



Best regards
Hubert

300 SE, EZ 10/91, 97.000 km, Originalzustand, 4-Gang-Automatik, blau/schwarz, Leder schwarz, Sitzheizung, Klimaautomatik, ASD, Servoschließung, Schiebedach, Parameterlenkung, Becker Grand Prix, Mittelarmlehne mit Box, Wurzelholz, Colorverglasung, Einbruch- und Diebstahlwarnanlage o.I., 8-Loch LMs, Winterräder mit Originalabdeckung, original Feuerlöscher, abnehmbare Anhängerkupplung, komplette Dokumentation
AlexanderZwo is offline  
#3 (permalink) Old 07-03-2007, 05:40 PM
BenzWorld Junior Member
 
Date registered: Dec 2006
Vehicle: 1997 E420
Location: Glendale, CA
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you, but ive seen that picture, i tried it, didnt help lol

Actually i opened up the fuse box up front and saw one was tooken out, i duno if the guy was tryin to make us pay more or something by claiming the PSE pump affected some electronics

The only thing not working now is still the things having to do with PSE pump, but also the lights wont turn on when opening a door. And now the guy is saying the PSE pump provides air to the engine, thats why its working weird now. It HAS been making some more noises recently, and the car vibrates more then usual, but i didnt see anything online about the PSE pump providing air to engine.
AA99 is offline  
#4 (permalink) Old 07-04-2007, 05:04 AM
BenzWorld Elite
 
Date registered: Dec 2002
Vehicle: 92 500SEL to 01 E320T and others
Location: Florida
Posts: 3,886
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
The PSE does various things, it provides pressure and vacuum to unlock the doors, trunk and fuel filler, It provided pressure for the lumbars, and it provides "back up" vacuum for your HVAC system when the engine is not producing any. This allows you to turn on the REST system for heat when the engine is not running. This also keeps the actuators fom closing during acceleration (no vacuum). It does not provide any vacuum to the engine unless the check valve fails to the reseroir. On some cars it provides for the trunk lid handle, the back up rods, and vacuum headrest if you dont have the electric seat.
There are electrial inputs from the switches in the front door handles and trunk for key lock and unlock, there is a connector from the alarm, and a connector from the infra red remote reciever, both of those devices are behind the liner near the fuel door. I think they can pull codes, but someone with knowledge should look at it. The red light means the alarm was not sucessfully set, and it could disable the starter intercept
Peter Guenther is offline  
#5 (permalink) Old 10-28-2008, 07:55 PM
BenzWorld Junior Member
 
Date registered: Oct 2006
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'm having similiar issues with my 1999 SLK230, when my door is locked the alarm goes off. My fog lights are not going off, my interior light does not go out. I was also told it was the PSE Pump.
CarolGS is offline  
#6 (permalink) Old 10-31-2008, 11:05 AM
BenzWorld Member
 
dbottoms's Avatar
 
Date registered: Sep 2002
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
CarolGS I have some good news for you maybe. I just posted earlier today that in my 1999 SLK 230 my door locks stopped working, and car alarm went off randomly. The interior dome light also stayed on persistently. I just followed Bazzle's post on taking the PSE Pump out and cleaning it with WD-40 and a soft Toothbrush, and my door locks started working again, and car alarm stopped, although my dome light remains on. I dont mind the light as I just keep it turned off. Checkout this thread. Will save you $800 US Dollars or so with less then 45 minutes of your own time (depending on how comfortable you are with electronics.

http://www.benzworld.org/forums/r170...ml#post3134610

Take care!
Douglas

1999 SLK 230, Sport Pkg, Auto, Special Order Obsidian Black Metallic, Oyster leather, First met on August 20, 1999
<IMG src=http://home.comcast.net/~dbottoms/douglasslk2.jpg>
dbottoms is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
PUZZLER for you all....! Re: PSE Pump/What the F...! Joey6 W140 S-Class 13 11-23-2010 06:30 AM
Looking for a used PSE(A-37) vac pump sealworld R170 SLK Class 2 03-14-2007 12:34 AM
Cordless drill motor looks a lot like closing assist pump and PSE pump motor. Brett San Diego W140 S-Class 5 03-12-2007 09:35 PM
Dead PSE pump bayhas W140 S-Class 8 12-03-2006 09:05 AM
Need a little guidance on the PSE Pump. LeeChiu R170 SLK Class 1 06-26-2005 12:45 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome