1993 400SEL AC issues - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-07-2005, 07:24 AM
BenzWorld Member
 
Date registered: Feb 2005
Posts: 81
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1993 400SEL AC issues

The AC on this car cycles on and off.
I connected a gauge manifold to it and the high pressure side pressure rises and then the ac compressor clicks off. Then the pressure falls and the compressor clicks on.
Obviously some pressure switch is preventing excessive pressures on the high side

As far as I recall, the high side carries gas from compressor to the condensor to be made into liquid and then to the evaporator to be passed thru the expansion valve and be converted into gas once again-cooling the evaporator and the interior of the car in the process. The low side carries this hot gas to the compressor.

So I think something in the high side is rectricted. Could be the expansion valve or the condensor or the filter.

Anyone with similar problems?

heartmd is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W140 S-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome