The CAPTCHA cannot be displayed. This may be a configuration or server problem. You may not be able to continue. Please visit our status page for more information or to contact us.

no dash, lights,radio, console lights(1984 500SEL) - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-01-2002, 01:57 PM Thread Starter
BenzWorld Elite
 
4benzes's Avatar
 
Date registered: Aug 2002
Vehicle: 2111 GLK 2000 E320 1999 ML430,1991 SEC560,1992 300SL, 1984 190E, 1991 300E,1994 E320
Location: Cleveland
Posts: 1,343
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to 4benzes
(Thread Starter)
no dash, lights,radio, console lights(1984 500SEL)

I have a little problem with the 1984 500SEL that I just picked up. I have no dash lights,
console lights, or power to my radio?(though it lights up). I changed all the fuses last night.
I left a message for the previous owner and he sent me an e-mail about a fuse being behind
the dash. I don't know what he is talking about. is there a separate fuse for all of these? I have never sen this type of problem on my other W126's????

Cleveland.
4benzes is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-01-2002, 02:31 PM
BenzWorld Member
 
Date registered: Aug 2002
Vehicle: 2006 500SE, 1972 280SE
Posts: 345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This has always been a Benz problem


My console instrumentation and dashboard lights have always given me problems, whether in my 1972 250, or my 1983 500SEL. I can't believe MB hadn't fixed that exact same design flaw between 72 and 83!!

When you twirl and wriggle the dashboard light fader switch - the same which you use to push to reset the trip odometer - you will very likely get the lights to work.

It sometimes takes a LOT of wriggling, but be on the look out for the lights to momentarily come on. Wriggle it slow, slightly pulling or pushing on the switch.

I don't know why I keep buying Benzes... I might call this one my last. Back then, Toyotas and Hondas were pretty crappy but today, you can't argue against the facts - ULEV standards AND 240hp under the hood AND great fuel economy...

graymarket500SEL is offline  
post #3 of 3 (permalink) Old 12-01-2002, 03:59 PM Thread Starter
BenzWorld Elite
 
4benzes's Avatar
 
Date registered: Aug 2002
Vehicle: 2111 GLK 2000 E320 1999 ML430,1991 SEC560,1992 300SL, 1984 190E, 1991 300E,1994 E320
Location: Cleveland
Posts: 1,343
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to 4benzes
(Thread Starter)
Thanks grey, but no luck :-(

On the long trip home from Tenn, that was the first thing that I tried dating back to my first MB(1977 240D. Still no lights came on. Also when I opened the front passenger door, I hear something that sounds like the hazard lights going off down in the passenger footwell, behind the carpeted cover. The hazards aren't acuatlly coming on, but the sound is the same---click,click---click,click??
I will keep searching........
4benzes is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome