no dash, lights,radio, console lights(1984 500SEL) - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-01-2002, 01:57 PM   #1 (permalink)
BenzWorld Elite
 
4benzes's Avatar
 
Date registered: Aug 2002
Vehicle: 1999 ML430,1991 SEC560,1992 300SL, 1984 190E, 1991 300E,1994 E320
Location: Cleveland
Posts: 1,341
Send a message via AIM to 4benzes
no dash, lights,radio, console lights(1984 500SEL)

I have a little problem with the 1984 500SEL that I just picked up. I have no dash lights,
console lights, or power to my radio?(though it lights up). I changed all the fuses last night.
I left a message for the previous owner and he sent me an e-mail about a fuse being behind
the dash. I don't know what he is talking about. is there a separate fuse for all of these? I have never sen this type of problem on my other W126's????

Cleveland.
4benzes is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-01-2002, 02:31 PM   #2 (permalink)
BenzWorld Member
 
Date registered: Aug 2002
Vehicle: 2006 500SE, 1972 280SE
Posts: 345
This has always been a Benz problem


My console instrumentation and dashboard lights have always given me problems, whether in my 1972 250, or my 1983 500SEL. I can't believe MB hadn't fixed that exact same design flaw between 72 and 83!!

When you twirl and wriggle the dashboard light fader switch - the same which you use to push to reset the trip odometer - you will very likely get the lights to work.

It sometimes takes a LOT of wriggling, but be on the look out for the lights to momentarily come on. Wriggle it slow, slightly pulling or pushing on the switch.

I don't know why I keep buying Benzes... I might call this one my last. Back then, Toyotas and Hondas were pretty crappy but today, you can't argue against the facts - ULEV standards AND 240hp under the hood AND great fuel economy...

graymarket500SEL is offline   Reply With Quote
Old 12-01-2002, 03:59 PM   #3 (permalink)
BenzWorld Elite
 
4benzes's Avatar
 
Date registered: Aug 2002
Vehicle: 1999 ML430,1991 SEC560,1992 300SL, 1984 190E, 1991 300E,1994 E320
Location: Cleveland
Posts: 1,341
Send a message via AIM to 4benzes
Thanks grey, but no luck :-(

On the long trip home from Tenn, that was the first thing that I tried dating back to my first MB(1977 240D. Still no lights came on. Also when I opened the front passenger door, I hear something that sounds like the hazard lights going off down in the passenger footwell, behind the carpeted cover. The hazards aren't acuatlly coming on, but the sound is the same---click,click---click,click??
I will keep searching........
4benzes is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:25 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.