88' 300 SE in need of help once again... Thanks in advance - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-13-2010, 08:20 AM   #1 (permalink)
Premium Member
 
LordNikonXTC's Avatar
 
Date registered: Feb 2005
Vehicle: 1988 300 SE
Location: Charleston, South CArolina
Posts: 47
Premium Member
Send a message via AIM to LordNikonXTC Send a message via MSN to LordNikonXTC Send a message via Yahoo to LordNikonXTC
Red face 88' 300 SE in need of help once again... Thanks in advance

Hello Benz lovers, it is me once again… I have a 1988 300 SE with about 310,000 miles on it. I have a couple of weird things that have taken me for a flip. Hope you guys can help me.

1st… Transmission. It seems recently that my transmission is having difficulty shifting into forth gear. Sometimes it will not shift into forth and there was once incident where it shifted from forth to third gear. Any suggestions? I am about to do a filter and oil change but is there an underline issue that I may cake a gander at?

2nd… Usually from a cold start, there are times when the car has difficult running at idle. First start. After that it runs great. Sometimes I don’t have a problem with it at all in the morning. It starts right up. Other times it will start and give me a rough idle for a few then I am good to go. I have changed the filter, I have good pressure, what could it be?

Looking forward to the advice. If you want you could call me at 843-647-3320. Lester… thanks….
LordNikonXTC is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-13-2010, 08:16 PM   #2 (permalink)
BenzWorld Elite
 
jdc1244's Avatar
 
Date registered: Jun 2003
Vehicle: 1991 300 SE
Location: Lakeland, Florida
Posts: 18,534
Quote:
1st… Transmission. It seems recently that my transmission is having difficulty shifting into forth gear. Sometimes it will not shift into forth and there was once incident where it shifted from forth to third gear. Any suggestions? I am about to do a filter and oil change but is there an underline issue that I may cake a gander at?
The ATF and filter change may address the problem; if it persists check for vacuum leaks.

Quote:
2nd… Usually from a cold start, there are times when the car has difficult running at idle. First start. After that it runs great. Sometimes I don’t have a problem with it at all in the morning. It starts right up. Other times it will start and give me a rough idle for a few then I am good to go. I have changed the filter, I have good pressure, what could it be?
Cap/rotor, plugs/wires last changed when? Good fuel pressure or compression? How many miles on the fuel pump?
jdc1244 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Need parts 88' 190e AC2 W201 190 Class 1 10-14-2008 04:43 PM
88' 300 SEL Update ColonelRemus W126 S,SE,SEC,SEL,SD,SDL Class 6 10-08-2008 05:38 AM
88' 300 TE warning indicators DavidMichael W124 E,CE,D,TD Class 4 06-13-2007 08:03 PM
88' 300e worth it...??? vwbuge W124 E,CE,D,TD Class 7 07-12-2005 08:35 AM


All times are GMT -7. The time now is 09:49 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.