1984 500SEL broken hood release? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-16-2010, 11:58 AM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1995 C280
Location: Connecticut
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Zak62592
(Thread Starter)
1984 500SEL broken hood release?

so unfortunately this old dinosaur doesn't run as well as it should. I would like to change the spark plugs/change air filter.. but unfortunately the hood latch inside the car is gone! the only thing left is this black cable, and pulling on it with pliers does not help. Is this a common problem and is there any other way to open the hood?
Zak62592 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-16-2010, 02:01 PM
BenzWorld Extremist
 
srsomasundaram's Avatar
 
Date registered: Feb 2006
Vehicle: 1983 300SD,2002 ML500,(MBCA Member)
Location: Greater Seattle area, WA,USA
Posts: 961
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to srsomasundaram Send a message via Skype™ to srsomasundaram
Quote:
Originally Posted by Zak62592 View Post
so unfortunately this old dinosaur doesn't run as well as it should. I would like to change the spark plugs/change air filter.. but unfortunately the hood latch inside the car is gone! the only thing left is this black cable, and pulling on it with pliers does not help. Is this a common problem and is there any other way to open the hood?
I think, pulling it with nose pliers, is about the only way you can open the hood....
I have had this experience and was able to open it with a pliers.....

Good Luck!
Soma

Soma
1983 300SD (250K Miles) ==>Astral Silver on Black MB Tex;
2002 ML500 (120K Miles) ==>Silver on Black Leather Interior:Sport Pkg;


srsomasundaram is offline  
#3 (permalink) Old 04-16-2010, 06:46 PM
BenzWorld Elite
 
Date registered: Jan 2004
Location: St. Louis
Posts: 1,648
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It helps (or maybe is the only way) to pull on the steel cable while keeping the plastic sheath from moving. Obviously fix it if you get it open
NordRhein is offline  
#4 (permalink) Old 04-17-2010, 02:33 AM
BenzWorld Member
 
Hypnotismo's Avatar
 
Date registered: Feb 2010
Vehicle: Sold, in the market.
Location: Petaluma, CA
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had a similar problem. If I remember right, pliers worked... was just rediculously tough for some reason!



1994 SL500 R129 (Silver/Blue Leather) _I am really the only one that drives it anymore. --FOR SALE!

2001 E320 Estate (Silver/Ash Leather) _Mother's

1988 260E Custom Sound System, tint, and cheapy paint job, so many memories! - SOLD
1986 420SEL - RIP 1/29/11
http://www.youtube.com/watch?v=xViYiPH9R9Y
http://www.youtube.com/watch?v=cGgNhzl4fr4
Hypnotismo is offline  
#5 (permalink) Old 04-17-2010, 05:31 AM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1995 C280
Location: Connecticut
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Zak62592
(Thread Starter)
Quote:
Originally Posted by Hypnotismo View Post
I had a similar problem. If I remember right, pliers worked... was just rediculously tough for some reason!
i think i used my super powers too hard and it seemed to pull the cable even further.. hahaha

you would hear a click inside the hood when you would pull the cable but it never opened it, now that the cable is pulled out all the way, nothing is happening.
Zak62592 is offline  
#6 (permalink) Old 04-17-2010, 01:10 PM
BenzWorld Member
 
Hypnotismo's Avatar
 
Date registered: Feb 2010
Vehicle: Sold, in the market.
Location: Petaluma, CA
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Zak62592 View Post
i think i used my super powers too hard and it seemed to pull the cable even further.. hahaha

you would hear a click inside the hood when you would pull the cable but it never opened it, now that the cable is pulled out all the way, nothing is happening.
OOH thats good! when you hear that click go to the front and look at the grille. There should be a small tab sticking out of it. Pull that out a bit and hold as you use another hand to open the hood



1994 SL500 R129 (Silver/Blue Leather) _I am really the only one that drives it anymore. --FOR SALE!

2001 E320 Estate (Silver/Ash Leather) _Mother's

1988 260E Custom Sound System, tint, and cheapy paint job, so many memories! - SOLD
1986 420SEL - RIP 1/29/11
http://www.youtube.com/watch?v=xViYiPH9R9Y
http://www.youtube.com/watch?v=cGgNhzl4fr4
Hypnotismo is offline  
#7 (permalink) Old 04-24-2010, 06:24 AM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1995 C280
Location: Connecticut
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Zak62592
(Thread Starter)
Quote:
Originally Posted by Hypnotismo View Post
OOH thats good! when you hear that click go to the front and look at the grille. There should be a small tab sticking out of it. Pull that out a bit and hold as you use another hand to open the hood
I know what you mean by that... But it was like the hood was trying to open but no matter how hard i pulled, it didn't happen. i'm afraid i pulled on the plastic wire too hard and the actual cable inside the wire is somewhere in there. Is there any other way to do it??
Zak62592 is offline  
#8 (permalink) Old 04-24-2010, 10:42 AM
Premium Member
 
foolio2's Avatar
 
Date registered: Oct 2009
Vehicle: 1986 420SEL - 2001 BMW 325xiT - 2013 BMW M3
Location: Indianapolis, IN
Posts: 1,024
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Premium Member
While you are pulling the wire, have someone else pushing on the hood to see if that releases some of the tension on the cable. My hood pull handle broke off too and as other posters described, you must must pull extremely hard to open it with just the cable and pliers. That little handle really multiplies your leverage. Alternatively, that little handle is only line 7 or 8 bucks. Replace it and see if that works. Then, make sure you really lubricate the "catches" that lock the hood down. Mine is like new now after a new handle and a good lube job. I also messed with the tension nut on the cable to tighten it up a bit.

---------------------------------------------------------------------------------------------
1986 Black on Grey 420 SEL (560 Interior Swap)
1986 Smoke on Burgundy 300 SDL - SOLD

foolio2 is offline  
#9 (permalink) Old 04-26-2010, 02:12 PM
BenzWorld Member
 
Date registered: Dec 2008
Vehicle: 1995 C280
Location: Connecticut
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Zak62592
(Thread Starter)
Quote:
Originally Posted by foolio2 View Post
While you are pulling the wire, have someone else pushing on the hood to see if that releases some of the tension on the cable. My hood pull handle broke off too and as other posters described, you must must pull extremely hard to open it with just the cable and pliers. That little handle really multiplies your leverage. Alternatively, that little handle is only line 7 or 8 bucks. Replace it and see if that works. Then, make sure you really lubricate the "catches" that lock the hood down. Mine is like new now after a new handle and a good lube job. I also messed with the tension nut on the cable to tighten it up a bit.
Thanks for the advice... but like I said before.. I pulled too hard and it seemed like the cable got extended somehow, and I don't see the threaded wire that was there before anymore, and whenever I pull on the cable, nothing happens, not even a sound that sounds like the latch is trying to open
Zak62592 is offline  
#10 (permalink) Old 04-26-2010, 03:38 PM
Premium Member
 
foolio2's Avatar
 
Date registered: Oct 2009
Vehicle: 1986 420SEL - 2001 BMW 325xiT - 2013 BMW M3
Location: Indianapolis, IN
Posts: 1,024
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Premium Member
Quote:
Originally Posted by Zak62592 View Post
Thanks for the advice... but like I said before.. I pulled too hard and it seemed like the cable got extended somehow, and I don't see the threaded wire that was there before anymore, and whenever I pull on the cable, nothing happens, not even a sound that sounds like the latch is trying to open
I see what you are saying now. Maybe if you have long skinny arms you can reach up under the front bumper to release the catches by hand or with a hook of some type?

---------------------------------------------------------------------------------------------
1986 Black on Grey 420 SEL (560 Interior Swap)
1986 Smoke on Burgundy 300 SDL - SOLD

foolio2 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Hood Release Broken in 1997 SL MACSL R129 SL Class 4 01-17-2010 09:59 AM
Anyone know how to remove the hood when the release latch inside the car is broken alabbasi W126 S,SE,SEC,SEL,SD,SDL Class 4 01-16-2010 03:44 PM
Broken hood release cable Dik W123 E,CE,D,CD,TD,TE Class 2 01-12-2010 10:42 AM
Plan B for broken hood release handle texholdem W210 E-Class 2 10-18-2009 06:34 PM
Air control lamp and hood release lever both broken luiscorrea1 W210 E-Class 1 08-02-2004 04:32 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome