cold start injector - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-20-2009, 04:54 PM
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1989 560 SEL
Location: Wi ,USA
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
cold start injector

How do you check out a cold start injector to see if it is faulty? Can it be rebuidl?
Thanks
toolbender is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-20-2009, 09:49 PM
CH4S Artist
 
Teutone's Avatar
 
Date registered: Sep 2004
Vehicle: 1985 500SEC, 1991 190E 2.6, bought 07/08 with 50k original miles.
Location: Los Angeles / Hannover Germany
Posts: 28,934
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 96 Post(s)
Lifetime Premium Member
The forum archive has a wealth of information available at your finger tips.
The search function accepts 2 words of at least 3 letters.
For all available resources / forum features / 'how to' navigate the forum etc, please make sure to carefully read the 'Welcome to the Forum' announcement / tutorial sticky on top of the W126 page.
Cheers
Attached Files
File Type: pdf 073-126 Testing starting valve control.pdf (104.5 KB, 190 views)
Teutone is offline  
#3 (permalink) Old 12-21-2009, 08:16 AM
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1989 560 SEL
Location: Wi ,USA
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Teutone
Thanks for the information.
toolbender is offline  
#4 (permalink) Old 12-21-2009, 09:41 AM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: 1990 420SEL
Location: Rhode Island
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Is this what will make the car run like crap when first started? Mine runs like crap, and the vacuum gauge is a quarter way, until the it warms up. Not trying to hijack a thread, but, what the heck if it is the problem!

Life is short...USE IT!

1990 420SEL (Karl)
1999 Expedition
1995 Wrangler
jmcruz06 is offline  
#5 (permalink) Old 12-21-2009, 10:17 AM
BenzWorld Elite
 
jhodg5ck's Avatar
 
Date registered: Sep 2002
Vehicle: Depends on the day!
Location: Atlanta, GA (Lilburn)
Posts: 13,270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to jhodg5ck
No, CSI only runs for up to 45 sec IIRC.

You have another issue @ hand. Could be faulty temp sender/faulty KE...

Jonathan

Blue Ridge Mercedes/AMG East
Jonathan Hodgman
http://www.blueridgemb.com/
Enthusiast Service, Restoration & Tuning.
Authorized RENNtech Dealer & Installer
Follow Us on Facebook!
Located in the Atlanta area
05 E55 Estate
96 S600 Euro
93 300SE
92 500E Euro Track Rat
91 300CE
91 560SEC ECE
91 500SL Euro
91 560SEC 226/271
88 300E AMG
89 560SEC AMG+ SOHC 6.0L
87 Hammer Wagon 6.0L 32V
87 Hammer 6.0L 32V
86 560SEL AMG 6.0L 32V

Mercedes Repair Atlanta
jhodg5ck is offline  
#6 (permalink) Old 12-21-2009, 01:32 PM
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1989 560 SEL
Location: Wi ,USA
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Jonathan
What is a KE?
I think that I might have found the problem-oxidized pins on the temp sender & connection.
Thanks
toolbender is offline  
#7 (permalink) Old 12-21-2009, 04:04 PM
BenzWorld Junior Member
 
abumshari6's Avatar
 
Date registered: Oct 2009
Vehicle: 72 300SEL 4.5 92 500 SEL 86 300 SE 90 230 CE
Location: KSA
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Teutone
Thank you - that's a useful PDF

سبحان الله وبحمده سبحان الله العظيم

abumshari6 is offline  
#8 (permalink) Old 12-21-2009, 04:30 PM
BenzWorld Elite
 
jhodg5ck's Avatar
 
Date registered: Sep 2002
Vehicle: Depends on the day!
Location: Atlanta, GA (Lilburn)
Posts: 13,270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to jhodg5ck
KE = fuel injection computer.

Jonathan

Blue Ridge Mercedes/AMG East
Jonathan Hodgman
http://www.blueridgemb.com/
Enthusiast Service, Restoration & Tuning.
Authorized RENNtech Dealer & Installer
Follow Us on Facebook!
Located in the Atlanta area
05 E55 Estate
96 S600 Euro
93 300SE
92 500E Euro Track Rat
91 300CE
91 560SEC ECE
91 500SL Euro
91 560SEC 226/271
88 300E AMG
89 560SEC AMG+ SOHC 6.0L
87 Hammer Wagon 6.0L 32V
87 Hammer 6.0L 32V
86 560SEL AMG 6.0L 32V

Mercedes Repair Atlanta
jhodg5ck is offline  
#9 (permalink) Old 12-21-2009, 07:25 PM
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1989 560 SEL
Location: Wi ,USA
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Jonathan
That sounds $$$$
Thanks again
toolbender is offline  
#10 (permalink) Old 12-21-2009, 08:56 PM
CH4S Artist
 
Teutone's Avatar
 
Date registered: Sep 2004
Vehicle: 1985 500SEC, 1991 190E 2.6, bought 07/08 with 50k original miles.
Location: Los Angeles / Hannover Germany
Posts: 28,934
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 96 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by abumshari6 View Post
Teutone
Thank you - that's a useful PDF
Welcome to the forum.
Please click 'User CP' on the top toolbar and complete your profile with the car mod and location, to make it easier to answer your posts.

Most of the pdf are in the forum archives.
The forum archive has a wealth of information available at your finger tips.
The search function accepts 2 words of at least 3 letters.
For all available resources / forum features / 'how to' navigate the forum etc, please make sure to carefully read the 'Welcome to the Forum' announcement / tutorial sticky on top of the W126 page.
Cheers
Teutone is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Cold Start Injector ItsACrazyAsian W201 190 Class 50 10-12-2009 12:57 PM
220 se cold start injector Redpawn Vintage Mercedes-Benz 2 06-09-2009 09:08 AM
190e fuel only at cold start injector???? slaphead W201 190 Class 3 04-07-2009 08:28 PM
fuel only at cold start injector - not the rest?? slaphead W201 190 Class 13 03-16-2009 04:05 PM
If cold start valve/injector bad ... allerton W126 S,SE,SEC,SEL,SD,SDL Class 3 09-28-2006 09:07 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome