help! dash lights wont work with headlights - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-23-2009, 03:08 PM
BenzWorld Elite
 
900$sel's Avatar
 
Date registered: Apr 2009
Vehicle: 1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Location: Philly/ Charlston SC
Posts: 1,377
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation help! dash lights wont work with headlights

checked fuses 6 and 11, not the problem, all lights seem to work fine just then i turn on the head lights the cabin remains dark..

any advice would be welcome

Thanks,
Troy

]"I'm not getting into that Nazi sled." [/B]
900$sel is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-23-2009, 03:13 PM
BenzWorld Elite
 
ElRojo's Avatar
 
Date registered: Jul 2005
Vehicle: 1990 560 SEL
Location: Los Angeles
Posts: 1,854
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
First thing I'd check is the rheostat /dimmer behind the instrument cluster. These often fail with age-- you can try to rebuild it (it's not too tough), or get one from a JY car (I have a couple to spare too). Just pull the cluster and take off the dimmer from the lower left side (where the dimmer adjustment wheel is).

Best--

1990 560 SEL, 190K. Smoke silver (702) on Cream beieg leather (265). Gen 2 euro bumpers, euro headlights/turns, W140 glass moonroof, orthopedic seats, Nakamichi CD400/MBQuart 4.125 ONYX amp w/ Polk db650 rears, db1000 fronts, rear "dummy" lights activated as brake lights, 35% bronze tints.
1983 300SD, 106K. Orient Red (501) on Java MB tex (154). SOLD (and I miss ol' Hans...)
ElRojo is offline  
#3 (permalink) Old 11-23-2009, 03:47 PM
BenzWorld Member
 
SIMONVW126's Avatar
 
Date registered: Feb 2008
Vehicle: 2005 Mercedes-Benz SLK350 Sport Package, 1984 Mercedes-Benz 500sel US Spec
Location: Atlanta, Ga
Posts: 302
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Now that we are on this topic... I repacled mine with an original from another car. This one seems to be made of ceramic and has a spring.

I recently removed one from a 1991 50sel and looks more modern... it's made of metal and plastic. I don't think it has a spring.

Do these fail as much as the originals?

1984 Mercedes-Benz 500SEL US SPEC (114,000 miles)

2005 Mercedes-Benz SLK350 Sport Package (16,000 miles)
SIMONVW126 is offline  
#4 (permalink) Old 11-23-2009, 04:50 PM
BenzWorld Elite
 
mclare's Avatar
 
Date registered: Aug 2008
Vehicle: 91 560SEC AMG w/300HP Custom Built Motor; 90 560SEL Stock
Location: Lancaster, CA
Posts: 8,781
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Send a message via Yahoo to mclare Send a message via Skype™ to mclare
Quote:
Originally Posted by ElRojo View Post
First thing I'd check is the rheostat /dimmer behind the instrument cluster. These often fail with age-- you can try to rebuild it (it's not too tough), or get one from a JY car (I have a couple to spare too). Just pull the cluster and take off the dimmer from the lower left side (where the dimmer adjustment wheel is).

Best--
Dave is 100% correct here and I only want to add one thing. There are two different (at least that I have found) types of dimmers. There are Ceramic and plastic, and there is also a two pin and a three pin one. My 91 SEC has the three pin one and Mapearso's '89 and Aroundthescenes '86 had the two pin one.

I believe the plastic is the three pin, though I would need to check it again. I also have them if Dave does not have a matching one, though I am sure he does.

Current Stable:
91-560 SEC AMG - Coupe - 199/261 - 300 HP Custom Built Motor - Highly Modified Coupe
90-560 SEL - Sedan - 199/261 - Stock

mclare is offline  
#5 (permalink) Old 11-23-2009, 05:05 PM
slightly creased
 
420 SE's Avatar
 
Date registered: Sep 2005
Vehicle: 1988 420 SE; 2008 ML 500
Location: Gold Coast, QLD, AUS & Doha, Qatar
Posts: 15,710
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 10 Post(s)
Lifetime Premium Member
mclare, you are correct, plastic 3 pin, ceramic 2 pin and not easily interchangeable.

Ross

OzBenz

beware of fundamentalists

420 SE is offline  
#6 (permalink) Old 11-24-2009, 01:00 PM
BenzWorld Elite
 
900$sel's Avatar
 
Date registered: Apr 2009
Vehicle: 1988 Mercedes Benz 420SEL 258,000 miles (SOLD) 1991 300se 168,000 miles, ASR 1999 GMC Yukon 192,000
Location: Philly/ Charlston SC
Posts: 1,377
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks for the help guys just when you think you know everything about these cars you learn somthing else

i had no idea that the car even had a rheostat...

]"I'm not getting into that Nazi sled." [/B]
900$sel is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W126 S,SE,SEC,SEL,SD,SDL Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
dash lights do not work Derekb3 W123 E,CE,D,CD,TD,TE Class 8 09-20-2009 10:44 AM
2001 ML320- Dash lights come on but engine wont crank? (intermittent) tonykari W163 M-Class 5 09-03-2009 11:51 AM
Dash Lights, Tach, etc. Do not work??? Beebeeper R/C107 SL/SLC Class 9 01-06-2008 12:09 PM
Dash lights and windows don't work kburks1230 R/C107 SL/SLC Class 31 07-07-2007 07:37 AM
Reverse lights wont work help please sonhoang W208 CLK Class 1 11-24-2006 02:31 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome