Wanted - ABS Fault codes for 1992 w124 CABRIOLET 16 pin connection. - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-06-2013, 10:38 AM   #1 (permalink)
BenzWorld Member
 
Rick Dean's Avatar
 
Date registered: May 2008
Vehicle: 1993 300e 2.8
Location: America
Posts: 109
Wanted - ABS Fault codes for 1992 w124 CABRIOLET 16 pin connection.

Hello all, Looking for ABS fault codes for 1992 w124 300CE Cabriolet 051 with 16 pin connection port. My code file listed below doesn't show it. Any help would be appreciated.

Thanks, Rick

http://mbworld.org/forums/attachment...de-scanner.pdf
Rick Dean is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-06-2013, 11:24 AM   #2 (permalink)
BenzWorld Veteran
 
Date registered: Aug 2012
Vehicle: 1994 Mercedes E320 convertible 1993 Mercedes 300D 2.5 euro 1987 Mercedes 300D. 1985 Mercedes
Location: WINDY CITY
Posts: 709
Quote:
Originally Posted by Rick Dean View Post
Hello all, Looking for ABS fault codes for 1992 w124 300CE Cabriolet 051 with 16 pin connection port. My code file listed below doesn't show it. Any help would be appreciated.

Thanks, Rick

http://mbworld.org/forums/attachment...de-scanner.pdf
Is that a gray market vehicle? Cabriolet W124 was never available in that year in USA.
djakovic is online now   Reply With Quote
Old 01-06-2013, 12:06 PM   #3 (permalink)
BenzWorld Elite
 
stormtigers's Avatar
 
Date registered: Apr 2011
Vehicle: '88 "Zender" 300CE Coupe "BRUNHILDE"
Location: Melbourne Australia
Posts: 2,890
Quote:
Originally Posted by djakovic View Post
Is that a gray market vehicle? Cabriolet W124 was never available in that year in USA.

Maybe a Japanese LHD import djakovic or else a late 1992 making it the first of the cab's in the USA maybe ?

Rick what is the engine type you have - M104.980 or M104.992 ?

The reason I ask is there are some 300CE's over there that are transition models and another member had issue finding fault codes because he was mistakenly looking at the wrong engine type and the corresponding code in that instance gave a completely different issue !

The 104.980 is a 24 valve 3 litre engine produced 217 hp (162 kW) with a 7k redline (CFI system)

The 104.992 is a 24 valve 3.2 litre engine produced 217 hp (161 kW) with a 6.5k redline. (HFM system)

# Flashes PROBABLE CAUSE for Mercedes 190E & 300 series (2.6L & 3.0L) 1991 thru 1993
1 No faults in system
2 Throttle Valve Switch (full throttle contact)
3 Coolant Temperature Sensor
4 Airflow Sensor Potentiometer
5 Oxygen Sensor
6 Not Assigned
7 TNA (engine RPM signal)
8 Altitude Pressure signal from EZL Ignition Control Unit
9 Current to Electro-hydraulic Actuator
10 Throttle Valve Switch (Idle Contact)
11 Air Injection system
12 Absolute Pressure valves from EZL Ignition Control Unit
13 Intake Air Temperature signal
14 Road Speed signal at CIS-E Control Unit
15 Not assigned
16 Exhaust Gas Recirculation (EGR)
17 Oxygen Sensor signal
18 Current to Idle Speed Air Valve
19 Not Assigned
20 Not Assigned
21 Not Assigned
22 Oxygen Sensor heating current
23 Short circuit to positive in Regeneration Switchover valve circuit
24 Not Assigned
25 Short circuit to positive in Start Valve circuit
26 Short circuit to positive in Shift Point Retard circuit
27 Data exchange fault between CIS-E Control Unit and EZL Ignition Control Unit
28 Loose contact in Coolant Temperature circuit
29 Difference in Coolant Temperatures between CIS-E Control Unit and EZL Ignition Control Unit
30 Not Assigned
31 Loose contact in Intake Air Temperature circuit
32 Not Assigned
33 Not Assigned
34 Faulty Coolant Temperature signal from EZL Ignition Control Unit

So Rick confirm which engine you have for certain - it may be you have the 3l with lots of grunt and not the 3.2l.

http://www.benzworld.org/forums/w124...ml#post5491653
__________________

1988 W124 Midnight Blue CE300 (223,000 kms)
MB 'Facelift' front, S600 Grill & Zender Body Kit
Bilstein & Eibach Pro Kit Suspension (lowered)
Ergon (Italian) E 17x7.5" Wheels ET35

Nexen 5000 235/45 ZR17


Being restored : Zender "star" 16 x 8 Wheels / Pirelli P7 225/55 R16


"Only two things are infinite, the universe & stupidity - and I'm not sure about the former." - Big 'AL' Einstein

Last edited by stormtigers; 01-06-2013 at 12:10 PM.
stormtigers is offline   Reply With Quote
Old 01-06-2013, 12:25 PM   #4 (permalink)
BenzWorld Elite
 
cbc atl's Avatar
 
Date registered: Feb 2010
Vehicle: 89 300E; 00 E320
Location: Atlanta, GA
Posts: 2,340
Models............................................ .............................................. Model Years
124.026 124.030 124.050 124.090 124.051 124.230 124.290 ...........1988-95
126.024 126.025 126.035 126.039 126.045 126.134 126.135 ...........1988-91

Connect wires of Scanner as follows:
Scanner........ Data Link Connector 8-pin
Yellow........... Socket 7
Black............. Socket 1
Red............... Battery (+)

FAULT CODE TABLE
DTC Readout........Possible Cause of Failure
1 No fault found
2 In car temperature sensor, short circuit
3 In car temperature sensor, open circuit
4 Outside temperature sensor, short circuit
5 Outside temperature sensor, open circuit
6 Evaporator temperature sensor, short circuit
7 Evaporator temperature sensor, open circuit
8 Heater core temperature sensor, short-circuit
9 Heater core sensor, open
12 Engine coolant temperature sensor, short circuit
13 Engine coolant temperature sensor, open circuit
30 Coolant pump, short circuit
31 Duo valve short circuit/open
33 A/C compressor control module short circuit
34 Auxiliary fan relay faulty
50 Switchover valve unit, faulty at between pins 5 and 8 (7 connections)
51 Switchover valve unit, faulty between pins 8 and 7 (7 connections)
52 Switchover valve unit, faulty between pins 8 and 3(7 connections)
54 Switchover valve unit, faulty between pins 8 and 4 (7 connections)
55 Switchover valve unit, faulty between pins 8 and 6(7 connections)
56 Switchover valve unit, faulty between pins 8 and 2(7 connections)
57 Switchover valve unit, faulty between pins 8 and 1(7 connections)
cbc atl is offline   Reply With Quote
Old 01-06-2013, 02:00 PM   #5 (permalink)
BenzWorld Member
 
Rick Dean's Avatar
 
Date registered: May 2008
Vehicle: 1993 300e 2.8
Location: America
Posts: 109
Thanks, helping out a friend, I'll get the engine number from him and post it. Car is from the UK.
Rick Dean is offline   Reply With Quote
Old 01-06-2013, 03:39 PM   #6 (permalink)
BenzWorld Member
 
Rick Dean's Avatar
 
Date registered: May 2008
Vehicle: 1993 300e 2.8
Location: America
Posts: 109
The vehicle was built in Sindelfingen Stutgart, Germany . The engine type is M104 980. The VIN No. Is WDB 1240611B 910830

Rick

Last edited by Rick Dean; 01-06-2013 at 03:54 PM.
Rick Dean is offline   Reply With Quote
Old 01-06-2013, 05:22 PM   #7 (permalink)
BenzWorld Elite
 
stormtigers's Avatar
 
Date registered: Apr 2011
Vehicle: '88 "Zender" 300CE Coupe "BRUNHILDE"
Location: Melbourne Australia
Posts: 2,890
WDB 1240611B 910830 VIN REPORT

Wanted - ABS Fault codes for 1992 w124 CABRIOLET 16 pin connection.-wdb-1240611b-910830.jpg

ELEMENTARY MY DEAR WATSON = JUST AS I THOUGHT !
The mysterious M104.980 Engine with CFI system

Make sure you read the correct error code for that engine not the later 3.2 Litre.

Refer to my list posted earlier !
stormtigers is offline   Reply With Quote
Old 01-09-2013, 11:41 AM   #8 (permalink)
BenzWorld Member
 
Rick Dean's Avatar
 
Date registered: May 2008
Vehicle: 1993 300e 2.8
Location: America
Posts: 109
Still stumped !!!!

Wonder why I can't find the codes for this car? Surly someone has them, I've looked and looked. Looking for the ABS codes.

Hello all, Looking for ABS fault codes for 1992 w124 300CE M104.980 Cabriolet 051 with 16 pin connection port. My code file listed below doesn't show it. Any help would be appreciated.

Thanks, Rick
Rick Dean is offline   Reply With Quote
Old 01-09-2013, 01:29 PM   #9 (permalink)
BenzWorld Elite
 
stormtigers's Avatar
 
Date registered: Apr 2011
Vehicle: '88 "Zender" 300CE Coupe "BRUNHILDE"
Location: Melbourne Australia
Posts: 2,890
Quote:
Originally Posted by Rick Dean View Post
Wonder why I can't find the codes for this car? Surly someone has them, I've looked and looked. Looking for the ABS codes.

Hello all, Looking for ABS fault codes for 1992 w124 300CE M104.980 Cabriolet 051 with 16 pin connection port. My code file listed below doesn't show it. Any help would be appreciated.

Thanks, Rick
Hello is this thing on ?

Rick -I posted the codes earlier !

# Flashes PROBABLE CAUSE for Mercedes 190E & 300 series (2.6L & 3.0L) 1991 thru 1993
1 No faults in system
2 Throttle Valve Switch (full throttle contact)
3 Coolant Temperature Sensor
4 Airflow Sensor Potentiometer
5 Oxygen Sensor
6 Not Assigned
7 TNA (engine RPM signal)
8 Altitude Pressure signal from EZL Ignition Control Unit
9 Current to Electro-hydraulic Actuator
10 Throttle Valve Switch (Idle Contact)
11 Air Injection system
12 Absolute Pressure valves from EZL Ignition Control Unit
13 Intake Air Temperature signal
14 Road Speed signal at CIS-E Control Unit
15 Not assigned
16 Exhaust Gas Recirculation (EGR)
17 Oxygen Sensor signal
18 Current to Idle Speed Air Valve
19 Not Assigned
20 Not Assigned
21 Not Assigned
22 Oxygen Sensor heating current
23 Short circuit to positive in Regeneration Switchover valve circuit
24 Not Assigned
25 Short circuit to positive in Start Valve circuit
26 Short circuit to positive in Shift Point Retard circuit
27 Data exchange fault between CIS-E Control Unit and EZL Ignition Control Unit
28 Loose contact in Coolant Temperature circuit
29 Difference in Coolant Temperatures between CIS-E Control Unit and EZL Ignition Control Unit
30 Not Assigned
31 Loose contact in Intake Air Temperature circuit
32 Not Assigned
33 Not Assigned
34 Faulty Coolant Temperature signal from EZL Ignition Control Unit

What code are you missing ?
stormtigers is offline   Reply With Quote
Old 10-13-2013, 03:35 AM   #10 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 1994 E220 W124
Location: Krugersdorp, South Africa
Posts: 27
Don't know if it is still needed... But Rick Dean, you will NOT find ABS fault codes in the 16-pin connector. The ABS on a W124 is a separate system, with its own Control Unit, and is not connected in any way with the main ECU. The only thing that relates ABS with the rest of the car's electrical/electronic system is the OVP.

What is the actual problem you're having with your friend's ABS?
Sicelo is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.