1992 400E Stereo Troubles - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-04-2012, 04:38 PM   #1 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
1992 400E Stereo Troubles

The previous owner of my car had an aftermarket CD player installed.

I would like to go back to the factory radio. The installation of the aftermarket CD player was done very poorly and it appears many wires were cut.

Is it possible to harvest an entire radio + harness from another car? I have attached pictures of the current state of the wiring once the radio is removed.

Aftermarket Harness =

Rear Speakers =

Front Speakers =







Any help in getting this sorted would be much appreciated!
__________________
- Steve
1989 560SEC AMG Euro / 1990 Volvo 740 GL Wagon
cyberdyne is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-05-2012, 06:03 AM   #2 (permalink)
Lifetime Premium Member
 
Floobydust's Avatar
 
Date registered: Nov 2002
Vehicle: 2008 ML550, 2000 SL500, 1995 E320 Cabriolet, 1980 TR8
Location: Massachusetts
Posts: 584
Lifetime Premium Member
The parts you need can be had on ebay . . .

First you will need a male ISO harness connector set like this one: ISO Wire Harness Male Adapter for Car Stereo System | eBay

Next, you will need the head unit which can be had by searching ebay for something like this: Mercedes Becker Be 1480 Am FM Cassette Radio W124 | eBay , or something, perhaps more suitable, can be had directly from Becker Auto Sound at Becker Autosound Website .

Lastly, a schematic might come in handy. See attached.

Hope this helps.
__________________
Floobydust: a contemporary term derived from the archaic Latin miscellaneous, whose disputed history probably springs from Greek origins (influenced, of course by Egyptian linguists) - meaning here "a mixed bag." - National Semiconductor Audio Handbook
Floobydust is offline   Reply With Quote
Old 11-05-2012, 08:42 AM   #3 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
Thank you very much! I have purchased the radio and connector sets you linked.

I may have gone a little overboard but I ordered two of the wiring harnesses just to be sure. Overkill is underrated.
cyberdyne is offline   Reply With Quote
Old 11-05-2012, 08:36 PM   #4 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
One thought, will this head unit be compatible with the multi-speaker system in the car? I have speakers in the doors, some don't?
cyberdyne is offline   Reply With Quote
Old 11-05-2012, 09:02 PM   #5 (permalink)
BenzWorld Elite
 
meinpanzer's Avatar
 
Date registered: Aug 2010
Vehicle: 92 400E, 95 S500,91 300TE practically stole it, 97 V10 Ford E350 to tow them home from time to time
Location: Savannah, Ga
Posts: 4,486
Do you have the amp in the trunk? passenger side above the battery.
meinpanzer is offline   Reply With Quote
Old 11-06-2012, 03:34 PM   #6 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
I will pull the liner back and check later today, what should I be looking for? Do you have a picture of what it looks like?
cyberdyne is offline   Reply With Quote
Old 11-06-2012, 07:24 PM   #7 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
So I had a chance to pull the liner back and I think I just unleashed another can of worms.







cyberdyne is offline   Reply With Quote
Old 11-06-2012, 08:33 PM   #8 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
Same goes for the alarm.......this is most upsetting!



And some mystery wires just for good measure



cyberdyne is offline   Reply With Quote
Old 11-06-2012, 08:33 PM   #9 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
I should also mention the power antenna assembly is MIA as well.
cyberdyne is offline   Reply With Quote
Old 11-06-2012, 10:42 PM   #10 (permalink)
Premium Member
 
Date registered: Sep 2006
Vehicle: 1989 560SEC AMG Euro
Location: Vancouver, BC, Canada
Posts: 2,239
Premium Member
Is there any way to determine which Becker alarm unit part # I need to replace?

I see a few of various units with different part #'s on eBay.
cyberdyne is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:44 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.