1992 300E 4Matic fuel filter and fuel pumps problem - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-03-2010, 02:24 AM
BenzWorld Newbie
 
Date registered: Mar 2010
Vehicle: 1992 300E 4MATIC
Location: Los Angeles, CA USA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 1992 300E 4Matic fuel filter and fuel pumps problem

I have 1992 300E 4Matic (168,000 miles), it was sitting my father garage for the last 3 years. It startup fine, when I press on the accelerator; there is a lot of hesitation and it’s slow to accelerate. Sometimes it stalls out. So I was thinking maybe since it was sitting in the garage for three years the fuel system is probably picking up a lot of dirty fuel maybe I should replace the fuel filter.

So I started on this journey to replace the fuel filter. I had trouble taking the old filter off. It was very difficult; I think the fuel filter is the original from 1991 or 1992. I was only able to slightly move the fuel line on the “out” end of the fuel filter; I was never able to unscrew the “in” end of the fuel filter. I tried a lot twisting and turning trying to get this sucker off. I gave up on my pursuit to replace the fuel filter. I put the braces back on the fuel pumps, fuel filter and fuel accumulator. I hooked it back up under the car with the rubber hangers.

I see no visible fuel leaks. As a precaution, before I put the protective cover back on I turn the car on to check for leaks.

When I turn the car on and I look under the car at the fuel pumps and fuel filter, I see fuel spilling out (almost gushing out) so I turn the car off and the leaking (or gushing) stops. I don't even see any small leaks.

Do you have any advice on how to fix this problem and possibly how to take this stubborn fuel filter off? Or should I give up and take this problem to my local Mercedes-Benz mechanic. Trying to save money, I don’ t have a lot of money. I inherited this car from my father; this is the only thing he left me when he died so I’m trying to keep it.

Any good advice would be greatly appreciated...
smt3 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-03-2010, 08:44 AM
Lifetime Premium Member
 
augapfel's Avatar
 
Date registered: Jan 2006
Vehicle: About a dozen 1988, 1989, 1990, and 1991 sedans, wagons, and 4Matics; drivers, projects, and parts
Location: Just west of Philly
Posts: 5,281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Does the pump setup look like this:
Attached Thumbnails
Click image for larger version

Name:	P8100007.jpg
Views:	3553
Size:	76.1 KB
ID:	306081  
augapfel is offline  
#3 (permalink) Old 05-03-2010, 02:01 PM
BenzWorld Newbie
 
Date registered: Mar 2010
Vehicle: 1992 300E 4MATIC
Location: Los Angeles, CA USA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Red face It looks something like this picture Except...

Quote:
Originally Posted by augapfel View Post
Does the pump setup look like this:
It looks something like this picture except My car has two fuel pumps. Do you have any advice for my problem?

Thanks...
smt3 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1997 S500 No Fuel at Injectors (fuel pumps already replaced) dleroux W140 S-Class 11 03-24-2012 03:46 AM
300e hesitation maybe fuel pumpS Naj W124 E,CE,D,TD Class 10 11-19-2009 09:04 AM
'97 C280 Fuel Tank (leak) and Fuel Pumps marvinstockman W202 C-Class 0 11-26-2008 06:16 AM
fuel air mix / testing fuel pumps and pump pressure william.wood W126 S,SE,SEC,SEL,SD,SDL Class 0 11-09-2005 11:32 AM
How many fuel filters & pumps for 91 300E? alee4 W124 E,CE,D,TD Class 0 10-07-2002 06:40 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome