Car is decelerating while driving? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-07-2010, 06:38 PM Thread Starter
BenzWorld Member
 
mintmojito's Avatar
 
Date registered: May 2008
Vehicle: 1989 Mercedes 300E, 106500 original miles
Location: Detroit, USA
Posts: 136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Car is decelerating while driving?

Hello again everybody. I hope everyone is well. I am curious, would anyone know why my car's [300E] decelerating while I am driving? The oil was changed and everything was checked today, and it looked fine. It's been happening the past couple days. My car is also idling too low @ 5 RPM when I stop at intersections. If I give it the gas, it seems to slow down further, and then after a 1-2 minutes it goes back to normal. No noises, and nothing is tipping me off. I am stumped! Thank you for any input.


1989 willow green Mercedes 300E, with a palomino interior, and 106500 original miles!
It's name is the Mint Mojito aka "Minty"!

mintmojito is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-07-2010, 07:29 PM
BenzWorld Elite
 
94Wagenmeister's Avatar
 
Date registered: May 2005
Vehicle: 85 300 TDT
Location: The DC Burbs
Posts: 2,258
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Send a message via AIM to 94Wagenmeister
If your car is decelerating some as you take your foot off the gas peddle it is perfectly normal. This is the normal braking action of the engine, related to its compression and gear ratio. It's probably more pronounced in your MB than in your last car. If your car is decelerating while you are pressing on the gas, that's a potential problem that should get checked ASAP.

Scott in MD/DC
94 E320 Wagon
"Money can't replace it, no memory can erase it
and I know I'm never gonna find another one to compare"-LW
85 TDT (coming soon!)
past: W126, W202, W201, lotsa VDubs
94Wagenmeister is offline  
post #3 of 6 (permalink) Old 02-07-2010, 07:31 PM Thread Starter
BenzWorld Member
 
mintmojito's Avatar
 
Date registered: May 2008
Vehicle: 1989 Mercedes 300E, 106500 original miles
Location: Detroit, USA
Posts: 136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by 94Wagenmeister View Post
If your car is decelerating while you are pressing on the gas, that's a potential problem that should get checked ASAP.
Yup, it is decelerating while my foot is pressing on the gas. It's so weird.

1989 willow green Mercedes 300E, with a palomino interior, and 106500 original miles!
It's name is the Mint Mojito aka "Minty"!

mintmojito is offline  
post #4 of 6 (permalink) Old 02-08-2010, 12:05 AM
BenzWorld Extremist
 
zviratko's Avatar
 
Date registered: Jan 2007
Vehicle: W124 400E, W126 500SE
Location: Prague
Posts: 971
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
change the air filter
change the fuel filter
check if both fuel pumps are running
zviratko is offline  
post #5 of 6 (permalink) Old 02-08-2010, 06:23 AM Thread Starter
BenzWorld Member
 
mintmojito's Avatar
 
Date registered: May 2008
Vehicle: 1989 Mercedes 300E, 106500 original miles
Location: Detroit, USA
Posts: 136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by zviratko View Post
change the air filter
change the fuel filter
check if both fuel pumps are running
I will check those today, thank you so much!

1989 willow green Mercedes 300E, with a palomino interior, and 106500 original miles!
It's name is the Mint Mojito aka "Minty"!

mintmojito is offline  
post #6 of 6 (permalink) Old 02-08-2010, 07:21 PM Thread Starter
BenzWorld Member
 
mintmojito's Avatar
 
Date registered: May 2008
Vehicle: 1989 Mercedes 300E, 106500 original miles
Location: Detroit, USA
Posts: 136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Looks like that was its problem. 1 new fuel filter, and 1 new air filter. It seems to be back to its tank-like self. Thanks a lot!

1989 willow green Mercedes 300E, with a palomino interior, and 106500 original miles!
It's name is the Mint Mojito aka "Minty"!

mintmojito is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    My Car is decelerating when I drive 59 year old hunker Vintage Mercedes-Benz 1 09-10-2009 05:47 PM
    Who is Driving this car? theonlybiker111 Off-Topic 4 06-28-2009 05:11 AM
    SL 500 - Strange whirring noise when decelerating jfdi R129 SL-Class 4 02-14-2009 09:21 AM
    Intermittant grinding when decelerating/braking scotta W140 S-Class 7 02-20-2008 12:08 PM
    Single knock when acceleration/decelerating etc. slk350driver R171 SLK-Class 3 07-07-2005 12:28 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome