Rough Idle and engine hesitation/misfiring at high rpm - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-15-2005, 08:31 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2005
Vehicle: 1995 E320 Wagon
Location: New Hampshire
Posts: 18
Rough Idle and engine hesitation/misfiring at high rpm

Fantastic forum here, I have learned alot over the years. Early this summer I purchased a nice 1995 E320 Wagon, and have been quite happy with it after performing some maintainance. It has been running very nice all summer until just recently. The car sat for 9 days then about 2 weeks ago, I went to drive it, and noticed it had a very rough idle, especially noticable when sitting at a light in drive. Doesnt matter if the car is cold or warm, still misfires. I also notice that under acceleration, it is sluggish and seems to misfire. In the past, a new set of wires, plugs and rotor (older W124) did the trick. Well I spent the $105.00 and replaced the wires and figured it would cure the issue. Unfortunately the same symptoms are still happening. I pulled each plug, and they look just fine, and were new only a few thousand miles ago. I checked to make sure I was getting a spark at each cyl using an inline spark indicator tool, and every one is indicating fine spark. Any ideas out there? I am planning on making a home brew diagnostic tool to see about what codes will come up. Where can I find the code lists and the "how to use" the led tool? Any and all help is much appreciated!
__________________
1962 Studebaker Hawk GT
1986 300SDL
1991 300TE
1967 Olds Delta 88 Conv.
1979 Porsche 930 (911 Turbo)
1986.5 Porsche 928S
2001 Kawasaki ZRX 1200R
2003 F250 TurboDiesel
1985 300SD (sold)
1984 300SD (running parts car)
slingerone2002 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-16-2005, 05:23 AM   #2 (permalink)
BenzWorld Extremist
 
Date registered: May 2003
Vehicle: E320 wagon
Location: southern cal.
Posts: 953
RE: Rough Idle and engine hesitation/misfiring at high rpm

Give it a test for bad injector O-rings. Get access to the base of each injector and give it a spray /puff of carburetor cleaner at the base of each one with the engine at the lowest idle after warming up . You will get an increase of RPM at the bad Seal / O-ring .They are .88 cents a piece about 2 hours to change ,if you have metric Allen tipped sockets - in 1/4 and 3/8 drive
Normally the car will run great 1500 - 4500 RPM even with bad O-rings ,as the vacuum is greatest at low idle. I changed mine last year.
Uboater is offline   Reply With Quote
Old 11-16-2005, 11:49 AM   #3 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2005
Vehicle: 1995 E320 Wagon
Location: New Hampshire
Posts: 18
RE: Rough Idle and engine hesitation/misfiring at high rpm

Thank you for the suggestion, I will give that a shot and let you know what I come up with. I did build one of those homemade diagnostic tools, and got a few codes off it, but am not sure what they mean, maybe you or someone else could help shed some light on it, definitely would be appreciated:
When I tested Socket #14 - I got code 9 and 11
Socket# 6 - I got code 3, 4 and 8
Socket # 8 - I got code 3

Any thoughts?
slingerone2002 is offline   Reply With Quote
Old 11-16-2005, 11:51 AM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2005
Vehicle: 1995 E320 Wagon
Location: New Hampshire
Posts: 18
RE: Rough Idle and engine hesitation/misfiring at high rpm

I should also mention that at 4000 rpm, the engine just "cuts out" and will no go to any higher RPM, almost like there is a governor or something.

[:(]
slingerone2002 is offline   Reply With Quote
Old 11-17-2005, 06:06 AM   #5 (permalink)
Yal
BenzWorld Elite
 
Date registered: Sep 2004
Location: LI, New York
Posts: 2,226
RE: Rough Idle and engine hesitation/misfiring at high rpm

Crank position sensor.
Yal is offline   Reply With Quote
Old 11-18-2005, 07:32 AM   #6 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2005
Vehicle: 1995 E320 Wagon
Location: New Hampshire
Posts: 18
RE: Rough Idle and engine hesitation/misfiring at high rpm

Thanks for the suggestion...is this difficult to change?
slingerone2002 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W124 E,CE,D,TD Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:15 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.