w123 280e idle problems - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-27-2008, 01:37 AM
BenzWorld Newbie
 
Date registered: Sep 2008
Vehicle: 1980 w123 280e
Location: Johannesburg South Africa
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
w123 280e idle problems

Hi All,

I need some advice on a 280e.(K-Jetronic CIS fuel system)
Problem is when the car runs hot ie: in stop/start traffic it wont idle correctly.
It will either idle very low and or stall.I am able to restart the car easily,but it wont idle correctly.
Starting from cold is 100% but in a very hot engine it stalls.
I have replaced the following:
Fuel filter,fuel actuator,fuel pressure valve,and had CO2 level checked.

Any advice would be appreciated.
brendanmny is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-19-2009, 03:38 PM
BenzWorld Member
 
Clasico's Avatar
 
Date registered: Jan 2009
Vehicle: SLK 230K auto
Location: Madrid, Spain
Posts: 95
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Me too

I seem to have the same problem than you in a 1982 280 CE.

It was working fine until now and all of a sudden it commenced to stall at iddle but restarts again with no problem, to stall yet again. Being and auto i can´t play that easy with the gas to maintain revs at iddle so i get stuck everytime i come to a halt which in Madrid traffic is all the time.

So if it is not fuel nor battery or alternator, what it is then, any idea? I figure out some kind of regulator of some sort, but being myself pretty useless mechanically, I rather ask you for help.

Thank you guys

Life only happens once, enjoy!
Clasico is offline  
#3 (permalink) Old 10-19-2009, 03:42 PM
BenzWorld Elite
 
79Mercy's Avatar
 
Date registered: Oct 2006
Vehicle: 1979 280CE
Location: Jacksonville, Florida
Posts: 6,107
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check the vacuum hose that is connected to the warm-up reg.

'79 280CE with 226,000 miles
'76 240D 4 speed with 190,000
'85 300D Turbo with 266,000 miles


GONE but not forgotten
'76 300D with 195,300 miles
"83 300D with 174,000 miles

79Mercy is offline  
#4 (permalink) Old 10-19-2009, 03:44 PM
BenzWorld Elite
 
vipercrazy's Avatar
 
Date registered: Jan 2007
Vehicle: EURO 280CE
Location: New Haven, CT
Posts: 1,690
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to vipercrazy
this forum may have what you need already,
http://w123gassers.smfforfree2.com/index.php

but off the top off my head, does your idle control screw adjust ok? sometimes they may stick one way or not change idle at all indicating the valve needs to be cleaned/replaced.

you may need to get a CIS pressure test kit and test fuel pressures at various places

the bently manual says to always check the cold start valve first to see it works correctly, a leaking csv will cause a rough idle, it is pretty much the cheapest piece of the puzzle. cause then next is the warm up regulator, distributor and accumulator.


for sale: Car Domain 80 EURO 280CE M110.984 english red, white cloth interior 194k
daily driver: 93 toyota MR2, black 5spd non-turbo, may just have to remedy that
mopar: 62 chrysler newport 4DR white 361 V8, 36k miles
vipercrazy is offline  
#5 (permalink) Old 10-19-2009, 04:14 PM
BenzWorld Member
 
Clasico's Avatar
 
Date registered: Jan 2009
Vehicle: SLK 230K auto
Location: Madrid, Spain
Posts: 95
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks for early reply vipercrazy.

I will (my wrench rather) start from there and see if it is just that or have to follow more expensive routes.

Someone mentioned vacuum, lets hope is not that again, i have had to repair some fixtures on the vacuum lines to sort out the trans and still have to check the lines to the seats (they are not staying put). Hate the damn thing!

Life only happens once, enjoy!
Clasico is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W123 E,CE,D,CD,TD,TE Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
My W123 280E New Look! iamd General Mercedes-Benz 7 04-25-2010 02:51 PM
engine problems - W123 280E twill6464 W123 E,CE,D,CD,TD,TE Class 3 03-27-2008 09:26 PM
here's my 280E W123 1980 iamd W123 E,CE,D,CD,TD,TE Class 27 12-14-2007 08:10 AM
F/s W123 1983 MB 280E Parts Predator2 W123 E,CE,D,CD,TD,TE Class 11 08-07-2004 11:28 PM
W123 280E for sale in uk Guest (MBNZ) W123 E,CE,D,CD,TD,TE Class 0 05-23-2001 03:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome