73 450 sel. no injector pulse - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 52 (permalink) Old 12-05-2015, 03:31 PM Thread Starter
BenzWorld Junior Member
 
81sportomega's Avatar
 
Date registered: Nov 2015
Vehicle: 73 mercedes 450sel
Location: Blaine, MN
Posts: 20
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
The ecu is #0280002008
81sportomega is offline  
Sponsored Links
Advertisement
 
post #12 of 52 (permalink) Old 12-05-2015, 03:38 PM
w108,107 Parts Hoarder
 
Fonzi's Avatar
 
Date registered: Jun 2010
Vehicle: 4Keep:450slc5.0cab 280sl5sp 280se4.5 500seAMG 2sell:500sl92 380se83 300se86 350sl4sp 75slc MorInSig
Location: Philadelphia Area
Posts: 18,759
Mentioned: 27 Post(s)
Quoted: 1622 Post(s)
Lifetime Premium Member
Garage
If you can fill out your profile, there might be someone near you that has a spare ECU you could test with.

.

My signature:
Click for list of my 32 MB since 2010. If, you want 70's-80's Mercedes tuner wheels, let me know.
Fonzi is offline  
post #13 of 52 (permalink) Old 12-05-2015, 03:45 PM Thread Starter
BenzWorld Junior Member
 
81sportomega's Avatar
 
Date registered: Nov 2015
Vehicle: 73 mercedes 450sel
Location: Blaine, MN
Posts: 20
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Trying to figure out how to do anything with my profile. I can't seem to figure out how to edit.......
81sportomega is offline  
post #14 of 52 (permalink) Old 12-05-2015, 03:56 PM Thread Starter
BenzWorld Junior Member
 
81sportomega's Avatar
 
Date registered: Nov 2015
Vehicle: 73 mercedes 450sel
Location: Blaine, MN
Posts: 20
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Nevermind, I got it. Exited enhanced mobile view.
81sportomega is offline  
post #15 of 52 (permalink) Old 12-05-2015, 05:46 PM
BenzWorld Elite
 
MBGraham's Avatar
 
Date registered: Oct 2006
Vehicle: '72 350SL, '85 300D, '98 E320, '14 GLK250
Location: Ont, Canada
Posts: 7,833
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
Quote:
Originally Posted by Grubeguy View Post
The distributor doesn't activate the fuel pump. The ecu senses engine rotation and activates the fuel pump relay.
Grube - The ECU senses engine rotation by looking at the pulses from the trigger points (which are in the distributor )

81sportomega - Pump starting when you rotate distributor indicates that in part trigger points are working and that ECU has power. Do you have the distributor out when you do that? It does need to be grounded (although maybe not for trigger point signal)

An owner in the 107 forum had very similar symptoms. For a start I would check continuity or circuit resistance from ECU plug to injector pairs. If those are good (I think resistance should be about 1.3ohms) and just one pair are firing, then it looks like an ECU problem.

If you can find an ECU, ones with the Bosch number ending in 005 or 008 should work. You can have ECU's checked and repaired but it costs somewhere in $500 range. If no loaners in your area, check eBay. I have a spare 005, but being in Canada, not too practical/cost effective to ship to you.

1972 350SL 4.5L - MBGraham, near Kingston, Ontario

Last edited by MBGraham; 12-08-2015 at 07:48 AM.
MBGraham is offline  
post #16 of 52 (permalink) Old 12-05-2015, 05:55 PM
BenzWorld Extremist
 
Date registered: Sep 2012
Vehicle: 300sel W109, 280S 70 , 220s 62. 230 66. Lancia Flavia 63.Pininfarina
Location: Totteridge London.
Posts: 807
Mentioned: 0 Post(s)
Quoted: 59 Post(s)
https://oldtimer.tips/en/
Should be able to resolve the issue.
adler is offline  
post #17 of 52 (permalink) Old 12-06-2015, 09:16 AM
BenzWorld Elite
 
MBGraham's Avatar
 
Date registered: Oct 2006
Vehicle: '72 350SL, '85 300D, '98 E320, '14 GLK250
Location: Ont, Canada
Posts: 7,833
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
Quote:
Originally Posted by adler View Post
https://oldtimer.tips/en/
Should be able to resolve the issue.
There is also a lot of Djet information and help right here on on Benzworld. Mainly in R/C107 and W116 forums.

http://www.benzworld.org/forums/w116...eshooting.html

Section 07.4/5 of http://www.benzworld.org/forums/r-c1...ka-egv107.html

and engine shop manual is on-line here (look under 450SL for 1973 model year) Same engine.
Model 107

or here.

1972 350SL 4.5L - MBGraham, near Kingston, Ontario
MBGraham is offline  
post #18 of 52 (permalink) Old 12-08-2015, 07:18 AM
BenzWorld Elite
 
Grubeguy's Avatar
 
Date registered: Jan 2006
Vehicle: 73 280SE 4.5, 71 300SEL, 03 BMW Z4, 72 Fiat 850, 80 Triumph TR7, 85 Porsche 911
Location: DC Area
Posts: 2,110
Mentioned: 1 Post(s)
Quoted: 95 Post(s)
Send a message via MSN to Grubeguy Send a message via Yahoo to Grubeguy
A D-Jet ECU writeup is attached (I'm hoping this isn't the same one Adler provided - my unit blocks a lot of links).

For a really good writeup on the manifold pressure sensor, see
The Manifold Pressure Sensor as well.

This one has a good description of the temp sensor:
Temperature Sensor II

Here's a good flowchart for troubleshooting the fuel pump circuit:
Fuel pump debug - power supply to relay board

Here's a link for D-jet parts. Note that it's geared toward a Porsche 914, but Bosch sold the system to Porsche, Mercedes, Audi, Volkswagen and others.
914 D-Jetronic Parts and Troubleshooting
Attached Files
File Type: pdf D-Jet ECU.pdf (1.38 MB, 56 views)
Grubeguy is offline  
post #19 of 52 (permalink) Old 12-08-2015, 08:16 AM
w108,107 Parts Hoarder
 
Fonzi's Avatar
 
Date registered: Jun 2010
Vehicle: 4Keep:450slc5.0cab 280sl5sp 280se4.5 500seAMG 2sell:500sl92 380se83 300se86 350sl4sp 75slc MorInSig
Location: Philadelphia Area
Posts: 18,759
Mentioned: 27 Post(s)
Quoted: 1622 Post(s)
Lifetime Premium Member
Garage
I ran a CL search in your area for 69-75 Mercedes to see if there are any running parts cars that could be used for d-jet parts to swap.

The $1999 asking SLC with hardtop chopped off looks like the cheapest option locally. Who know? Maybe the seller would let you borrow some parts for a fee, or just let you buy it cheaper. http://www.benzworld.org/forums/13438001-post.html

Just using some spare d-jet parts to swap in and test might work well to determine what component is the culprit.

.

My signature:
Click for list of my 32 MB since 2010. If, you want 70's-80's Mercedes tuner wheels, let me know.
Fonzi is offline  
post #20 of 52 (permalink) Old 01-02-2016, 06:14 PM Thread Starter
BenzWorld Junior Member
 
81sportomega's Avatar
 
Date registered: Nov 2015
Vehicle: 73 mercedes 450sel
Location: Blaine, MN
Posts: 20
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Ok , it's been a while since I've been working on it. Still not running. Owner bought a reman. Ecu but that's not it. A little more reading I tested the throttle position switch. That "clicks" the injectors but the main injector pulse apparently doesn't work. So if I cycle the throttle several times it gets some gas to run for a couple seconds. I pulled the trigger points out and cleaned them but I'm starting to believe they might still be a problem.
Since the injector circuits apparently must be ok being the tps cycling activates them anyone have an idea?
81sportomega is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome