w113 280SL - Warm Running Device. - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 11-21-2015, 09:16 AM Thread Starter
BenzWorld Extremist
 
Date registered: Aug 2009
Vehicle: W107 W113
Posts: 1,010
Mentioned: 0 Post(s)
Quoted: 43 Post(s)
(Thread Starter)
Ok, thank you again.

So just to understand: you felt pressure against the inject pump internal spring when mounting the thermostat assembly onto the the pump?

Did you plunger have in/out free travel when you had the assembly outside the pump?

Thank you for helping - this is very critical, as if this isn't working properly the car will also be running in over rich condition.

Regards

R107
S320L1999 is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 11-22-2015, 06:06 PM
BenzWorld Veteran
 
Date registered: Jan 2007
Posts: 753
Mentioned: 2 Post(s)
Quoted: 85 Post(s)
So just to understand: you felt pressure against the inject pump internal spring when mounting the thermostat assembly onto the the pump? YES. IF YOU DON'T FEEL THIS WHEN YOU MOUNT THE WRD ON THE PUMP THEN YOU HAVE A PROBLEM.

Did you plunger have in/out free travel when you had the assembly outside the pump? CAN'T ANSWER THIS QUESTION BECAUSE I ONLY TOOK THE TOP PART OFF.

SORRY I CAN'T ANSWER YOUR BASIC QUESTION.

Chuck Taylor
Falls Church VA
1998 SL500
1959 220S
1970 280SL
ctaylor738 is offline  
post #13 of 13 (permalink) Old 12-05-2015, 07:16 AM Thread Starter
BenzWorld Extremist
 
Date registered: Aug 2009
Vehicle: W107 W113
Posts: 1,010
Mentioned: 0 Post(s)
Quoted: 43 Post(s)
(Thread Starter)
Hello, I installed the WRD and did the ultimate "fire test".

I let the engine run until it was at operating temperature, and then removed the WRD air filter.

It was still pulling air from the WRD - is this normal?

Thank you

R107
S320L1999 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome