1976 300D oil circulation problem on engine - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-18-2015, 10:21 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1976 300D
Location: Tabaco City, Philippines
Posts: 67
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Send a message via Yahoo to amarbenj
(Thread Starter)
1976 300D oil circulation problem on engine

i noticed the "noisy" engine one time. the oil pressure gauge on the instrument cluster is functioning. but it seems that the oil doesnt circulate anymore on the engine. i opened the hood and and remove the valve to check if the oil circulates. it seems in the negative. what went wrong?

when the oil pressure gauge on the instrument cluster is working, does it mean the oil pump is ok?

kindly help.

thanks.

amar
amarbenj is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-19-2015, 12:26 PM
BenzWorld Elite
 
Date registered: Jul 2008
Posts: 4,807
Mentioned: 4 Post(s)
Quoted: 320 Post(s)
What does the oil pressure gauge read? Does it drop? I am thinking your thrust bushing has went bad...thus the oil pump is only working sometimes...

Check out the thread I made...

Clank Clank when cold....new engine time?? - Page 2 - PeachParts Mercedes ShopForum
amarbenj likes this.

Be your own person...
DON'T....
Drink the Kool-Aid....
cooljjay is offline  
post #3 of 5 (permalink) Old 09-27-2015, 07:51 PM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1976 300D
Location: Tabaco City, Philippines
Posts: 67
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Send a message via Yahoo to amarbenj
(Thread Starter)
it actually started after that "bad hit" over a big rock that almost pressed my oil pan.
after which, oil no longer circulates on the engine. but the oil pressure gauge is functioning when i first started the engine in the morning.
i removed the oil pump and cleanse it with just a diesel fuel. i tried rotating the shaft on the top end point and it seems ok. i removed the screen and found some particles of metal on it. i reinstall it and change oil. but still, i noticed that the oil did not circulates after running it for 3-5 minutes. Worse, the engine shut off. when i restarted it, i heard a more louder noise on the engine but it no longer starts even after i change the oil.

my 1976 300D is my first car. i have no budget to replace the engine or buy a new car. If my 300D will not run, i will be depriving my family with some family travel on weekends. i really wanted to fix it. but i dont know the problem after that BIG HIT.

please help me. i really need your help. kindly give me a detailed work to do.

SALAMAT PO ASIN DIOS MABALOS SAINDO GABOS. (thank you and God Bless you all)


AMAR(Philippines)
amarbenj is offline  
post #4 of 5 (permalink) Old 09-29-2015, 12:16 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1976 300D
Location: Tabaco City, Philippines
Posts: 67
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Send a message via Yahoo to amarbenj
(Thread Starter)
Hello there!

May i request your expertise on this matter please.
Was that "big hit" already the end of my 300D?

please help me.

thanks.

amar
amarbenj is offline  
post #5 of 5 (permalink) Old 09-29-2015, 12:20 AM Thread Starter
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 1976 300D
Location: Tabaco City, Philippines
Posts: 67
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Send a message via Yahoo to amarbenj
(Thread Starter)
Hello there!

May i request your expertise on this matter please.
Was that "big hit" already the end of my 300D?

please help me.

thanks.

amar
amarbenj is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome