Odd Seatbelt Mounting Points 250SE Coupe - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-29-2015, 04:23 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2015
Vehicle: 1967 250SE Coupe
Location: Portland, Oregon
Posts: 92
Mentioned: 1 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
Odd Seatbelt Mounting Points 250SE Coupe

Hi Everyone,

I have a newly acquired '67 250SE Coupe that I'm planning to put seat belts in (currently it has none). I found the tunnel side mounts for the front seats on top of the tunnel instead of on the side like every other photo I've seen. The mounts still have the factory plugs in them, so belts have never been fitted to this car.

So is there anything odd about this? Was it a 250 only thing? The car is a Euro market vehicle if that makes any difference about the placement of the mounts.

Any info much appreciated. Thanks.
Zack



(I pulled one plug out already just to check the threads)
RedtailPDX is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-30-2015, 10:56 AM
BenzWorld Veteran
 
Date registered: Jan 2007
Posts: 753
Mentioned: 2 Post(s)
Quoted: 85 Post(s)
The EPC shows a three-part belt set with "L" brackets where the belts would attach to the floor. That looks to be consistent with what you've got in your car.

Chuck Taylor
Falls Church VA
1998 SL500
1959 220S
1970 280SL
ctaylor738 is offline  
post #3 of 7 (permalink) Old 06-30-2015, 01:34 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2015
Vehicle: 1967 250SE Coupe
Location: Portland, Oregon
Posts: 92
Mentioned: 1 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
Okay, thanks for the advice. Most mounts I have seen are down low on the tunnel instead of on top like these are, but I don't think it matters too much either way. They're clearly factory mount points.
RedtailPDX is offline  
 
post #4 of 7 (permalink) Old 07-02-2015, 11:55 AM
BenzWorld Veteran
 
Date registered: Jan 2007
Posts: 753
Mentioned: 2 Post(s)
Quoted: 85 Post(s)
If you can't find belts with the "L" attachment sewn in, try Andover Restraints. They have "L" brackets that would allow you to use belts with standard straight attachments.

I recently put belts in my Ponton, and would recommend retractable belts. Maybe belts from a 450SL?

Chuck Taylor
Falls Church VA
1998 SL500
1959 220S
1970 280SL

Last edited by ctaylor738; 07-02-2015 at 12:03 PM.
ctaylor738 is offline  
post #5 of 7 (permalink) Old 07-02-2015, 12:22 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2015
Vehicle: 1967 250SE Coupe
Location: Portland, Oregon
Posts: 92
Mentioned: 1 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
I actually have a couple color samples coming from Andover Restraints so I can match the webbing to my upholstery. I'm planning to go with retractable belts using the chrome 'aircraft' type buckle. Not yet decided on floppy end or the rigid sleeved style.
RedtailPDX is offline  
post #6 of 7 (permalink) Old 07-02-2015, 12:46 PM
Cruise Control
 
Zeitgeist's Avatar
 
Date registered: Sep 2004
Vehicle: '87 300TD/'90 300D/'94 Quattro/'89 Vanagon TDI/'01 EV Weekender VR6
Location: Cascadia
Posts: 52,132
Mentioned: 6 Post(s)
Quoted: 1633 Post(s)
Lifetime Premium Member
The 110 chassis I've been working on originally had attachment points for lap belts in the floor pan sections. I think the 110 and 111 share a lot of common configurations. There were two plastic plugs in the rear side of the tunnel, as well. I ended up welding in attachment points for the belt reel at the base of the pillar and along the frame rails.

Zeitgeist is offline  
post #7 of 7 (permalink) Old 07-02-2015, 06:59 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2015
Vehicle: 1967 250SE Coupe
Location: Portland, Oregon
Posts: 92
Mentioned: 1 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
Nice looking work there! I am planning to use the single lower mount for the reel and belt end, as is apparently standard for the coupe. Less than ideal I know, but there is not much room for an alternate arrangement.

I find it interesting that there is a hole in the sound deadening material of my car where the mounts usually are on the floor beside the transmission tunnel. I wonder if this arrangement was a euro market only arrangement.
RedtailPDX is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome