how to remove and reattach trunk emblems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-08-2015, 09:28 AM Thread Starter
BenzWorld Member
 
Kaelor's Avatar
 
Date registered: Apr 2015
Vehicle: 1970 W115 200/8
Location: Lima, Perú
Posts: 194
Mentioned: 1 Post(s)
Quoted: 24 Post(s)
(Thread Starter)
how to remove and reattach trunk emblems

So, last time I painted my trunk I covered the 200 emblem and part of the star with masking tape but it utrned out to be really time consuming and a pain in the ass (ended up cutting myself). So I gave up covering all of it and that's why my "automatic" emblem is black now lol. I want to know how to remove the trunk emblems so I can paint it the right way without having to cover them. And also how to reattach them and what to use for it? I read somewhere that they can be reattached with double sided tape but I'm not sure how accurate this information is. Since many of you here have a lot of experience with old mercs, you surely have some knowledge on the subject; way more than me that's for sure.

Is it really worth taking those out or is it just better to cover them??

Plz give me some tips on this issue
Attached Thumbnails
Click image for larger version

Name:	IMG_1210_800_600.JPG
Views:	32
Size:	86.8 KB
ID:	1476345  
Kaelor is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-08-2015, 12:11 PM
BenzWorld Elite
 
rumb's Avatar
 
Date registered: Oct 2012
Vehicle: 1968 250S, 1991 300se, 1998 SL500, 2x 1977 450SEL 6.9. Past MB's; 300SD, 300E, 300TE, 190E, ML420
Location: Colorado
Posts: 2,350
Mentioned: 5 Post(s)
Quoted: 425 Post(s)
Garage
look inside the lid, there are clips holding them on.
Kaelor likes this.
rumb is online now  
post #3 of 6 (permalink) Old 06-08-2015, 02:38 PM Thread Starter
BenzWorld Member
 
Kaelor's Avatar
 
Date registered: Apr 2015
Vehicle: 1970 W115 200/8
Location: Lima, Perú
Posts: 194
Mentioned: 1 Post(s)
Quoted: 24 Post(s)
(Thread Starter)
So that's it? only clips? so I would have to attach it back with the clips right?
Kaelor is offline  
post #4 of 6 (permalink) Old 06-08-2015, 05:38 PM
BenzWorld Member
 
Date registered: Jun 2011
Vehicle: C230 Sport, 1971 220D
Location: Cincinnati, Ohio
Posts: 54
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Kaelor,

My 1971 220d just had nuts attached to the studs on the emblem. 10mm maybe? I took mine off during waxing.

Good Luck,
Tim
Kaelor likes this.
biggreen1 is offline  
post #5 of 6 (permalink) Old 06-08-2015, 07:10 PM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: 1998 SL500, 2010 GLK 350, 1972 300SEL 4.5, 1971 280SL, 1970 300SEL 6.3
Location: Midlothian, VA
Posts: 326
Mentioned: 0 Post(s)
Quoted: 37 Post(s)
Many have push on nuts. Just use a deep socket like 4 or 5mm and push them on.
Will
Kaelor likes this.
Baybear is online now  
post #6 of 6 (permalink) Old 06-09-2015, 09:04 AM Thread Starter
BenzWorld Member
 
Kaelor's Avatar
 
Date registered: Apr 2015
Vehicle: 1970 W115 200/8
Location: Lima, Perú
Posts: 194
Mentioned: 1 Post(s)
Quoted: 24 Post(s)
(Thread Starter)
Well I guess I will have to replace those cuz they look quite rusty. Thankfully I mixed my ATF and Acetone solution to remove really rusty bolts and nuts . Let's see how it goes.
Kaelor is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Vintage Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome